bradley_lau's profile

25 Messages

 • 

324 Points

Fri, May 24, 2019 3:33 PM

Lightroom Classic: Tethering frustration with Canon 5DM3 on macOS 10.14

Im officially done with Lightroom Tethering. I am a pro photographer who will jump ship today as so many other photographers have as well. I shoot Canon and the camera connection is ALWAYS  random. It may work for a few minutes, then die in the middle of a shoot. It happens over and over again. Im the idiot for sticking with it for so long. I am done. Capture One, you now have my business. Get your #$%! together Adobe.

Responses

Employee

 • 

74 Messages

 • 

1.1K Points

2 y ago

Hi Bradley, Which version of Lightroom classic are you using? Care to share the camera model so that we can test this in-house also?

25 Messages

 • 

324 Points

2 y ago

Its CC so it updates automatically, Canon 5DM3

3 Messages

 • 

100 Points

2 y ago

I am having the same problem here in my studio. Shooting with a 5D mk3 tethered to an iMac running Lightroom CC 8.3.1. Things were working great then about 4 weeks ago LR started dropping connection with the camera. Tried several different USB cables with the same problem. Since the camera was due for a cleaning I sent it down to CPS and had them go ahead and replace the USB connection in the camera. Made no difference, LR is still dropping connection. The connection drop happens always right after capture but before it comes up on the computer. 

1.1K Messages

 • 

18.2K Points

2 y ago

Why not use the free Canon Utility? Its much better for tethering than LR anyway.