lynne_skilken's profile

10 Messages


224 Points

Wed, Oct 10, 2018 8:46 PM

Lightroom Classic: Stuck syncing photos - Error message bad argument #1 to '?' (number expected, got nil) iPad/cloud

LrCC desktop (Lightroom Classic version: 7.5 [ 1186149 ] and Windows 7 Business Edition Version: 6.1.7601) stuck syncing photos. Error message bad argument #1 to '?' (number expected, got nil) and others.  Edits (both metadata and adjustments) made on the iPad sync to the cloud and to my iPhone but not to the desktop. I've tried everything -- it is maddening and I don't want to loose the edits I've made.


20 Messages


406 Points

3 y ago

I have the same problem...a few weeks ago I deleted the file sync data on my pc, and the resynch worked......then the edits on my iPad stopped again. I did the same thing deleting the sync data file, but this time it didn’t rebuild and my pc now just locks and stops as Lightroom is eating up all my memory. I’m hoping there is an upgrade shortly - Adobe Max is nexT maybe something the meantime I have turned sync off so I can use my catalogue.

Adobe Administrator


10.2K Messages


137.2K Points

3 y ago

There is a solution mentioned on this thread: 

Can you give it a try and see if it works?
Adobe Photography Products

Quality Engineering - Customer Advocacy

3 Messages


218 Points

3 y ago

I had the same problem and step-by-step we solved it with Adobe support.What we did was the following:

  1. Created a new empty catalog and set it to sync from LR cloud. It did not complete, which meant that the data was corrupt in the cloud.
  2. Closed LR Classic, launched LR Desktop (NOT CLASSIC) and from All Photos, selected everything and deleted. Deleted also the sync file cache.
  3. At that stage I do not know if the Adobe technician reset something extra in my cloud data from Adobe. Both LR Desktop and LR in the Web at that stage, showed no photos.
  4. Launched OLD catalog which, when set to sync, showed nothing to sync. Had to re-select the folders, it re-uploaded them and from now-on it works.
DO BACKUPS before you try! Especially photos from iPad/iPhone that MASTERS are in the Cloud.

26 Messages


488 Points

3 y ago

I had the same issue..

It seemed to be localized to just photos taken with the iPhone itself.
Tried the hidden rebuild sync file option. Didn’t work. Deleted sync data on pc. Didn’t work. Unchecked all collections, deleted sync data restarted, and this was the weirdest part.
The collections that were unchecked still showed the photo files as being synced with LR CC..

I decided at this point LR CC had a photos file issue that was not talking with LR Classic photo files.

Deleted all LR CC photos and I’m waiting for the next update before I reload the collections I had issues with.

All DNG files sync just fine. In my option I suspect i’s an iOS photo file format issue.



6.6K Messages


110.1K Points

3 y ago

A long shot but testing a theory for those still having this issue... what happens if you roll back to 7.4?

Victoria Bampton a.k.a. The Lightroom Queen

Author of Adobe Lightroom Classic - The Missing FAQ and Adobe Lightroom - Edit Like a Pro books.