henry_ky's profile

5 Messages

 • 

112 Points

Sun, Nov 10, 2019 2:15 AM

Lightroom Classic: States newly imported DNG files are corrupted or damaged

After the November 2019 update, any time a DNG file from any camera is imported via card reader to Lightroom Classic, the application gives "files appear corrupted or damaged" error message.  I had to roll back to the earlier version for the error to go away.  I run LR in Mac OS Catalina with the latest update.  I have tried different card reader to read files from the Lumix and Leica cameras to no avail.  I have no problem editing my files since using the older LR version.  Anyone has the same problem?

This conversation has been merged. Please refer the main conversation:

Lightroom Classic: Freezes when importing Nikon D850 Files under Catalina

Responses

644 Messages

 • 

9.7K Points

2 y ago

NO.
I just import 24 Leica M10 images, 8 from a memory card and 16 from my hard drive and none of them show as corrupted or damaged.
It's not LR it is your Mac running Catalina. Apple at work again, It just Works, "NOT".

5 Messages

 • 

112 Points

2 y ago

Thanks for letting me know. I can wait this out until they iron out the incompatibilities.. I am happy LR gives the easy option to roll back the the older version.

Adobe Administrator

 • 

10.7K Messages

 • 

142.1K Points

2 y ago

Which camera model is experiencing the issue?

5 Messages

 • 

112 Points

2 y ago

Leica M10, Leica Q2, Panasonic GX85, and Panasonic G3.  These are all supported by LR.

3 Messages

 • 

80 Points

2 y ago

I'm having the exact same issues. Camera model is Canon 5D Mark IV. PLUS, I cannot open any of my CR2 files into Photoshop, LR, ACR, etc.

1 Message

 • 

62 Points

2 y ago

Same issue here. Can't open any files at all in Lightroom, no matter whether it is old or newly imported. Had to roll back to 8.41. Does not seem to be camera specific. My cameras are currently Sony A7R III, Sony A9. But as far as I could tell, it happens with every photo in Lightroom.

3 Messages

 • 

80 Points

2 y ago

Yes. This is the only way that I've been able to get it to work. I have rolled back my LR and PS. Finally working now.