Skip to main content
Adobe Photoshop Family

68 Messages

 • 

916 Points

Mon, May 14, 2018 2:49 PM

Closed

Acknowledged

Lightroom Classic: Sort by capture time bug

Using LR CC Classic 7.3.1.  When I import a mixture of still and video files into lightroom and attempt to sort by 'Capture Time' the .ARW (sony raw) and .mov (video) are separated, but within their file extension, they are sorted correctly by capture time.  If I edit capture time (Metadata>Edit Capture Time) and do not make any changes but select 'Change', then the file is placed in proper capture time sequence.  This behavior has been observed by others via a conversation on photo.net.

This is a difficult issue when one is shooting with two different cameras with different extensions and one wants to sort all of the captured pictures in sequence or when there is a mixture of stills and video from the same camera.

Please fix this bug

This conversation has been merged. Please refer the main conversation:

Lightroom: Metadata including dimensions and capture date for MP4 not read when THM sidecar present

Responses

Official Solution

Employee

 • 

1.7K Messages

 • 

32.4K Points

3 years ago

This should be fixed in the next Lr update.

Principal Scientist, Adobe Lightroom

Champion

 • 

5.5K Messages

 • 

97.2K Points

Merging.

Please reference the new conversation here: Lightroom Classic: Sort by capture time bug (merging)

Employee

 • 

1.7K Messages

 • 

32.4K Points

3 years ago

Please provide a downloadable link to a sample .arw and .mov files that are shot close in time. Thanks.

Principal Scientist, Adobe Lightroom

68 Messages

 • 

916 Points

3 years ago

that I have or have not adjusted

68 Messages

 • 

916 Points

3 years ago

Here is a link.  Let me know if that works for you.  There are 7 files: two ARW, followed by MP4 and THM and then two more ARW files.  They are numbered sequentially as they were taken.  The last image is a screenshoot showing the sort order with the .mp4 at the end and you can see it was sorted by capture time.

Here is the link to the files
https://www.dropbox.com/sh/rntfzwqvgcgjmin/AAD14CrJyHSi-nhWuPcvGoy9a?dl=0

Let me know when you have got them so I can delete them to conserve space.

Champion

 • 

5.5K Messages

 • 

97.2K Points

Merging.

Please reference the new conversation here: Lightroom Classic: Sort by capture time bug (merging)

68 Messages

 • 

916 Points

3 years ago

i think I need your email address for you to see the files.  Mine is saseelig@comcast.net

Employee

 • 

1.7K Messages

 • 

32.4K Points

3 years ago

Thanks. I am able to download. Please feel free to remove the link. I'll do some investigation and log bug if necessary. Thanks for the report.

Principal Scientist, Adobe Lightroom

68 Messages

 • 

916 Points

3 years ago

wow....if that is true I will have to give you a 10 star rating

Champion

 • 

5.5K Messages

 • 

97.2K Points

3 years ago

"This should be fixed in the next Lr update."

The underlying cause of this problem is that the camera has strictly followed the QuickTime/MP4 standard and recorded the capture time in QuickTime:CreateDate in UTC: 2018:05:14 17:54:43. But LR interprets that field as local time (2018:05:14 12:54:43), due to the many cameras that ignored the standard and wrote local time.

The only way for LR to know the local time of the .mp4 is to get EXIF:DateTimeOriginal from the accompany .thm sidecar.  Will the fix get the capture date from the .thm sidecar rather than the .mp4?

68 Messages

 • 

916 Points

3 years ago

Not sure whether this is relevant, but a similar problem occurs with scanned tiff images interspersed with camera taken pictures. In other words, scan some pictures as tiff and import Imp light room, then import pictures .ARW files, and then scan some more pictures as tiff. The new tiff images cluster with the older tiff files, and will come before the ARW files. In this situation there is no THM file.

Champion

 • 

5.5K Messages

 • 

97.2K Points

The .thm sidecar file isn't the cause of the problem with the .mp4 -- it's a possible solution, since it contains the correct capture date expessed in local time, while the .mp4 contains the capture date in UTC (which is what LR is currently using).

Champion

 • 

5.5K Messages

 • 

97.2K Points

Regarding your scans, a long-standing bug with photos not containing any metadata capture date (e.g. scans) was a fixed a few versions ago.  You can understand what might happening more easily by showing the capture date under thumbnails in grid view -- go to View > View Options > Cell Extras.  If you post a screenshot of the misordered thumbnails with the capture dates under them, that will make clearer what the issue might be.

68 Messages

 • 

916 Points

I have attached a screen shot of misordered ARW and MP4 files.  The date and time are correct, but the sort sequence is wrong....

68 Messages

 • 

916 Points

@ John...and here is a screenshot of a mixture of scanned (tiff) and camera pictures with the date/time showing...  the sort sequence is incorrect based on the date/time showing.  The data/time shown is accurate based on what I was doing.

Champion

 • 

5.5K Messages

 • 

97.2K Points

Likely separate bug from the main thread.

Please reference the new conversation here: Lightroom Classic: Sort by capture time bug (scans and raws)

Champion

 • 

5.5K Messages

 • 

97.2K Points

Likely separate bug from the main thread.

Please reference the new conversation here: Lightroom Classic: Sort by capture time bug (scans and raws)