Skip to main content
Adobe Photoshop Family

7 Messages

 • 

140 Points

Wed, Jan 8, 2020 2:10 PM

Lightroom Classic: Panorama Stiching - Photo Merge Error, unable to merge the photos

Hello,

after a couple of years away from photo editing, I am back and discovering the latest version of Lightroom classic, the 9.1. Last version I used was version 6.

I am bumping into an issue with Lightroom classic 9.1 and don't understand what is happening and how to solve the issue.

Basically whenever in a new catalog I am trying to merge a few pictures together as a panorama, Lightroom will be able to render the preview, but then it will drop me an error message after a while when I carry on to merging the panorama.




It doesn't depend on the number of pictures. it gave me the error with 2 pictures as well as with 16...

I was able to flawlessly stich 16 vertical pics panoramas in Lightroom 6...

I opened one of my old Lightroom 6 catalogs and was able to successfully merge several 10+ RAW files panoramas. It seems like the issue is only in new Catalogs that I create.

I shared the RAW files that are failing with other people, and they were able to successfully merge the panoramas where I am failing.

I completely uninstalled LR 9.1, didn't keep the settings, deleted all the Lightroom related folders from the system, and re-installed LR Classic version 9.1. Issue is persisting...

Here are some infos from my LR config :

Lightroom Classic version: 9.1 [ 201911291132-64cf80b4 ]

License: Creative Cloud

Language setting: en

Operating system: Windows 10 - Home Premium Edition

Version: 10.0.18363

Application architecture: x64

System architecture: x64

Logical processor count: 12

Processor speed: 3,7 GHz

Built-in memory: 32686,3 MB

Real memory available to Lightroom: 32686,3 MB

Real memory used by Lightroom: 1419,2 MB (4,3%)

Virtual memory used by Lightroom: 1868,4 MB

GDI objects count: 750

USER objects count: 2372

Process handles count: 1940

Memory cache size: 451,4MB

Internal Camera Raw version: 12.1 [ 351 ]

Maximum thread count used by Camera Raw: 5

Camera Raw SIMD optimization: SSE2,AVX,AVX2

Camera Raw virtual memory: 494MB / 16343MB (3%)

Camera Raw real memory: 495MB / 32686MB (1%)

System DPI setting: 144 DPI (high DPI mode)

Desktop composition enabled: Yes

Displays: 1) 3840x2160

Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No



Graphics Processor Info: 

DirectX: NVIDIA GeForce RTX 2060 SUPER (26.21.14.4112)







Application folder: C:\Program Files\Adobe\Adobe Lightroom Classic

Library Path: C:\Users\xxx\OneDrive\Images\divers\divers-2-2.lrcat

Settings Folder: C:\Users\xxx\AppData\Roaming\Adobe\Lightroom



Installed Plugins: 

1) AdobeStock

2) Facebook

3) Flickr

4) Nikon Tether Plugin



Anybody has an idea of what is happening ?

Responses

Adobe Administrator

 • 

8.1K Messages

 • 

116.9K Points

9 months ago

Me,

Try resetting your preference file:

A Preference File will survive a Lightroom uninstall/reinstall. Sometimes weird behavior is corrected/cured by resetting the preferences.

Reset Procedure:
1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom.
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.Does the behavior continue after resetting the preferences?
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

7 Messages

 • 

140 Points

Is there a way I could back up my preferences before doing this ? Like I said in my post, I am pretty sure I already reset my preferences when uninstalling Lightroom and deleting all the Lightroom folders in program files\adobe and in Appdata\roaming and local.
I spent some time setting everything back again, so I'd like to back settings up before doing what you suggested, just in case :)

Thanks in advance

Champion

 • 

5.8K Messages

 • 

102.3K Points

Yes, the manual option here will work: How do I reset Lightroom’s Preferences?

7 Messages

 • 

140 Points

9 months ago

Hi Rikk, Hi Victoria,
I renamed my "Lightroom Classic CC 7 Preferences.agprefs" preference file instead of getting it deleted, it rebuild a new one and sadly the behavior is still there.
Tried to create a new catalog and import new RAW files I recently shot, and the result is still the same :(
"unable to merge the photos" exactly as in the screenshot of my 1st post.

Heeeeeelp, this is a brand new computer with a fresh install of windows and lightroom...

7 Messages

 • 

140 Points

9 months ago

I actually just tried to stitch a panorama with horizontal photos instead of vertical ones, and it worked. Looks like the issue occurs with panoramas based on vertical frames ?

Will have to experiment a bit more to confirm this 100%

Employee

 • 

32 Messages

 • 

434 Points

Hello, are you trying to stitch vertical images (shot in portrait mode) into a horizontal or a vertical image? 

7 Messages

 • 

140 Points

Hi, a series of portrait shot images into a horizontal panorama

3 Messages

 • 

82 Points

8 months ago

I'm getting the same problem. So frustrating. 
Even photoshop is unable to stitch. The preview generated on Lightroom is perfect - exactly what I need but when I click merge, it comes "Unable to Merge" after a minute or so. Please help. 

3 Messages

 • 

82 Points

8 months ago

Hey ok so i just resolved the issue. What I did was, I went to Preferences and just clicked on "Purge Cache" under the "Performance" tab - and it seemed to do the trick. Apparently there wasn't enough space on my C drive for this operation to happen - if that's what it requires. 

Hope it helps whoever requires it. 

8 Messages

 • 

140 Points

3 months ago

I'm having a similar problem. It affects all my attempts to merge either panoramas or HDR. I was getting the same error message, but then it just started locking my computer completely so I have to reboot. I just tried clearing my cache as suggested and it made no difference. This is driving me mad!

7 Messages

 • 

140 Points

Issue still hasn't solved for me :(

Adobe Administrator

 • 

8.1K Messages

 • 

116.9K Points

Have you installed Windows 10 2004 yet? 
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

7 Messages

 • 

140 Points

nope, it's not yet showing available on my computer