Skip to main content
Adobe Photoshop Family

1 Message

 • 

110 Points

Wed, Sep 27, 2017 4:53 AM

Solved

Lightroom Classic: Non-alphabetical order of external editing presets (macOS High Sierra)

I have quite a few Lightroom external editing presets. These were always displayed in alphabetical order in the "Edit In" dialogue box but I noticed that, post upgrade to Mac OS High Sierra, the order seems to have become random. I tried deleting and re-creating but the issue persists. Not the most serious problem in the world but a workflow nuisance. I have reverted to the previous OS with the hope that a later release from either Abobe or Apple will address the issue.

Responses

Official Solution

Adobe Administrator

 • 

498 Messages

 • 

9.6K Points

3 years ago

We have provided a partial fix for this issue, which got introduced by MacOS High Sierra. This should work if the Preset file is present in the Preset folder.

Thanks,
Sunil

14 Messages

 • 

200 Points

Can you please explain what you mean by the Preset file being present in the Preset folder? I'm not clear on what the "partial fix" is that you are referring to. I have several presets for my watermarks, and it takes me forever now to locate the one I need, because they all are named similarly and not in the proper order.  (I used LR 5.7). Thanks.

Champion

 • 

5K Messages

 • 

91.8K Points

I think this may be permanently broken now in LR 5.7 running on MacOS 10.13 (High Sierra).  Evidently, something in 10.13 changed and broke how LR sorts presets, and LR needed to be changed as a result. 

Since Adobe almost never releases updates to older versions, your only options are to live with the problem or upgrade to LR 6.13 (not free) or LR 7 (Classic, not free).   The option to upgrade LR 6.13 is still available but presumably will go away soon (since 6.13 is the last update for LR 6).  

14 Messages

 • 

200 Points

Well that sucks.  But if it really is worth it, I don't mind upgrading and even going to CC version, to have the ongoing support and updates. But I am terrified of upgrading and causing further glitches. I wish soooo badly someone could just sit beside me and help me on my computer.  I'm having nasty website glitches, software glitches, a part broke on my Canon 5DM3, and my fairly new MacBook Pro retina display is losing its finish in different parts of my screen.  Some good news and vibes sure would be nice....

I don't know if 6.13 is glitch-free (I'm experiencing other issues with the High Sierra update, and the presets not being in alphabetical order is minor in comparison to the other problems).... so I am hesitant....

11 Messages

 • 

168 Points

3 years ago

Hi Nick,

Thanks for reporting this issue. Please provide screenshots for the same , also lets us know your Lightroom version.

Thanks,
Ruby

 

15 Messages

 • 

330 Points

3 years ago

There are more Bugs with the alphabetical order, in various presets.


Champion

 • 

3K Messages

 • 

55.6K Points

3 years ago

Yes, I can confirm this. When you add a preset the problem seems to have gone, but after a Lightroom restart it is back again.

Johan W. Elzenga,

http://www.johanfoto.com

Adobe Administrator

 • 

498 Messages

 • 

9.6K Points

3 years ago

Thanks for bringing up this.
We are working on it.

Thanks,
Sunil

Champion

 • 

5K Messages

 • 

91.8K Points

3 years ago

4 Messages

 • 

112 Points

3 years ago

I have this issue also. I have a number of preset watermarks (eg. bottom left, bottom right, light or dark versions etc) for easy pre-positioning on photo's plus some various club logo's, and I find it extremely frustrating that every time I open LR the list is jumbled - that is NON alphabetical. Each time I need to make a slight adjustment to a rarely used wm and save it, only  then the order is restored. UNTIL the next time I open LR. Considering cancelling my PS/LR subscription and using open source like GIMP !!!!

Champion

 • 

5K Messages

 • 

91.8K Points

Please do Help > System Info and report the exact version of LR and Mac / Windows.

14 Messages

 • 

200 Points

Sid, i'm guessing you m night have LR5.... is that right? I think that is the only reason why I am continuing to experience this frustrating problem (you'll see that John R. Ellis commented on that above in the string). LR and PS also continuously crash on me, and it is beyond frustrating. I'm too afraid to upgrade to the last stand alone version that LR made, as I have no experience with loading new versions, and I'm nervous to do so!

833 Messages

 • 

13.1K Points

3 years ago

Hello, for these alphabetical stories pay attention, the sort is the following, we start with the titles whose first letter is an uppercase, then those are starting with the lower case. So always start your titles either with a capital letter, or a lowercase letter, but do not mix them, they will follow logically!

833 Messages

 • 

13.1K Points

3 years ago

Hello, for these alphabetical stories play attention, the sort is the following, we start with the titles whose first letter is an uppercase, then those are starting with the lower case. So always start your titles either with a capital letter, or a lowercase letter, but do not mix them, they will follow logically!

4 Messages

 • 

112 Points

3 years ago

Pay attention....  capital or lower case or numerical doesnt work!

833 Messages

 • 

13.1K Points

3 years ago

LR Classic 7.1 High Sierra 10.13.3

Develop presets, Where is the problem ?

Champion

 • 

5K Messages

 • 

91.8K Points

As your screenshot shows, LR retains spaces at the beginning of preset names.  When sorting strings, nearly all applications follow the convention that space comes before letters and digits, so that's why " Reset Grain" comes before the other presets. 

Whether it's desirable for LR to retain spaces at the beginning of preset names is a separate question.

Adobe Administrator

 • 

498 Messages

 • 

9.6K Points

3 years ago

Sid,
Could you please post a screen shot?

Thanks,
Sunil

4 Messages

 • 

112 Points

3 years ago

Lightroom version: CC 2015.6.1 License: Creative Cloud
Operating system: Mac OS 10
Version: 10.13 [3]


ALL Capitals starting each preset version but jumbled


So after I modifiy and save any preset, all are in correct alphabetical order as per below

Champion

 • 

5K Messages

 • 

91.8K Points

Sid, you're still on an old version, CC 2015.6.1.  The latest version of CC 2015 is 2015.14.  You're also eligible to upgrade to LR Classic 7.2.  Either one should fix the problem, I believe.

Champion

 • 

5K Messages

 • 

91.8K Points

Do Help > Updates to start the update process.

4 Messages

 • 

112 Points

Thank you for your help John, much appreciated. I had previously contacted and was told I would have to purchase if I wanted the latest version. Have gone upgrade as you suggested and appears to be resolved. Again thank you.

Champion

 • 

5K Messages

 • 

91.8K Points

Glad you got it resolved.

14 Messages

 • 

200 Points

3 years ago

yikes! And I thought the problem was you might be using LR5, which I thought was the reason I was having this problem! I was going to buy the LR6 as the last downloadable, stand-alone version ONLY BECAUSE I am having this problem..... but you're not even using LR5.  I am afraid this problem will continue on afterwards if I buy LR6, and it drives me nuts!   (Same thing happens to me after I modify a preset, everything goes in order, I never noticed that before).