Skip to main content
Adobe Photoshop Family

9 Messages

 • 

162 Points

Mon, Nov 19, 2018 6:53 PM

Solved

Lightroom Classic: Need help repairing a corrupted Catalog

Have reinstalled by computer (Win 10, 64) and upgraded Lightroom to release 8.0. Now I cannot access my catalog.
LR says it is corrupted, but if I try to repair it does not work.





And to make it worse, if I try to restore the catalog from a backup this also fails.

Responses

67 Messages

 • 

1.4K Points

2 years ago

Are you absolutely sure that you are starting Classic CC 8.0?
Have you tried to install the version you used until your upgrade?
Before you tried to restore from backup, did you unzip the catalog backup?
Also, check this: https://feedback.photoshop.com/photoshop_family/topics/lr-catalog-can-not-open-wont-repair-and-can-n...

Adobe Administrator

 • 

505 Messages

 • 

9.6K Points

2 years ago

Please let us know if the problem persists.
I have sent you an email off list for more details.

Thanks,
Sunil

9 Messages

 • 

162 Points

Sunil did you get my email and the transfer with the catalog?

9 Messages

 • 

162 Points

2 years ago

I have recieved your mail and will look into it later today - when I'm at the computer again!
Thank you so much for replying!

28 Messages

 • 

440 Points

2 years ago

I think I may be having a similar problem.  I am dead in the water with Mavericks and Lightroom Classic 8.0.  See this thread. https://feedback.photoshop.com/photoshop_family/topics/catalog-compatibility-mavericks-vs-high-sierr...

I started with catalogs created with Lightroom Classic CC 7.<something> on Mavericks. After upgrading to Lightroom Classic CC 8, none of my catalogs are readable. There are two types of failure: Warnings of a corrupt catalog, and Lightroom never gets past the splash screen. At this point the only idea I have is to find out how to revert Lightroom Classic CC to version 7.<something> and see what happens. Any other suggestions?

I have a machine running Lightroom Classic CC 8.0 with Mac OS 10.13.6 and everything seems fine.

28 Messages

 • 

440 Points

Sorry, not Mavericks, Mojave, the other M word.  Mac OS 12.14.1 is the OS where I am having a problem.

Adobe Administrator

 • 

8.2K Messages

 • 

117.6K Points

2 years ago

"At this point the only idea I have is to find out how to revert Lightroom Classic CC to version 7"

Unlike previous upgrades to the Lightroom major version, there was no catalog change between version 7 and version 8. The same catalog is operable in version 7.x and version 8.x. 

Corruption of catalogs is most commonly linked to hardware failures or a synced storage location. If you are not storing your catalog in a syncing location (Dropbox or similar) then it would be a good idea to test your hard drive. 
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

28 Messages

 • 

440 Points

Rikk,

Thanks for the information.

I have resolved the problem by rolling back to 7.5 and restoring my .lrcat files from offline backup.

When I was trying and failing with Lightroom 8, I tried multiple .lrcat files stored on 3 different local drives. No synced storage, no network storage. Only traditional local file systems (2 USB-C portable SSD, 1 Thunderbolt 2 RAID). In all cases Lightroom 8 failed to read. In (at least) 2 cases Lightroom 8 trashed the .lrcat files. After rolling back to 7.5 and restoring from backups everything is great, so I strongly doubt there are hardware issues with 3 of my storage systems. Two of the 3 passed total surface checks 2 months ago and have seen little use since then, further adding to my doubts about this theory.

I am up and running, but I do not anticipate attempting the upgrade to version 8 for many months.