Skip to main content
Adobe Photoshop Family

158 Messages

 • 

2.5K Points

Thu, Jul 25, 2019 1:26 AM

Lightroom Classic: Map not showing pictures in correct location

Map Module not showing photographs in correct GPS location. Thought it was my 7D Mark II GPS, Photos seem scattered all around map when they are taken at same location. but when I take a picture with Cell phone to compare it too displays in wrong location. could it be a issue in LR? or something wrong with devices?  Im sure the exact spot can not be given due to military requirements.  But again with locations scattered seems odd.  anyone else have this issue?

Responses

Champion

 • 

5K Messages

 • 

91.6K Points

a year ago

GPS receivers can often have errors of up to 50’ (15 m). Are you seeing larger distances between photos taken at the same location?

158 Messages

 • 

2.5K Points

a year ago

yes. example I am at a outdoor Rodeo arena. and I am in one center location. But the pin flag shows up all around the arena. in place that I dont even stand at greater than 50'.

Employee

 • 

291 Messages

 • 

7.8K Points

a year ago

Ronald, could you check what are the GPS cordinates embeded in the images? Is the embedded GPS data same as that you are seeing in LrClassic or different? LrClassic would place the images on map based on the GPS data.

Champion

 • 

5K Messages

 • 

91.6K Points

a year ago

Upload a couple sample photos to Dropbox or similar and post the sharing link here. We can test whether our LRs are correctly placing the photos on the map based on the GPS coordinates embedded in the photos. Most likely, what you're seeing is due to the GPS coordinates that were embedded in the photos by the camera, but we can verify that.

158 Messages

 • 

2.5K Points

a year ago

I will work to upload picture(s) but I did a compare.  checking LR Classic for a photo the GPS coords display were:  40 11 58.223N  75 47 19.835W   but when I view in Acdsee I see 40.11 58 224000N 75 47.836000W   (the photo location is at HopewelL Lake in Birdsboro PA. Not sure about how the two software products interpet the GPS data.   I tired using the Canon GPS utility but it truncates displayed data.  Anyone recomend a good software to view data?

Champion

 • 

5K Messages

 • 

91.6K Points

a year ago

Note that the coordinates displayed by LR differ by 0.001 of 1 second of latitude/longitude from those displayed by Acdsee, which is approximately 3 cm. (It appears that one of the programs is incorrectly rounding.) This minor discrepancy wouldn’t account for the big differences you’re observing.

158 Messages

 • 

2.5K Points

a year ago

I have taken another 2100 photographs tonight and when I see them on LR MAP here is the layout I get. Note I was standing in the gate where the 327 photos are taken I did NOT move from that spot for 2 hrs. I will say I was shooting thru the fence (Metal).

Champion

 • 

5K Messages

 • 

91.6K Points

I'm guessing the truck in the upper center is about 20' long. That would put all of the pins within about 50' of the red X shown below:



So it's likely that you're observing normal GPS errors. 

The Canon 7D Mark II is five years old, and inexpensive GPS units have improved considerably since then. You could get significantly better accuracy with a separate GPS logger that uses WAAS. You'd then use LR to tag your photos with GPS coordinates using track logs produced by the logger.

158 Messages

 • 

2.5K Points

a year ago

Hello, I went back and took New pictures. this time I used my Garmin GPSmap 62s Gps data. the location data while a smaller sample was more accurate. I will keep trying. I guess I had hoped that the GPS in the camera was a little more accurate.  Hate the idea the camera has this feature. but is not that accurate. 

Champion

 • 

5K Messages

 • 

91.6K Points

Garmin claims accuracy of less than 33' (10 m) for the 62s, and less than 10 to 16' (3 - 5 m) when you've enabled WAAS. I observe better than 10' accuracy with my 64st.