Skip to main content
Adobe Photoshop Family

10 Messages

 • 

606 Points

Tue, Dec 18, 2018 1:13 PM

Lightroom Classic: Mac Mojave is hanging several miuntes in import module (importing SD-Card)

I am using the most current version of Lightroom Classic CC and the most current version of MacOS Mojave.
When trying to import my SD-Card after a shooting lightroom ist showing the import module after inserting the SD-Card.
But the it is painfully slow an hanging... hardly can scroll the pictures to select them - just sowing the spinning beachball for minutes...
After several minutes importing itself is as fast as I am used to.

I am having the same problem either with miy 2013 MacPro (USB3 Cardreader - which worked fine with LR Classic 7) - or my MacBook pro with internal USB3 Cardreader.

When copying the photos from the SD-Card to the desktop and then importing them it works as suggested.

Any clue what to do?

Responses

294 Messages

 • 

4.5K Points

2 years ago

Do as you suggested: "...copying the photos from the SD-Card to the desktop and then importing them it works as suggested."

I never import directly from memory cards; everything goes to a pair of mirrored G-Tech 20TB RAID drives and from there to either Photo Mechanic or Lightroom.

You're not experiencing a bug with Lightroom; you're running into the duty cycle limitations of memory cards.

564 Messages

 • 

11.9K Points

2 years ago

I’ve been having the same issues as you Guido but on a Windows machine. And as you said, it worked fine previously.

20 Messages

 • 

474 Points

2 years ago

Not sure if you have your desktop backing up to iCloud but I suspect it has something to do with how Mojave and iCloud relate to each other.  Just a theory.  Since upgrading to Mojave I've had issues downloading images to a folder on my desktop.  I drag images and I get a spinning beachball for what can go up to a minute or two before images download.  I have less issues if I drag images into a folder in a pictures folder directly on the drive that is not backing up to iCloud.  Would love to know if anyone has a fix for this besides disabling iCloud.

10 Messages

 • 

606 Points

2 years ago

Well yesterday I tried to import around 250 photos I copied to my desktop first.
This also took painfully long... (usig the "moving" function for importing)

I now have seen, that the first time I tested improting from Desktop just "adding" was selected and due to the smart previews I did not recognice that the photos aren ́t there anymore after deleting that folder from my desktop.

@charles: I am not syncing my "pictures" with iCloud - but I am syncing it with the "Drive" app on my Synology NAS.
If there is a problem I would expect a slow importing itself - but just browsing the source is taking a very long time.