Skip to main content
Adobe Photoshop Family

11 Messages

 • 

222 Points

Tue, Oct 8, 2019 11:10 PM

Lightroom Classic: Losing Library order after "Edit in Layer in Photoshop" Save

I think I have found an "odd behavior" in LR (i use the latest release of August)
I organize the Library > by Capture Time
When in the Development room i pick 2 images and Edit > as layer in Photoshop
do the PS editing and flatten the layers (CTRL-SHIFT-E) and Save, then return to LR classic the save image is not organize by CAPTURE time but saved as a last image in CUSTOM ORDER.
This is annoying and keeping the SORT by in Library would be better

Responses

799 Messages

 • 

11.5K Points

a year ago

You are not alone! At least we know when it happens we just need to go to Sort and back to Capture Time, but it’s annoying!

11 Messages

 • 

222 Points

a year ago

Yes indeed but each time i wonder why the image does not appear ... then after some delay go and find it.

799 Messages

 • 

11.5K Points

a year ago

It’s usually at the very bottom of your folder!

Adobe Administrator

 • 

508 Messages

 • 

9.7K Points

a year ago

Thanks for the feedback.
We are investigating.

Thanks,
Sunil

Champion

 • 

5.3K Messages

 • 

95.7K Points

a year ago

Make sure File > Library Filters > Lock Filters is unchecked. Does the problem still occur?

799 Messages

 • 

11.5K Points

a year ago

What does "Lock Filters" mean? What is being locked?

799 Messages

 • 

11.5K Points

Yes, mine said "Locked".

Champion

 • 

5.9K Messages

 • 

104K Points

Lock Filters means when you move from one folder to another, the filters will stay enabled.

Victoria Bampton a.k.a. The Lightroom Queen

www.lightroomqueen.com

Author of Adobe Lightroom Classic - The Missing FAQ and Adobe Lightroom - Edit Like a Pro books.

Champion

 • 

5.3K Messages

 • 

95.7K Points

Lock Filters also keeps the filters enabled and unchanged after you do a Photo Merge or do an export with the exported photos automatically added to the catalog (otherwise LR resets the filters).

I've seen anomalies in the past where locking the filters stopped changes to sort order.

Champion

 • 

5.3K Messages

 • 

95.7K Points

a year ago

Philippe, if locking filters doesn't solve the problem, could you provide a full-resolution screen recording of the entire LR window showing the problem?  Sometimes that gives valuable troubleshooting clues and can help Adobe reproduce the problem.

11 Messages

 • 

222 Points

a year ago

Not too sure how to "lock the filter" You have a link for me to learn about this ?

Champion

 • 

5.3K Messages

 • 

95.7K Points

Do the menu command File > Library Filters -- is the submenu item "Lock Filters" checked or unchecked?  If it's unchecked, then select the item Lock Filters to check it.

799 Messages

 • 

11.5K Points

Confused! Mine was "Checked", and my sort order was changed occasionally. I just unchecked it, and I've done some Nik/Edit In exports and so far no problems (but then it was never a daily thing, maybe once a fortenight).

11 Messages

 • 

222 Points

a year ago

It was on "checked"

Champion

 • 

5.3K Messages

 • 

95.7K Points

...so not related to your problem.

11 Messages

 • 

222 Points

a year ago

Indeed. This is not a critical issue, just a odd behavior for possible streamlining in a future release. It si the  same issue as the losing the filter setup after a CTRL- M panorama.