Skip to main content
Adobe Photoshop Family

30 Messages

 • 

652 Points

Mon, Apr 9, 2018 6:38 AM

Lightroom Classic: Latest update running very slow

I’ve just updated to the latest version of Lr CC Classic on my 2015 MacBook Pro Retina (2.5 GHz i7, 16gb Ram, 512gb SSD, Intel Iris Pro 1536 mb) and after importing images, it’s taking a long time to scroll through the pics and have the spinning beach ball every 3-5 photos. Images are .jpg off a Nikon D4s. It’s driving me mad!!!Has anyone got any thoughts please? New computer time?Thanks

Responses

Champion

 • 

6.2K Messages

 • 

106.2K Points

3 years ago

That does sound frustrating Jon. What kind of previews are you building when you're importing the photos, has it finished building those previews, and which module are you looking through the photos in?

Victoria Bampton a.k.a. The Lightroom Queen

www.lightroomqueen.com

Author of Adobe Lightroom Classic - The Missing FAQ and Adobe Lightroom - Edit Like a Pro books.

4 Messages

 • 

142 Points

3 years ago

Not time for a new computer.  Time for a new photo-editing program.  Because of problems like this with Lightroom, I've switched to On 1 Photo and have never looked back.

30 Messages

 • 

652 Points

The trouble is I know Lr really well and the export section is a lifesaver. I really don’t fancy changing software

30 Messages

 • 

652 Points

3 years ago

Previews are Standard and I only have one folder with 4000 images. Scrolling through is taking forever!! After 5-10 photos the spinning wheel starts again.

2 Messages

 • 

70 Points

3 years ago

I have the same problem. every couple of pictures I get the spinning wheel. I haven't changed previews settings, and before Classic 7.3 it run great... I wish I could downgrade to Classic 7.2.

33 Messages

 • 

502 Points

Hi Marco,

If you haven't already worked it out...

You can go back to 7.2. If you go to the Creative Cloud menu (top toolbar) when you see the Lightroom Open icon there's an arrow (dropdown menu) to the right that allows you to install previous versions.

I am having similar issues with 7.3 and 7.4. The 7.2 version appears to run a little better.

Hope that helps, regards, Harvey

1 Message

 • 

60 Points

3 years ago

Same here its so bad, Im about to bail I can't get anything done with the kind of slow down

33 Messages

 • 

502 Points

3 years ago

Hi Lawton, I'm in the same boat with you... have you been able to get any improvement in LR performance over the past few weeks?

Regards,

Harvey