Skip to main content
Adobe Photoshop Family

3 Messages

 • 

94 Points

Wed, Dec 20, 2017 12:30 AM

Lightroom Classic: Importing from catalog loses edits

I'm trying to export photos from one catalog, and import them into another one.

As a test, I tried exporting just one photo to a new catalog using "export as catalog", which works fine. But when I try to import the exported photo to a third new catalog using "import from another catalog", the photo is imported but all the edits (e.g. cropping) are lost. 

To ensure it was a simple test, all the test catalogs are on the same computer (an iMac) and I was using the same Lightroom version (classic CC) throughout. 

What am I doing wrong? I don't see any import settings that I could choose, even if I wanted to.

Thanks in anticipation,

RM

Responses

1.9K Messages

 • 

22.8K Points

3 years ago

Got 'Auto save XMP' on? 
Try selecting the images you wish to export to the new catalog. Type command (control) S key. Try Export as Catalog again, then import as Catalog. Better? 

Author “Color Management for Photographers"

3 Messages

 • 

94 Points

Thanks, problem solved! I'm amazed I've managed to use Lightroom for over five years without ever having had to learn that. You're most kind.

RM

100 Messages

 • 

1.8K Points

I would call this a workaround, not a fix.
I do this regularly (and I've just tested with version 7.1), importing from a catalog allways imports all settings for the image, even when I've not generated the XMP files.
Therefore, I think there is something broken on your machine.

Champion

 • 

3.3K Messages

 • 

58.1K Points

Agreed. This may have worked, but it should not have been necessary. The whole idea about exporting/importing as catalog is that a catalog contains the edits, so it's the method of choice to bring over such edits. If they don't come over unless you write the edits to XMP as well, then something is wrong.

Were these new images or existing ones? If you import a catalog with images that are already present in the main catalog as well, you will get a question what to do if edits are different. You can save the edits as a virtual copy, for example. Maybe you chose to ignore them...

Johan W. Elzenga,

http://www.johanfoto.com

3 Messages

 • 

94 Points

Thank you both for your help. I tend to agree, there's probably something not right with my set-up, although I've cured the problem for now.

Johan, I was exporting an existing image (with edits) to a new catalog, then importing into a third catalog which had no images in it until the one I imported. 

I tested the export stage, and the edits were preserved at that point. They were only lost at the import stage. And I was not asked any questions about conflicting edits.

Since the process is now working for me, I'm probably going to leave it there for now, but I shall recall this conversation if I find further problems.

Cheers,

RM

Champion

 • 

3.3K Messages

 • 

58.1K Points

You won't see any questions (as in a separate dialog box), but there are some options at the bottom of the 'import from another catalog' dialog, depending on what Lightroom found.

Johan W. Elzenga,

http://www.johanfoto.com

Champion

 • 

3.3K Messages

 • 

58.1K Points

BTW: to me this sounds like you perhaps used the normal (image) import rather than 'import from another catalog'. If you use the normal image import, then you would indeed lose the edits. But using 'save metadata to files' before that import would have retained the the edits. Exactly like what you've experienced...

Johan W. Elzenga,

http://www.johanfoto.com