John_R_Ellis's profile
Champion

Champion

 • 

5.9K Messages

 • 

102.3K Points

Wed, May 1, 2019 7:12 PM

Lightroom Classic: Edit In Photoshop hangs after renaming a previous edited version

If you invoke Edit In Photoshop / Edit A Copy after renaming a previous version of the file, Edit In Photoshop can hang, with Photoshop never opening.

To reproduce:

1. Make a folder "f" with a single file, "x.tif".

2. Import "x.tif" into the catalog using the import option Add.

3. Select that photo and do Edit In Photoshop with Edit A Copy.

4. In Photoshop, close the file, returning to LR. A second photo appears in "f", named "x-2.tif".

5. In the Metadata > Default panel, rename "x-2.tif" to "x-a.tif".

6. Select "x.tif" and do Edit In Photoshop with Edit A Copy.

7. Photoshop never opens. The progress bar shows this indefinitely:



This bug might be related to another one I just reported: 
https://feedback.photoshop.com/photoshop_family/topics/lightroom-importing-after-renaming-a-file-can-corrupt-the-catalog

But the recipe here doesn't corrupt the catalog.

Tested on LR 8.2.1 / Mac OS 10.14.3.

Responses

Champion

 • 

5.9K Messages

 • 

102.3K Points

2 y ago

A common use-case: External editors and plugins produce new versions name photo-1.tif, photo-2.tif, etc. Sometimes a user wants to make several different versions with different settings for comparison, so she renames the files to have more useful names, e.g. photo-large.tif, photo-small.tif, etc.

 

Employee

 • 

104 Messages

 • 

1.9K Points

Thanks for reporting. The issue is reproducible and we have logged a bug for the same.

-Mayuri

Champion

 • 

5.9K Messages

 • 

102.3K Points

Thanks much.

Employee

 • 

104 Messages

 • 

1.9K Points

Hi,

Lightroom Classic 8.3 contained a fix for this issue. Please update to 8.3 and verify that you are no longer seeing the issue. 

Thanks
Mayuri

Champion

 • 

2.4K Messages

 • 

38.8K Points

2 y ago

I can confirm the same behavior using LR 8.2.1. on Windows 10 Build 17763.

On closing LR I also get the following message. This is after running the above test AND then doing extensive editing on other image files with no issues. Just an FYI.


Champion

 • 

5.9K Messages

 • 

102.3K Points

2 y ago

I verified that the recipe now works correctly.