Skip to main content
Adobe Photoshop Family

21 Messages

 • 

522 Points

Wed, Nov 13, 2019 1:58 AM

Solved

Lightroom Classic: Deleting a keyword from the keyword list doesn't remove it from auto complete

If someone has already reported this I apologize. I did try to search for it but couldn't find anything with the keywords I was using.

If I enter a misspelled keyword accidentally it continues to show up in "Autocomplete" even though I delete it from the Keyword List.

I've never had this happen before. I recently upgraded to the 9.0 release.

My specific example of this behavior is when I go through to keyword basketball photos one of my keywords is Dribble. In the past I could type in dri and hit enter and it would autocomplete Dribble. I accidentally entered dri9 (the 9 is above the right side of the I key) and when I hit RightArrow to move to the next photo it entered dri9 into the keyword list. On the next dribbling photo when I typed dri it showed dri9 as the top option in autocomplete. I went into the keyword list and deleted the dri9 keyword. That removed it from the photo and from the keyword list but it still shows up in autocomplete.

I tried to see if I could remove it by entering dri9 in a different photo. This added it back to the keyword list. I went into the list and deleted the dri9 keyword again. That removed it from the photo and autocomplete again but then when I tried to enter dribble I noticed that I now had two instances of dri9 in the autocomplete popup. I continued to try exiting lightroom and backing up/optimizing the catalog and entering and deleting the keyword. Nothing worked although I now have four instances of dri9 in the autocomplete popup. There is also another keyword that it has happened on although I can't remember what it is now.

One other thing I did try using the Filter Keywords box in the keywords list and can't find dri9 anywhere.

Responses

43 Messages

 • 

732 Points

a year ago

Hi Tony,
Thank you reporting the issue.We are looking into it.

~Prabal Kumar Ghosh

91 Messages

 • 

1.8K Points

a year ago

Hi Tony,

Thanks for reporting the issue.We are aware of the issue and we are working on the fix. We will keep you posted for further updates.

Thanks
Mayuri

49 Messages

 • 

744 Points

a year ago

Hi Tony,

Along with your catalog, you will find a folder containing the suffix -- "Helper.lrdata". Please delete this folder. It is harmless to do so. Restart Lightroom after that. Please check if the issue persists.

With Regards,
Reetesh Mukul


3 Messages

 • 

102 Points

a year ago

Hi,

I am having the same issue. Below my post from the community forum.

In my case deleting the "Helper-Folder" solves the problem only temporary. Keywords removed in the past disappear from the autocomplete list. But as soon as I am entering new keywords and remove them again the same issue comes up again.

BR
Chris

__________________________________________

Since the update to Version 9.0 LR keeps on suggesting Keywords which were entered once but removed from the list afterwards.

As I am no native speaker I added the screenshot below to make clear what I mean. I simulated that I tagged a photo of my friend Sabine errously with "Sabiene". After recognizing my "fault" I removed the keyword from that photo and hit "Purge Unused Keywords". That succesfully removed the keyword from the keyword list but not from the suggestions. At the time the screenshot below was made "Sabiene" wasn't in the keyword list anymore.

Deactivating "Offer suggestions from recently entered values" and "Clear all suggestions lists" don't have any influence on the behaviour. Also this problem seems to affect all of my catalogues. No matter if they  were updated from previous version or newly created ones. The only workaround I found until now is to delete the helper.db of the catalogue.



21 Messages

 • 

522 Points

a year ago

Hi Reetesh,

I had the same result as Christian above.

I shut down Lightroom, deleted the helper file and the "dri9" keyword disappeared from the autocomplete popup when I got back into Lightroom.

I tried entering dri9 again on a photo and then deleting it from the Keyword List. After deleting it from the list it disappeared from the keywords in the photo but it persists in the autocomplete popup.

I'm going to delete the helper file again so it won't cause issues and await the fix!

Thanks for looking at this so quickly!
Tony Claxton

49 Messages

 • 

744 Points

a year ago

This is effectively a bug on which we are working on. The above is a tiny workaround.

6 Messages

 • 

136 Points

a year ago

This reply was created from a merged topic originally titled "Purge Unused Keywords" not working properly.

The feature "Purge Unused Keywords" is not working properly. A keyword that was used but that no longer exists in any images still appears in the Keyword drop down when typing. I selected all images in the Catalog (no filters on, etc.) and according to the Metadata pane, the Keyword isn't be used in an image, so it's still being stored in Lightroom's cache of used keywords. This is frustrating because I need a tightly controlled set of keywords for use in my office of several photographers (who may not know they're using the wrong keyword), and incorrect keywords are a real pain in our workflow.

I created a new catalog and imported the same photos that were in the other catalog, and the bad keyword doesn't show up, so it's Lightroom at fault, not human error.

6 Messages

 • 

136 Points

a year ago

Thanks for the temporary fix with the Helper file, it will be great to see this bug fixed.

474 Messages

 • 

12.2K Points

Also, be aware that if you have collapsed stacks, and you select all images the KW may not show up as being associated with any of the selected images but it may still be associated with images buried in collapsed stacks.

170 Messages

 • 

4.4K Points

This should be added to the bug report. It makes no sense to ignore the changes to images in stacks.

70 Messages

 • 

1.1K Points

10 months ago

This reply was created from a merged topic originally titled Lightroom Classic 9 Keywords Errors.

I am using the most recent version of Lightroom Classic (Version 9.0).  I misspelled a keyword and then I corrected the spelling and purged unused keywords.  When I look at the keyword list they have been purged but then when I start typing to add a keyword the misspelled and previously purged unused keyword is coming up as a keyword suggestion.  The older versions deleted unused keywords from the suggestions as well.  please fix this.

1.3K Messages

 • 

22.5K Points

I don't think it did delete them. You probably need to go to Catalog Settings / Metadata and clear the suggestions.

70 Messages

 • 

1.1K Points

In the previous versions when you purged unused keywords it also deleted unused suggestions

1.3K Messages

 • 

22.5K Points

I don't think so, but try that Catalog Setting.

4 Messages

 • 

108 Points

Thanks John!  The suggested work around is most helpful.

3 Messages

 • 

102 Points

10 months ago

Unfortunately the problem still persists with 9.1

97 Messages

 • 

1.8K Points

10 months ago

The delete keyword process forget to detete it from the helper.db (where the suggested list is stored) database as well.
Until a fix is available, a workaround is to delete the helper.db file.

1.3K Messages

 • 

22.5K Points

And since that helper.db is a recent addition, that would explain a change. Recent suggestions were capped at 10 items.

4 Messages

 • 

108 Points

10 months ago

This reply was created from a merged topic originally titled How To Erase Incorrect Keywords From Suggested Drop Down Choices.

I have multiple key words using Lightroom Classic that are misspelled or just incorrect, and they appear on the drop down when choosing a new key word for an image.  They have been corrected in the Key Word History module but they continue to show up in the suggested drop down lists.  This makes my OCD go crazy!  Is there anyway to get at these incorrect Key words and erase them off the face of the Earth?!  I am currently key wording thousands of images and it's an issue for me to get the correct Key word applied while trying to avoid incorrect Key words.

I have begun to use the custom Key word set feature and like that.  Too bad you only have Nine Key words per set.

Champion

 • 

5.1K Messages

 • 

92.7K Points

Two workarounds:

- See this post for deleting Helper.lrdata: 
https://feedback.photoshop.com/photoshop_family/topics/deleting-a-keyword-from-the-keyword-list-does...

- Do Catalog Settings > Metadata > Clear All Suggestion Lists.

You'll have to do this each time a misspelled or deleted keyword gets into the suggested-keyword list.

165 Messages

 • 

2.9K Points

In some other applications that provide suggestions based on typing history, I've been able to just scroll down to the incorrect word when the list appears and hit the Delete key to delete any incorrectly spelt word from that list. I haven't tried that with LR, but if that worked it may be better than the relatively nuclear option of clearing all LR suggestions...

4 Messages

 • 

108 Points

I was unable to affect (delete) the incorrectly spelled suggested word. So I have used the suggested work around and erased the suggested keywords.  I'm fine with this work around!  Big thanks to all here...

1 Message

 • 

62 Points

9 months ago

So bad behaviour. I'm affected too, ended with 9 same duplicate entries (on screenshot 5 of them), until was told a workaround on LightQueen forums. 



Fix is so much awaited!

13 Messages

 • 

322 Points

9 months ago

I'm also experiencing this problem; unable to delete keyword autofills/ suggestion lists. I'm on MacOS 10.15.2, using LR Classic 9.1.

I've tried 3 methods for solving this; none have worked:

  1. clicked on "clear all suggestion lists"
  2. deleted LR preferences
  3. deleted helper.lrdata file associated with catalog
If anyone knows of any other methods, please let me know. I mistakenly added a keyword that starts with a space, and it keeps popping up everytime I try to add keywords, very annoying.

Champion

 • 

5.1K Messages

 • 

92.7K Points

"I mistakenly added a keyword that starts with a space"

Do you know how you might have done that? LR normally doesn't allow you to create a keyword starting or ending with a space:



Does that keyword still appear in the Keyword List panel? If so, delete it -- otherwise, LR will continue to suggest it.

Also, did you restart LR after deleting Helper.lrdata?

13 Messages

 • 

322 Points

Thanks for the reply! Hm, not sure how I added a keyword with a space, actually I don't see the space, but when I hit the space bar the problem keyword always appears.

I did just find it in the keyword list and deleted it, that seems to have worked, thanks again.

97 Messages

 • 

1.8K Points

9 months ago

I've tried 3 methods for solving this; none have worked:
  3. deleted helper.lrdata file associated with catalog

This is strange because helper.lradata is where the suggested list is kept by LR, so removing it suppress the suggested list.
When I discovered this bug, I even fixed the suggested list by manually removing the bad entry in the helper.lradata (what the remove keyword process forget to do), so I didn't loose other keyword suggestions.