Skip to main content
Adobe Photoshop Family

74 Messages

 • 

1.3K Points

Mon, Jul 11, 2016 9:29 PM

Not a problem

Lightroom Classic: Creates unwanted sub-folder on import

When I import photo's (from an SD card) into an existing or new folder, LR will always create a sub-folder inside the folder I choose with the name of a folder I have used in an earlier import. I know LR will create sub-folders with the year and import date, but that is not what I mean. Say I want to import my photos to a folder called "Test". It doesn't matter if that is an existing or a new folder. So I check the photo's I want to import, choose the folder "Test" and click "Import". After it's finished importing, the folder structure shows:
Test
   BBQ GGG 2016 (which is a folder name I've used before on another import)
        2016
              2016-07-xx


The sub-folder BBQ GGG 2016 is utter nonsens. So after each import I have to drag the 2016-mm-dd folder to the root folder and delete the erroneous folder.

Responses

542 Messages

 • 

10.6K Points

4 years ago

In the Destination panel of the Import dialog, do you have the "Into Subfolder" checkbox checked?  That would cause the behavior you're describing, if I'm understanding what you're saying correctly.  Uncheck that box and you should be fine.  (Lr will still organize by date without the box checked.)



If that's not it...

What version of Lr and what operating system are you using?
Can you post some screenshots of your import dialog settings and the Folder panel after you do an import?

2 Messages

 • 

110 Points

Hi Tom.
This option no longer exists in latest versions of Lightroom CC.
However it has retained the last value used in previous versions and constantly creates an extra subfolder for all my imports. There's no way from the dialog to stop it from doing this, so I wondered if you knew where this preference was stored?

Thanks!

Champion

 • 

5.8K Messages

 • 

102.2K Points

This checkbox should still exist. Can you show us a screenshot of your Destination panel please Olivier?

2 Messages

 • 

110 Points

Hey Victoria, thanks for your reply.
Actually thanks to you, yes, I found it!
It's "hidden" in the minimized view of the dialog (sorry, French):

I had never seen/used this before and the checkbox/input is not in the larger view at all, so it's quite misleading :\

Anyway, problem solved, thanks!

1 Message

 • 

62 Points

Hi Guys,
Same problem here, while seeing Olivier answer I was happy to get the solution but I'm not able to find any possibilities to switch the view of the dialog.Can anybody help me in this?

235 Messages

 • 

4.1K Points

You are trying to Import the files to an SD card!
This is not an acceptable location for your files.
Choose a Folder Destination on your hard-drive.

What do you see in the Destination Panel (lower right) that is not shown in your screen-clip.
If you do not see a Destination Panel- [Right-Click] on another panel Header (Apply During Import) and click on [Show All] to enable all panels visible.

158 Messages

 • 

2.5K Points

4 years ago

I created a sub folder last night with 1400 pictures. when complete LR said there were 0 pictures.  But there were in fact pictures.  I moved them out to another folder and the results the # of pictures were -1400  weird

Adobe Administrator

 • 

8K Messages

 • 

116K Points

4 years ago

Show us a screen capture of your Import dialog featuring Destination panel settings and we will see if we can diagnose where you are getting the extra folder from. 
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

74 Messages

 • 

1.3K Points

4 years ago

Hi Tom, you are exactly right. I accidentally had the checkbox checked and the name of the "ghost" sub folder was in there. This is certainly something to be aware of. I would expect settings like this to be reset on a new import. It is easily overlooked. Thanks for your help

1 Message

 • 

80 Points

3 years ago

I am having this same problem in Lightroom CC "Classic"  (ie the "classic" online version), and I most certainly do not see any "create subfolder" checkbox anywhere in the import dialog.  I created the subfolder which self-generates every time I do an import 18 months ago!  Cannot see how to stop this behavior.  Help, please!

542 Messages

 • 

10.6K Points

Can you post a screenshot of your import screen?

2 Messages

 • 

70 Points

5 months ago

I am having a very similar if not identical problem with the current version of Lightroom Classic (9.0)

When importing from a local folder to my catalog (which is stored on an external HD) and I try importing to an existing folder LR creates a sub-folder within my target destination folder using the (YYYY/MM/DD) format. I have made sure I do not have the "create sub-folder" option checked but the problem continues. Any help is appreciated!:)


2 Messages

 • 

70 Points

5 months ago

No sooner do I ask for help then do I find the answer, sorry! but if someone else has this same problem the solution is changing the "Organize" drop down box to the "Into One Folder" option. I was confused and left it as "Date" because I was organizing my folders by date and didnt realize the effect the option was having! whoops! :)