Skip to main content
Adobe Photoshop Family

Champion

 • 

2.1K Messages

 • 

36.8K Points

Fri, Feb 16, 2018 12:05 AM

Acknowledged

Lightroom Classic CC: Radial Filters on Rotated Images are not rotated.

Rikk, I found another bug with the Radial Filter control.

The below image has Spot Removal, Radial Filter, Adjustment Brush, and Graduated Filter applied (from Left to Right). The Crop Tool Angle control moves ALL of the Local controls with the image. The Transform Rotate control moves all of the Local controls except the Radial Filter. All of the Local Controls should remain fixed to their relative image bitmap position.



Note: This conversation was created from a reply on: Lightroom 5.7.1: Copied radial filter effects appears on mirrored position when c....

Responses

838 Messages

 • 

13.1K Points

2 years ago

Hello, can not reproduce this behavior LR Classic 8.1 on macOS 10.14.1 Imac 27 '' (late 2013).

838 Messages

 • 

13.1K Points



LR Classic 8.1 on macOS 10.14.1 Imac 27 '' (late 2013). GPU active

Champion

 • 

747 Messages

 • 

13.3K Points

You appear to be using the ANGLE tool in Crop where it works correctly.  Try ROTATE in Transform where is doesn't work for me and Todd.

Champion

 • 

747 Messages

 • 

13.3K Points

2 years ago

I can reproduce it consistently and easily on Mac 10.13.6 and Lr 8.1.

Champion

 • 

2.1K Messages

 • 

36.8K Points

2 years ago

Rikk, this issue is still present in LR 8.1 on my Windows 10 system.

Champion

 • 

747 Messages

 • 

13.3K Points

8 months ago

Rikk
This issue is still present in Lr9.2 on macOS 10.14.6

Champion

 • 

2.1K Messages

 • 

36.8K Points

8 months ago

This issue is still present in LR 9.2......one year later!

Champion

 • 

747 Messages

 • 

13.3K Points

8 months ago

Todd
Unfortunately!!!!     I consider this a bug that should have a higher priority but apparently it is not in Adobe Land.

Adobe Administrator

 • 

8.1K Messages

 • 

117.1K Points

8 months ago

Todd & Robert, there are only 2 Me-toos in 2 years and one of those is from Adobe Staff.  That probably helps to explain the time gap since reporting.

The issue is still open in our system and a fix is planned for an upcoming release. There is no ETA. 
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

Champion

 • 

2.1K Messages

 • 

36.8K Points

Rikk, if it were a Feature Request I'd agree with you. Clearly this is a major implementation oversight even though most users may not realize it. You say, "A fix is planned, but there is no ETA." What's the threshold required for Adobe to fix it?

As these types of "Acknowledged" issues are left dangling LR Classic becomes an albatross collecting multiple errors that will unquestionably frustrate more and more users. We've provided our support gratis by providing detailed reports of these issues. Implementing them should be Adobe's first priority.

New features added such as the recent 9.2 'Raw Default Settings' changes can wait! In fact I (and others) prefer the previous implementation and question what "new" benefits it provides. This capability was present in LR 9.1 and earlier versions using the Develop module ALT + RESET 'Default Develop Settings' editing function.

Rikk, I appreciate your support and don't mean to shoot the messenger. I'm commenting here in the hopes you will bring it to the attention of the appropriate Adobe staff who can address these issues. Thank you!

Champion

 • 

747 Messages

 • 

13.3K Points

I agree Todd.  A couple of releases where Adobe just concentrates on bug fixes would be great.  Clean up the code and then start adding/improving things.  Unfortunately that probably wouldn't fly with the bean counters.  

Adobe Administrator

 • 

8.1K Messages

 • 

117.1K Points

@Todd, A note about the Raw Defaults feature work currently underway specifically referring to your comment “New features added such as the recent 9.2 'Raw Default Settings' changes can wait!”

Raw Defaults is a desired feature not only in Lightroom Classic but across the breadth of Adobe Photography Products. In order to deploy to additional clients in future updates, work had to be done to Camera Raw to prepare for deployment in the Lightroom Ecosystem. Unfortunately the existing Lightroom Classic deployment of default edit settings was not compatible.  To eventually deploy across the Ecosystem, it was necessary to modify Lightroom Classic in sync with Camera Raw. 

That said, feedback about functionality and UI are always welcome -but probably not best discussed deep in a thread about a Radial Filter bug.

I reviewed the notes on the bug and it does not appear to be an oversight as you suspected. The rotation is actually happening but happening wrongly and differently depending upon the location of the Radial on the image.  I have tickled the bug a bit to see if we can get it bumped in priority - but,as you say, I am the messenger. 
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

Champion

 • 

2.1K Messages

 • 

36.8K Points

Thanks Rikk–Much appreciated. I was afraid that was the case and now understand the need to change the current 'Default Develop Settings' interface. The release notes do not state that and in fact in insinuate it is a new feature. "With this release, we have added the ability to easily configure default settings for raw images in Lightroom Classic."
It would have helped if that was explained in more detail in the release notes AND if the 9.2 installer contained a subroutine to automatically create and assign camera specific presets for the Camera Raw Defaults based on the user's current settings (if present). Doing that AFTER the 9.2 update is much more difficult since there's no way of invoking and then reading the original defaults (i.e. Reset button). I think that caught a lot users off-guard, self included. Also the ability to create ISO dependent default settings is now much more difficult and  requires manually editing the presets with a text editor.
I don't use ISO dependent default settings and creating new presets for my five camera models wasn't that difficult. I have a 2nd system still running LR 9.1, which made it easier to record and copy over my default develop settings to new presets for my Raw Defaults. For may other users that's not the case!

Champion

 • 

747 Messages

 • 

13.3K Points

8 months ago

Rikk
I realize there are only a few me-toos on this but I still feel this particular bug should rate a higher priority for the following reasons.

1.  I suspect the Rotation slider in the Transform panel is not used much (I might be wrong) and when it is used the value is many times relatively small.  The non-rotation of the Radial Filter probably goes unnoticed by most but the error is still there in a carefully crafted Radial Filter.  People not noticing this probably accounts for the low me-toos.   

2. There is NO workaround except to reedit the radial filter.  Unfortunately there is an issue with reediting the Radial Filter if you use a brush to modify the Radial Filter MASK.

Radial Filter with Brush modification (UnRotated)



Radial Filter with Brush modification  (Rotate with Transform)

The Radial doesn't rotate but its modification does.  There is not and easy workaround for this issue.

838 Messages

 • 

13.1K Points

J'ai enfin compris le problème, Fonction "Transformation / Rotation manuelle", pareil pour moi sur macOS 10.15.3, LR Classic 9.2 et CameraRaw 12.2.

I finally understood problem, Function ' Transform / manual Rotation ', the similar for me on macOS 10.15.3, LR Classic 9.2 and CameraRaw 12.2.