Skip to main content
Adobe Photoshop Family

4 Messages

 • 

104 Points

Mon, Oct 29, 2018 12:57 PM

Closed

Acknowledged

Lightroom Classic CC 8.0: Ghost images in last days

In the last days I somehow ended up with ghost images in my Lightroom Classic CC 8.0 catalog. Please see the following links for examples. When I right click and click [show in explorer] I get an error message: "An internal error has occured: ?:0: attempt to index field 'rootFile' (a nil value)".

https://i.imgur.com/4m1SUb5.png

https://i.imgur.com/MSLWTnM.png

Please let me know how to remove these ghost images.


This conversation has been merged. Please refer the main conversation:

Responses

8 Messages

 • 

276 Points

2 years ago

I am also experiencing the same issue.

Champion

 • 

3.1K Messages

 • 

56.1K Points

2 years ago

This looks like catalog corruption. Do you make regular catalog backups?

Johan W. Elzenga,

http://www.johanfoto.com

4 Messages

 • 

104 Points

2 years ago

Every day, I have serious doubt this is catalog corruption.

Champion

 • 

3.1K Messages

 • 

56.1K Points

And why do you doubt this? The Lightroom catalog is a database. Each image in the catalog is a database record. If the catalog shows a lot of phantom records, and if trying to remove such a record generates an error message, then that does not seem like very healthy database to me. But if you know better, then I’m happy to hear your solution.

Johan W. Elzenga,

http://www.johanfoto.com

8 Messages

 • 

276 Points

I do daily backups and have not had any catalog issues.  

Champion

 • 

3.1K Messages

 • 

56.1K Points

Hugh? You do have issues with your catalog because you said you have the same problem with phantom images (and get the same error when you try to delete these?).

Johan W. Elzenga,

http://www.johanfoto.com