Skip to main content
Adobe Photoshop Family

6 Messages

 • 

162 Points

Thu, Oct 10, 2019 4:24 PM

Lightroom Classic: Brushing and export pretty slow under macOS 10.15 Catalina

I just update MacOsX to Catalina; LR Classic always updated.Selection brush and export are pretty slow so far.overall functions a bit slower than usual

Responses

Adobe Administrator

 • 

7.9K Messages

 • 

114.6K Points

a year ago

Have you checked Preferences>Performance and toggled the GPU section to see if one option is faster than another for your Brush?

Adobe Photography Products

Quality Engineering - Customer Advocacy 

99 Messages

 • 

1.7K Points

Related: Has Adobe converted graphics processing on Mac to Metal instead of the (now deprecated) OpenGL? I am thinking of Lightroom, Photoshop, and Premiere but really all the major apps in CC. If not, are there plans?

Champion

 • 

5K Messages

 • 

91.7K Points

Lightroom and Camera Raw currently use Metal. As of the upcoming major release later this fall, LR and ACR will no longer support OpenGL: 
https://blogs.adobe.com/crawlspace/2019/08/changes-to-os-and-graphics-processor-gpu-support-in-adobe...

6 Messages

 • 

162 Points

a year ago

Yes Off course Rikk...Even tried to work on Dynamic previews, empty the cache...after a few selection, its getting slower and sloppy, even worth with auto mask or when unmasking (alt)

Adobe Administrator

 • 

7.9K Messages

 • 

114.6K Points

I've been testing on a Macbook Pro with Catalina and have tested up to 50 individual brush strokes. I am not seeing any degradation. 

How many brush strokes are we talking about? What type of adjustments? In conjunction with many spot removals? Lens Correction?

Adobe Photography Products

Quality Engineering - Customer Advocacy 

6 Messages

 • 

162 Points

Hi Rikk.I've been working on simple edits, with 2 to 5 selections, without spot removals, but always lens corrections
(I know sport removal slows a lot LR... does lens correction too??)
Anyway, it's my usual kind of work, and I definitely see a downturn in my edits... Hell Spinning wheel showing a lot, lots of lag when adding strokes to a selection ...

Adobe Administrator

 • 

7.9K Messages

 • 

114.6K Points

So far, I cannot duplicate this behavior. You may need to attempt a clean reinstall to make certain you are in a good state before trying anything else. 

Clean Classic Install ProcedureClose Lightroom
Restart the computer
Use the Adobe Creative Cloud App to uninstall Lightroom Classic
Restart the computer
Install Lightroom Classic via the Creative Cloud App without launching any other programs.
Restart the computer
Launch Lightroom
Wait 5 minutes 

Adobe Photography Products

Quality Engineering - Customer Advocacy 

576 Messages

 • 

9.1K Points

a year ago

Maybe you shouldn't of upgrade to the new OS X?

Champion

 • 

5.8K Messages

 • 

102.2K Points

That's not very helpful Just Shot Me!! ;-)

799 Messages

 • 

11.5K Points

a year ago

You are correct Victoria, but Just Shot Me has a point. As I said in another post: "No corporate IT person would ever install a ".0" version of an OS on a work computer. I'm waiting for 10.15.2 or .3, for my iMac, and I was a Mac IT pro for 25 years. I have a laptop that I use for testing first before I ruin my main computer!

PS- there's no version of Onyx for Catalina yet, otherwise, Manud70, I'd suggest running that when it's available: https://www.titanium-software.fr/en/onyx.html