Skip to main content
Adobe Photoshop Family

3 Messages

 • 

102 Points

Mon, Oct 16, 2017 9:58 PM

Solved

Lightroom Classic: After High Sierra install, application stops working and closes suddenly

I have encountered a repeated error crash error after installing High Sierra.  

I was connected to an external monitor to provide a second screen.

I first notice it when in the development module and clicked on the 'color' panel and selected one of the colors to adjust.  Lightroom would just close without warning.  It would re-open only after several attempts to re-open the application (or after a system re-start).  The would re-occur intermittently when often when selecting the color panel in the dev module again.

The issue was still persistent after reseting Lightroom applications.

I am running Lightroom version: CC 2015.6 [ 1078672 ]. 
MacBook Pro (Retina, 15-inch, Mid 2015)
High Sierra Version: 10.13 [0]
Graphics Processor Info: AMD Radeon R9 M370X OpenGL Engine

I have the crash logs, should I post them here too?

Responses

799 Messages

 • 

11.5K Points

3 years ago

Have you tried running Onyx? There is a version for High Sierra, you can get this link: https://www.titanium-software.fr/en/o... Also try repeating the same action in another (admin) account, or with an empty catalog as a troubleshooting tactic.

20 Messages

 • 

544 Points

3 years ago

Hi Mark,
We have observed a High Sierra specific crash when multiple devices (cameras, SD cards, phones etc.) are simultaneously connected to the computer. I suspect that the crash you are facing could be the same one.
Could you please check if this crash stops happening if you connect only one device?

Thanks,
-Amit

3 Messages

 • 

102 Points

Thanks for your reply Amit.  I found out I was on an old version of Lightroom (despite checking of updates).

2 Messages

 • 

70 Points

Hi Amit,
I have this problem also. My Lighroom is version 4.1. How can I fixed this?

20 Messages

 • 

544 Points

Hi Matin,
Could you please check if the crash is reproducible if you connect only one device (camera/SD Card/Phone) to your computer?

2 Messages

 • 

70 Points

Hi Amit, yes LR4 crashes also when there is only one device connected to LR4. Even when i connect my camera with wifi. 

Champion

 • 

5.9K Messages

 • 

103.9K Points

3 years ago

In addition to Amit's suggestion, update to the latest version of Lightroom (2015.12) as 2015.6 is more than a year out of date.

Victoria Bampton a.k.a. The Lightroom Queen

www.lightroomqueen.com

Author of Adobe Lightroom Classic - The Missing FAQ and Adobe Lightroom - Edit Like a Pro books.

3 Messages

 • 

102 Points

3 years ago

Thank you. 

I had to uninstall and then re-install lightroom. After I re-installed I noticed it was a later version as the library view looked slightly different.  

Strangely, one of the very first things I had done was a "check for updates" on the creative cloud and it had declared photoshop AND lightroom were up to date so something seems to have gone awry over the updating process.

Thanks you!