Skip to main content
Adobe Photoshop Family

282 Messages

 • 

5.6K Points

Sat, Jul 4, 2020 8:54 AM

Lightroom Classic 9.3: HSL/Color / B & W TAT activation adds Convert to Black & White No/Yes to the History panel

In Color Treatment mode, when an image has at least one Graduated or Radial Filter local adjustment, then activating the TAT on the HSL/Color panel results in Convert to Black & White No being added to the History panel.

In Black & White Treatment mode, when an image has at least one Graduated or Radial Filter local adjusted, then activating the TAT on the B & W panel results in Convert to Black & White Yes being added to the History panel.

This problem does not occur when there are no Graduated or Radial Filter local adjustments, nor does it occur when the only local adjustments are Local Brush Adjustments.

These are meaningless steps being inserted into the History panel every time the HSL/Color or B & W TAT is activated after a Graduated or Radial Filter has been added.

Yet another annoying new bug in LrC 9.3 for which I use Undo to remove from the History panel every time it occurs.

Responses

Champion

 • 

744 Messages

 • 

13.3K Points

3 months ago

I can duplicate that behavior.  Good catch.

Champion

 • 

5.8K Messages

 • 

102.2K Points

3 months ago

I've already bugged this internally, although I thought it was process version related.

Champion

 • 

744 Messages

 • 

13.3K Points

3 months ago

Victoria,
Its broken for me on Lr9.3 PV5

282 Messages

 • 

5.6K Points

3 months ago

Hi Victoria,

I tried this with PV1 and Lr 9.3's behaviour is still the same, so it's not related to the process version.

282 Messages

 • 

5.6K Points

3 months ago

This is another problem new to LrC 9.3 that I suspect could be related.

Selecting a Graduated Filter by clicking its pin adds an Update Graduated Filter entry into the History panel.

This doesn't happen with the Radial Filter or Adjustment Brush.

The development team are already aware of this issue.

I also suspect that both problems could be related to the fix for this problem:

https://feedback.photoshop.com/photoshop_family/topics/lr-classic-toggling-b-w-deletes-all-radial-filters-graduated-filters-and-adjustment-brushes


145 Messages

 • 

2.4K Points

2 months ago

I just encountered it.

7.9K Messages

 • 

114.4K Points

a month ago

Updates to Camera Raw, Lightroom Classic, and the Lightroom Ecosystem were released yesterday evening and contain a fix for this issue.  Please install the appropriate update and see if it solves this problem. 

Thank you for your patience.

Adobe Photography Products
Quality Engineer: Customer Advocacy

282 Messages

 • 

5.6K Points

a month ago

Confirming that this bug has now been fixed in LrC 9.4.