Skip to main content
Adobe Photoshop Family

12 Messages

 • 

380 Points

Wed, Aug 14, 2019 3:48 PM

Solved

Lightroom Classic 8.4: Hanging on launch (Mac 10.14.6)

I just upgraded Lightroom Classic from v 8.1.3 to 8.4.  It now hangs. I am on MacOS Mojave version 10.14.6. When reverting to v 8.1.3, Lightroom works fine. Are there compatibility issues with this version of Mojave? Thanks

Responses

3 Messages

 • 

86 Points

a year ago

It has been two weeks since you said engineering was working on a fix. It would be nice to get an update as to when the fix can be expected. It would seem that if you are going to charge people every month to have access to the software it should work and any problems should be fixed quickly.

Adobe Administrator

 • 

8.2K Messages

 • 

118.3K Points

a year ago

Lightroom Classic 8.4.1 was released earlier today and has a fix for this issue. Please install the update and let us know if you are still seeing this issue. 

Thank you for your patience!
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

13 Messages

 • 

182 Points

Just tried to update and the app is still using V8.4, not 8.4.1 

13 Messages

 • 

182 Points

Updated now and it opened an empty catalogue just fine, then swapped over to my normal one equally well...

It's looking good! (so far!)

4 Messages

 • 

80 Points

When I click on upgrade, I still get version 8.4 with the same issue.  I don't have an option for 8.4.1.  Do you have a link?

13 Messages

 • 

182 Points

I just did the same... 

Click on the three vertical dots and select check for upgrades and it sorts itself out!

4 Messages

 • 

80 Points

Where do you see 3 vertical dots?  Thanks

4 Messages

 • 

80 Points

Thanks, it now works.

13 Messages

 • 

182 Points

Click on the Creative Cloud Manager from the tool bar and the drop down has three dots top right hand corner, the first option is "check for app updates" click on that and you'll then get the option to upgrade again.

Adobe Administrator

 • 

8.2K Messages

 • 

118.3K Points

9 months ago

Updates to Lightroom Classic, Camera Raw, and the Lightroom Ecosystem were released yesterday and contain a fix for this issue.  Please install the appropriate update and see if it solves this problem. You can read more about the updates here.

Thank you for your patience. 
 

Adobe Photography Products

Quality Engineering - Customer Advocacy