craig_pessman's profile

2 Messages

 • 

120 Points

Sun, Apr 15, 2018 2:08 PM

Lightroom Classic 7.3: Slow is the application of presets to an entire shoot

Unfortunately several of the performance gains you delivered in the last release has been lost in this release.  Particularly slow is the application of presets to an entire shoot. Sharpening is particularly slow, lens profiles are terribly slow.  Also as I edit photos whenever I hit the crop shortcut key I see a flash of a previous crop instead of the photo I am working on. I have also experienced a preset being applied to a photo when I have hovered over it but not clicked on it and then I can't reset the photo without stopping and starting LR.  Exports are still slow and previews are back to being slower.  Not as bad as before but slower than the last release.  I am also experiencing LR Not Responding errors on Exports of large file sets.  I have to kill LR to get it to respond again.  Overall I am disappointed you released a version that was this poorly tested and obviously performs slower than the last release after you made such a big deal of the performance gains.

Responses

Official Solution

Adobe Administrator

 • 

10.7K Messages

 • 

142.1K Points

3 y ago

Lightroom Classic CC 7.5 was released today and should address this issue.  If you don’t see the update in your Creative Cloud App, hit the [Ctrl/Cmd]+ [Alt/Opt]+[R] to force a refresh. 

Give the new version a try and let us know if it solves the issue. 

151 Messages

 • 

3.1K Points

3 y ago

This latest version is certainly a bit weird ... last time I started it, I got a feedback request on why LR had crashed (it hadn't). I started filling in the form after I'd finished working in LR and the form then disappeared half-way through my typing!  I am slowly but steadily losing what faith I had in Adobe's position on LR.

Adobe Administrator

 • 

10.7K Messages

 • 

142.1K Points

3 y ago

Craig,

I am sorry you are experiencing poor performance. 

The Crop issue where the previous image shows briefly is a known issue and should be resolved in an update. 

Regarding the rest of the items on your list, it would be helpful if you could provide more information. 

OS Version:
Specs on your computer:
Actual specific operations you report as slow and the time in seconds they take:

From the group of issues you describe, I would suspect a good first step would be to reset your Lightroom Classic CC preferences. Here are the instructions.

Reset Procedure:

1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom. 
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.

Do the various behavior issues improve in their performance after resetting the preferences?

4 Messages

 • 

134 Points

3 y ago

It's horrible for me, too.  Instead of previewing presets in the preview window it now tries to preview the preset on the entire photo and it's killing my computer with no way to turn it off.  I wouldn't have upgrade had I not needed RAW capability for the Sony Ay-III.  This is ridiculous.   

2 Messages

 • 

94 Points

3 y ago

Nice to know it's not just me. I used to put a preset on a 1,000 photos or more and it was done in seconds.  Now I put it on 500 and it takes over 10 minutes to put it on the photos.  It's disgustingly slow. I was so happy it finally sped up last release but this release is slower than all the ones I used previously.  I'm using Win 7 with 8 GB of RAM and and Intel i7 chip so there's no reason for this to be so excruciatingly slow!!  I'm NOT happy about it whatsoever and wish I could go back to the previous release.  I'm going to try to figure out if I can because there is NOTHING in this release that is better about Lightroom for me.  :(