Skip to main content
Adobe Photoshop Family

3 Messages

 • 

96 Points

Thu, Nov 30, 2017 6:30 PM

Lightroom Classic 7.0.1: Error switching modules after deleting rejected photos in Develop

Yes. This problem was fixed in some earlier versions of Lightroom, but appears to have resurfaced in Lightroom Classic. I just reproduced it in Lightroom Classic CC 7.0.1 on MacOS X 10.12.6 (Sierra).

Adobe's support team on Twitter have denied that the problem exists, but I can reproduce it reliably on my system.Note: This conversation was created from a reply on: Lightroom: Deleting rejected photos while in Develop doesn't work.

Lightroom reports "Error changing modules" after rejected photos are deleted while in the Develop. STEPS TO REPRODUCE

1. Launch Lightroom.

2. Switch to Develop.

3. Flag 1 or more photos as Rejected.

4. Choose "Delete Rejected Photos" from "Photo" menu.

5. Switch to Library.

EXPECTED BEHAVIOR

Switch to Library should work correctly.

ACTUAL BEHAVIOR

Lightroom displays a dialog reading "Error changing modules". Thereafter, the app is in an inconsistent state; no photographs are displayed in the Library module, and choosing "Quit" causes the app to exit without the normal prompts to back-up the catalog etc.

Responses

Official Solution

Adobe Administrator

 • 

14.8K Messages

 • 

284.8K Points

3 years ago

I can reproduce and will log a bug for the eng team. Thanks.

Sr. Product Manager, Adobe Digital Imaging

22 Messages

 • 

436 Points

3 years ago

Just happened  to me.  Current LR Classic CC.

Champion

 • 

5.8K Messages

 • 

102.2K Points

3 years ago

There's another new Classic bug on error changing modules too, which isn't specific to Delete Rejected Photos, but could be related. https://feedback.photoshop.com/photoshop_family/topics/changing-modules-error