Skip to main content
Adobe Photoshop Family

Champion

 • 

2.1K Messages

 • 

36.3K Points

Tue, Oct 31, 2017 5:25 PM

Lightroom Classic 7.0: Stacking Issue

When exporting images with 'Add to Stack' checked only one (1) image file can be stacked with the original. When a second export file is created using the same original file it is stacked with the original, but the first export file is removed from the stack. The first export file is then moved to the end at the bottom of the Grid view (last image). Changing Sort Order to Capture Time or File Name or A>Z, Z>A has no effect. The file remains at the bottom position of Grid View as the last picture. I also reset the LR Classic Preferences file with no change in behavior.

If you right-click on the original file and select 'Unstack' all of the files appear together as expected using Capture Time sort in the Grid view. I checked LR CC 2015.12 using the same image file in the same folder structure and it behaves as expected with all files stacked below the original.

Both Windows and Mac OS X platforms exhibit this issue with LR Classic 7.0 and 7.0.1. Please see this post for more details:

https://forums.adobe.com/message/9934148#9934148

Responses

Official Solution

Employee

 • 

291 Messages

 • 

7.8K Points

3 years ago

We were able to reproduce this and have logged a bug for the same.

Thanks,
Smit Keniya
Lightroom Classic CC Team

Champion

 • 

744 Messages

 • 

13.3K Points

Thanks for looking into this.

Official Solution

14.6K Messages

 • 

282.6K Points

3 years ago

This was fixed in the 7.1 update.

Champion

 • 

744 Messages

 • 

13.3K Points

3 years ago

This becomes even stranger for me.  If I export a CR2 and "Add to Stack"/"Below Original" the above scenario you describe happens.

 

If I export a CR2 and "Add To Stack"/"Above Original" than on the second export there becomes FOUR thumbnails all next to each other.   There are TWO CR2 files with the same name that point to the exact same photo on disk when I use "Show in Finder".  There are TWO JPG files with different names with each stacked with a different CR2 thumbnail (they are actually the same file).  If I remove one of the JPG files then the "phantom" CR2 is also removed.

Champion

 • 

2.1K Messages

 • 

36.3K Points

Thanks Rob. I can confirm the same behavior on my Windows 7 system so we have two different stacking issues.

497 Messages

 • 

9.6K Points

Thanks for reporting. We also see similar behavior.
We are looking into it.

Thanks,
Sunil

Champion

 • 

2.1K Messages

 • 

36.3K Points

Thank you Sunil!

15 Messages

 • 

350 Points

3 years ago

Thank, you, Smit

5 Messages

 • 

104 Points

3 years ago

I have a related problem I think, reported in this thread:
https://forums.adobe.com/thread/2410653

I exported 1600 wide JPGs and published to Flickr via LR Classic. I then made changes to a Raw, and re-exported, selecting Overwrite. This then created another thumbnail with the same name. Checking in Windows, there is only one file, so it creates a ghost thumbnail within LR Classic. If you try to delete one, it deletes both, so losing the publish link to Flickr. I tried optimising the catalogue. It used to work fine, flagging up the revised JPG for re-publishing in Flickr.

I also noticed some thumbnails at the end of the LR Classic grid view detached from the opened stack.

Champion

 • 

2.1K Messages

 • 

36.3K Points

3 years ago

The LR Classic 7.1 update released today fixes the stacking issue on my Windows 7 system.

New features summary for the October 2017 and later releases of Lightroom Classic CC

2 Messages

 • 

176 Points

3 years ago

The 7.1 update fixed it for me too.

5 Messages

 • 

104 Points

3 years ago

And it seems to have fixed my re-export problem, though an old ghost remains. I decided to delete it, lose the link to Flickr and re-export.