JPEG's profile

21 Messages

 • 

286 Points

Thu, Mar 18, 2021 8:44 PM

Lightroom Classic: 10.2 Message "The catalog could not be opened due to an unexpected error."

This issue has returned.

The catalog opened ONCE (and only once) after updating to LrC 10.2; I do this as a test everytime I update LrC.

Now, a few days later, I get the pop-up with the error text: "The catalog could not be opened due to an unexpected error."

Responses

83 Messages

 • 

1.1K Points

2 m ago

This morning I updated LRC to 10.2 and now I get the Unexpected Error Opening Catalog. HELP! what do I do now?

Ive tried restarting PC but no help.

Note: This comment was created from a merged conversation originally titled Lightroom Classic: Unexpected Error Opening Catalog Version 10.2

83 Messages

 • 

1.1K Points

I can not open catalog. 

83 Messages

 • 

1.1K Points

I rolled back to version 10.1.1 and LRC appears to be working now.  Anything I can do to get 10.2 to work? in Windows? I even tried a accessing a backup and it failed.

Adobe Administrator

 • 

539 Messages

 • 

9.9K Points

Where you updating from Lightroom Classic 10.1.1 version? Did Lightroom Classic prompted for an upgrade? I am sending an email off-list. We can investigate your catalog.

Thanks,
Sunil

83 Messages

 • 

1.1K Points

I did not get a auto update msg. I just went into lrc help and did software update and was told there is a new version.

1.1K Messages

 • 

12K Points

Instead of starting Lightroom, go to the catalog and double click on it. That should automatically open Lightroom with that catalog.

If this does not work then try resetting your preferences file. There are are a multitude of examples on this forum as well as on the Lightroom Queen website.

Still not working, clear your previews. Hate to recommend that as it can take a long time to rebuild them.

Lastly there's the possibility that one of the Lightroom files is corrupt and that a reinstall is needed.

Hopefully someone else has a better idea.

 

Tip: hopefully you externalize all edits. If not, do that first. Then you can create a new catalog and import all your images without losing your edits. Edit history is lost but the final result is kept. Let's say that you moved the Contrast slider 3 times for a given image. History shows all  3 steps while only the net result is externalized. You will also lose your albums, create a keyword for each album and then you can easily recreate them through you will have lost your reordering.

83 Messages

 • 

1.1K Points

I have tried the double click and it fails. I have sent my lcat file to adobe and awaiitng a reply.  I have reverted to 10.1.1 and operational

6 Messages

 • 

106 Points

same thing happening to me! Im using a Mac are you?

21 Messages

 • 

286 Points

2 m ago

Commenting on my own post to add more info (sorry).

I rolled back to LrC 10.1.1 and my 10.1.1 catalog opens just fine. (I restored my 10.1.1 catalog via Time Machine.)

My 10.1.1 catalog did NOT open with 10.2. (Same "The catalog could not be opened due to an unexpected error." message)

I am on macOS Catalina 10.15.7

6 Messages

 • 

106 Points

@JPEG same thing happens to me

Adobe Administrator

 • 

10.3K Messages

 • 

137.8K Points

2 m ago

Since the 10.2 update on Monday, this is the only report I can recall seeing. I would say this not a returned issue but likely a completely different issue. 

  1. I would recommend opening your catalog in 10.1.1 and letting it sit idle for 5 minutes.
  2. Close Lightroom 10.1.1
  3. Make a copy of that catalog via the file system
  4. Install 10.2.
  5. Open the original catalog from step one
  6. Screen shot the error. if it won't open and post it here.
  7. If it fails, Zip the catalog from step 3 and I will send you instructions.
Adobe Photography Products

Quality Engineering - Customer Advocacy

1 Message

 • 

62 Points

I cannot open in 10.2 or 10.1.1.  I had upgraded to Big Sur about two weeks ago and had not had any issues until today when I got the "Unexpected Error Opening Catalog" pop up.

21 Messages

 • 

286 Points

2 m ago

@Rikk Thanks. I followed these steps and they worked.

I also re-opened my new 10.2 catalog (using LrC 10.2) several additional times to be sure.

There must be something about the 5-minute wait time. During that wait time, the additional "*Sync" and "Mobile Downloads" files were magically created.

I will test daily for a few more days to be sure this fix has really taken hold.

21 Messages

 • 

286 Points

2 m ago

Bummer. I re-tried opening my catalog about 7 hours after the "success" reported above and now it fails again.

I did not use LrC in the interim.

Summarizing, on macOS 10.15.7, I cannot open my catalog with LrC 10.2 -- even though it opened this morning. Weird.

I have been using Lightroom for at least 10 years, on both Mac and PC, and I have never seen anything like this.

Screenshot of error dialog below.

9 Messages

 • 

172 Points

@JPEG

Very same here 

3 Messages

 • 

80 Points

Me too!  Reminiscent of October in that booting usually results in the catalog opening on the first try but not subsequent tries.

3 Messages

 • 

80 Points

I've had a run of a few days of LrC 10.2 opening normally.

3 Messages

 • 

80 Points

and now it's back :(  Restarting still solves it but darn.

21 Messages

 • 

286 Points

2 m ago

Now, after a couple of days, I re-tried LrC 10.2 and (surprise!) it successfully opened my catalog. (21 March)

Strange.

I did not touch LrC, nor my files, folders or photos, in the intervening period.

This time, a "verifying integrity" message box popped up briefly before the catalog fully opened.

Understandably, I am quite "spooked" by this behavior. I will check periodically to see if this issue is really gone.

I am not a professional, and I (thankfully) don't use LrC for work. But I am photo enthusiast and I am naturally concerned about ~20 years of photos and edits.

9 Messages

 • 

150 Points

2 m ago

I reported this also to @Rikk there are too many reports now for this to be a hardware error

21 Messages

 • 

286 Points

2 m ago

Failed again (March 22).

I successfully opened it 2-3 times as a test, then it failed again today.

Same error dialog:

21 Messages

 • 

286 Points

2 m ago

After ~16 hours (overnight) with no other usage of this computer, the catalog opened on the first try. "Integrity check" message box popped up briefly. (March 23)

My iMac is not showing any other kind of odd behavior.

Could this be related to some Adobe cloud/sync intermittent issue? When this fails, is my LrC 10.2 instance reaching out to some online Adobe service that it cannot find?

21 Messages

 • 

286 Points

After 7 days (now March 30) my LrC catalog still opens fine.

I have not been using LrC for anything but testing over the last 7 days.

6 Messages

 • 

106 Points

2 m ago

When I update Lr classic this error “ Unexpected error opening catalog; choose a different catalog, try again, quit” happens.  Anyone have any ideas how to fix this? My Mac needs to be updated to Big Sur 11.2.3 (I was waiting for the next version to update). Lr works fine when I go back a version. I called support and tried their chat and it was a waste of time. I have a Mac using Big Sur. 

Note: This comment was created from a merged conversation originally titled “Unexpected error opening catalog” on Mac after latest Lr update

Adobe Administrator

 • 

539 Messages

 • 

9.9K Points

We need some additional info to investigate this further.
I have sent you a mail with details.

Thanks,
Sunil

Adobe Administrator

 • 

10.3K Messages

 • 

137.8K Points

This thread is being merged into an existing authoritative thread for better tracking and response. Please review the official answer (if any) in the second post on the thread for more information. 

Adobe Photography Products

Quality Engineering - Customer Advocacy

4 Messages

 • 

100 Points

2 m ago

I'm sorry Adobe but over the last 12 months every time there's an update there seems to be a problem.  If it's not Media Encoder then it's Lightroom Classic.  There was a similar issue to this in December and then a new update resolved that problem and now it seems similar is happening again.

2 Messages

 • 

70 Points

2 m ago

When I upgraded from LrC 9 to 10, I started having catalog problems. After the catalog was upgraded, the LrC would launch once, then not launch again without testing catalog integrity upon startup. I tried backing up, restoring backups, creating a new catalog and importing the old one -- all the same result. Now after updating to 10.2, it's worse. LrC won't even give me the option to select a catalog and test integrity - it just closes. I uninstalled, wiped prefs and re-installed, then tried again with a new catalog. The same outcome -- crashing immediately after launch. So LrC is unusable, and I can't roll back the catalog to v9 to use older software. 

What is going on here?

2 Messages

 • 

70 Points

I started using Lr at v2. Today I started looking for alternatives. 

21 Messages

 • 

286 Points

1 m ago

My catalog again failed to open today (April 7).

I have not be using LrC (10.2) recently outside of daily testing to see if my catalog still opens.

Screenshot of error dialog below.

21 Messages

 • 

286 Points

1 m ago

Still failing, same error. April 10.

Adobe Administrator

 • 

10.3K Messages

 • 

137.8K Points

I am curious JPEG - if you simply rename the catalog (and corresponding preview folders) to a different name does the issue persist?

Adobe Photography Products

Quality Engineering - Customer Advocacy

21 Messages

 • 

286 Points

Hi @Rikk

Surprisingly, my catalog opens just fine this morning (April 12). I have not made any changes to LrC or to my Mac so I can't understand this intermittent behavior.

Anyway, thanks for checking. I will conduct the test you suggest the next time catalog opening fails.

-JPEG

21 Messages

 • 

286 Points

After almost two weeks for normal/correct behavior, my catalog once again failed to open today (April 23). (Same error message.)

@Rikk, the first thing I tried was just rebooting my iMac. Then, after the reboot, the catalog opened just fine. (!!!)

So, due to this success, I was unable to execute the renaming test that you suggested.

1 Message

 • 

60 Points

1 m ago

I upgraded to Lightroom 10.2 earlier, and upon recently launching it encountered this error. I had to revert to the previous version *and* restart before I could open my catalog again. It seems this has gone on for a month, and there isn't useful, new information available here? No fix or suspected cause? Is this issue specific to operating Lightroom under Catalina?

As an aside, in my opinion Adobe needs to put a lot more work into stability. Constant Cloud Sync issues and anything that threatens a Lightroom library like this is remarkably bad for a program we are to rely on for professional application. It seems like I am spending as much time troubleshooting problems with Lightroom as I am actually making productive use of the program.