todd_shaner_6660895's profile
Champion

Champion

 • 

2.4K Messages

 • 

38.7K Points

Wed, Apr 29, 2015 6:24 PM

Lightroom CC: Soft Proof Histogram Displays Incorrect RGB Values

The LR CC Soft Proof RGB values shown in the Histogram are incorrect when the cursor is hovered over a specific area of the image. It does not matter what color profile is used or if the ' Graphics Processor option is enabled or disabled in LR Preferences. The values remain the same and incorrect regardless of the Profile selected in the Soft Proofing panel.

The Soft Proof Histogram appears to display the LR Native Color Space values (Melissa RGB) without RGB data conversion to the Profile color space setting in the Soft Proof panel. Please see this post for further details:

https://forums.adobe.com/message/7489...

Responses

Official Solution

Adobe Administrator

 • 

15.9K Messages

 • 

295.3K Points

5 y ago

This issue should be resolved by installing the Lightroom update that was released today:

http://blogs.adobe.com/lightroomjourn...

Sr. Product Manager, Adobe Digital Imaging

3 Messages

 • 

110 Points

6 y ago

I have tried getting Adobe's attention via Lightroom's forum only to be told they do not review the posts there. So here are links to several posts I have made concerning this problem. I have posted examples so that you can appreciate the issue particularly for a professional studio which depends on accurate RGB values.

https://forums.adobe.com/thread/1936393
http://www.canonrumors.com/forum/inde...

263 Messages

 • 

6.2K Points

6 y ago

I can confirm the issue. The RGB numbers are incorrect in soft proof in LR 2015.

8 Messages

 • 

150 Points

5 y ago

This reply was created from a merged topic originally titled Soft Proofing Bug in LR 6.x and LR CC 2014, and LR CC 2015.x.

LR CC 2015.3 and LR 6 have a bug in the Soft Proofing feature. Neither will display the correct RGB values in the Histogram window. However, LR 5.7.1 and earlier do. However, when the file is exported to Photoshop the RGB values and histogram are correct. This bug has been discussed in several forums since April 2015. This is an essential component for our studio. We need to accurately evaluate each file to meet our clients needs and to insure the product is properly reproduced. We have not update our production machines because of this bug. And can not update them until it is fixed.

Employee

 • 

1.7K Messages

 • 

32.4K Points

5 y ago

Make sure your destination color profile is good. We have heard some similar report only to find that the color profile is not wellformed/corrupted. Sometimes it helps to use Apple's ColorSync Utility to repair the profiles.

Is it happening on a particular color profile or happening on all profiles?

Principal Scientist, Adobe Lightroom

263 Messages

 • 

6.2K Points

Simon, this is a real bug introduced with LR 2015/6 and happens with all profiles. The RGB display is incorrect. I haven't checked yet in 6.3 but Kim's report seems to indicate it is still a problem.

8 Messages

 • 

150 Points

Jao - It is still a problem. Simon - profiles are identical in all versions and when opened in Photoshop. It is an color engine problem as far as I can determine. Only work around is not use LR 6.x or LR CC any version!

Employee

 • 

1.7K Messages

 • 

32.4K Points

The profiles that work fine in PS does not necessarily mean Lr would like it. PS might be using a slightly different API that might be more tolerant. With an EPSON RGB color profile applied, I see Lr read out different RGB values (after conversion) when toggling soft proofing on and off. Does the image render for the softproofing look correct to you? Or the problem is just the RGB read out.

If you can share the color profile somewhere, I'd be happy to take a look.

Principal Scientist, Adobe Lightroom

8 Messages

 • 

150 Points

You seem not to understand the problem. It is not a profile issue.

8 Messages

 • 

150 Points

This problem is across many machines in two different studios all using the same profiles all having the same issue. If you read all the other user's experiences you will note they are the same. It does not appear to be a profile issue unless we are all having the same profile corruption across many both PCs and Macs.

Champion

 • 

2.4K Messages

 • 

38.7K Points

Every profile shows the same RGB values in the Soft Proof histogram. See this post https://forums.adobe.com/message/7493...

263 Messages

 • 

6.2K Points

Simon, the display is correct. The RGB readout is not. this is even true for proofing to the built in sRGB and adobeRGB profiles. This is also a problem with every single external profile. LR 5.7 did this correct. 2015 CC and 6 have a bad bug in the RGB display.

8 Messages

 • 

150 Points

This is not an operator error. This is a software bug. Please accept this.

87 Messages

 • 

2.1K Points

5 y ago

Hello All,

I apologize for the delay in addressing this issue (it was unfortunately overlooked and only brought to my attention last week). We were able to reproduce the issue in-house and identify the problem. A fix has been implemented and will be included in the next release of Lightroom. Thank you for bringing it to our attention.

2.1K Messages

 • 

25.1K Points

This issue was reported last April!
https://forums.adobe.com/message/7494...

Author “Color Management for Photographers" & "Photoshop CC Color Management" (pluralsight.com)

Champion

 • 

2.4K Messages

 • 

38.7K Points

5 y ago

Thank you Kelly–Much appreciated.

Champion

 • 

2.4K Messages

 • 

38.7K Points

5 y ago

Team Adobe Engineering I have discovered another issue with the Histogram values when NOT in Soft Proof mode. A 100% Blue Lab 0, 90 -128 (RGB 255, 0, 0) reads 0.1, 90.1, -172.3. The maximum Lab a b values are 127 to -128......-172.3 makes no sense and is incorrect!

2.1K Messages

 • 

25.1K Points

5 y ago

That -172.3 value is kosher for a 'color' value (device value) in a color space like ProPhoto RGB that isn't a visible color. PS truncates to 127 and -128 because those are legal and actual visible color values, B255 in ProPhoto RGB isn't.

>>Can you explain B255 not being a visible color value in more detail?

http://digitaldog.net/files/ColorNumb...

Author “Color Management for Photographers" & "Photoshop CC Color Management" (pluralsight.com)

Champion

 • 

2.4K Messages

 • 

38.7K Points

Andrew, thanks for the clarification. If PS and LR used the same Lab values it would be more helpful. Is this just a legacy compatibility issue in PS? If so perhaps a Preferences option to use the restricted 128 -127 "visible" values or the 'full-range' values would be a nice feature for LR users.

2.1K Messages

 • 

25.1K Points

The Photoshop Lab value read out's were designed long before synthetic RGB working spaces like ProPhoto, that define values that are not colors existed.

There's nothing inherent 'wrong' truncating' the Lab values as they are actually defined as we see in Photoshop. It's somewhat useful to see that a value that exceeds 128-127 as it informs the user these are not colors but device values. None the less, what Adobe really must do is make Lightroom and Photoshop behave the same and they haven't. So I'd kind of prefer to see Photoshop's info palette updated to act like LR's, along with the added precision. I've requested this, nothing yet.

Author “Color Management for Photographers" & "Photoshop CC Color Management" (pluralsight.com)

2.1K Messages

 • 

25.1K Points

5 y ago

The numbers provided in the soft proof ARE wrong, it's a known bug that should be fixed in the next release.

Author “Color Management for Photographers" & "Photoshop CC Color Management" (pluralsight.com)

2.1K Messages

 • 

25.1K Points

5 y ago

Downloading now to check Jeff.
NOT listed that I see on your site of bug fixes for this build:

Fixed several instability, functionality and performance issues introduced in Lightroom CC 2015.2.x/6.2.x.
Fixed a bug that caused edits made and saved in Photoshop or 3rd party plug-ins to not appear in the Develop module.
Fixed a bug related to user default for Chromatic Aberration Correction no longer honored after new Import option was removed.
Fixed several bugs related to Panorama Merge.
Fixed a bug so that Rotated photos will correctly show as rotated when in Full Screen view.
Fixed a bug that caused a performance slowdown when creating Standard sized previews on high resolution monitors.
Fixed a bug that caused image previews to be incorrectly displayed as completely black after import if “Auto Tone” is on in preferences.
Fixed a bug that caused crash when using the Radial or Graduated Filter.
Fixed a bug that caused Palette, a 3rd party hardware device, to stop working with Lightroom.
Fixed a bug that caused the Map module to appear pixelated and photos to be dropped in the wrong place when using hi-dpi monitors on Windows.
Fixed a bug related to Full Screen that prevented you from exiting Full Screen view while using the Spot Healing Tool.
Fixed a bug that caused the Flickr Publish Service to improperly publish multi-word keywords.

Author “Color Management for Photographers" & "Photoshop CC Color Management" (pluralsight.com)

2.1K Messages

 • 

25.1K Points

5 y ago

OK, seems to be fixed. ACR set to ProPhoto RGB (workflow options) and LR set the same in a soft proof produce the same values now on a Macbeth red. Yeah.

Author “Color Management for Photographers" & "Photoshop CC Color Management" (pluralsight.com)

1 Message

 • 

60 Points

5 y ago

I too can confirm this bug seems to be fixed. I compared a couple of files in LR 5.7.1 and LR CC 2015 9.4 and they were identical. Great!!!

Now we can finally use LR CC in our studio workflow.

Thanks all.

87 Messages

 • 

2.1K Points

5 y ago

Thanks for the verification.

Champion

 • 

2.4K Messages

 • 

38.7K Points

5 y ago

Thank you! I can confirm the soft proof values are now correct in LR CC 2015.4.

I also checked PS CC 2015.1.2 and it truncates Lab a b values to the "visible" range of 128 to -127. As suggested by Andrew Rodney it would be preferable if PS displayed the same "full-range" Lab a b values the same as LR, including the added decimal point precision (xxx.x).

It would be helpful if a PS option could be implemented to allow viewing the full range values as displayed in LR (xxx.x) or the current truncated 128 127 range values.