Skip to main content
Adobe Photoshop Family

2 Messages

 • 

80 Points

Fri, May 1, 2015 6:52 PM

Lightroom CC, painfully slow across the board on my system

First off, let me inform regarding my system specification. I am running on fifth gen i7, 16 GB ram, 1 TB SSD, and ATI Radeon R7 265 as GPU. The screen resolution for my system is UHD or 4K.

I am experiencing extremely slow operations in previewing photo and developing photo. So slow that it has made my productivity suffers greatly. Now, it is painfully slow whether I enabled GPU acceleration or not.

Is this a software glitch and that it's not fully optimized yet or should I expect it to perform like this for the foreseeable future so I can cancel my subscription?

Responses

4 Messages

 • 

100 Points

6 years ago

Try reducing the Reduce the Lightroom.exe process priority to "Below Average". I know i sounds counter intuitive but if its the issue it sounds like then should solve the issue.

I just posted this, might help

http://feedback.photoshop.com/photosh...

14 Messages

 • 

190 Points

Wow, thanks ... LR CC is nor FAR more rsponsive, nearly as fast as LR5 used to be! Thank you!

1 Message

 • 

60 Points

6 years ago

How do you reduce the "lightroom process" to below priority?

14 Messages

 • 

190 Points

Start LR, got to task manager, go to processes, find LR, right mouse click LR, at process priority choose "Below Average". You have to do this after each start up of LR. Or see this post:

http://feedback.photoshop.com/photosh...