Skip to main content
Adobe Photoshop Family

3 Messages

 • 

300 Points

Thu, Sep 22, 2016 4:49 PM

Answered

Lightroom CC: "Apply auto tone mix when first converting to black and white" gone

Where did "Apply auto tone mix when first converting to black and white" go in the latest release of LR CC (2015.7) The default is now set to AUTO and I have no way to fix this. The support representative told me they removed the option and fixed it to "Auto." WHY??!!

Responses

Official Solution

Adobe Administrator

 • 

8.1K Messages

 • 

116.9K Points

4 years ago

 

Adobe Photography Products

Quality Engineering - Customer Advocacy

89 Messages

 • 

1.5K Points

Dear Rikk, thank you.

That information and explanation has the logic of a certain presidential candidate to it: "It was removed because it's removed." - not exactly satisfying information. :-}

As I pointed out above, with the configuration option gone, it would be logical to NOT apply the Black & White Auto Mix then, OR alternative also apply the Auto-Tone adjustments to every photo (I guess that would make everyone VERY, very happy;-).

This would completely eliminate the need for any workarounds. For those who want the Black & White Auto Mix, it's just one mouse click away, just like the Auto-Tone Adjustments are.

3 Messages

 • 

300 Points

Couldn't agree more... why on earth would you just simply remove additional flexibility from your application?  The 'workaround' is just that... a 'workaround' that shouldn't have to exist.  It's extra motions. Using a preset requires extra mouse clicks, extra searching around the screen, etc.  I process over 175,000 images a year with LR.  Either enhance the application to allow us to program a preset to a keyboard shortcut, or simply allow us to decide wether we'd like to have the automix applied. 

5 Messages

 • 

192 Points

This is totally unacceptable for me. I mainly work in black & white and always use the V key to check and compare pictures in the Library. Now I should instead move my mouse over a preset? This will make my workflow much, much slower and less intuitive. I agree with what other poeple already wrote: you can't lock an AUTO function to be always ON, this is insane. I sincerely hope you will fix this ASAP.

4 Messages

 • 

92 Points

This is ridiculous. I use flat mix most of the time, and when I need auto mix, it's one click away. Now I installed LR 6.8 on a new PC, and I am stuck with auto-mix. I have to manually set every slider to "0" to get flat mix. If I double-click a slider label, it gets set to nothing, or effectively -100 (why?). I am not making a preset for something that should take one click or less.If Adobe doesn't bring flat mix back, I am leaving for On1 Photo RAW.

250 Messages

 • 

6K Points

Vladimir, double click on the "black and white mix" text above the sliders. It will reset them all to zero. I am annoyed too that the default neutral mix is gone but luckily you don't have to manually zero them all.

89 Messages

 • 

1.5K Points

4 years ago

I noticed that too and I hope that the option to have a truly "zeroed" black & white mix as a starting point will be restored.

I reverted to v6.6.1 for other reasons but I'm glad that I'm not the only one with this problem.

Champion

 • 

5.1K Messages

 • 

92.7K Points

4 years ago

I don't know why that option was removed, but you can easily work around this.   Select a test photo and in Develop, convert it to Black & White, and in the B&W panel, set all the Black&White Mix sliders to 0.  Then create a develop preset with these settings:



When you use the preset to first convert a photo to B&W, all the mix sliders will be zeroed.

3 Messages

 • 

300 Points

Clicking "V" to convert to black and white is MUCH easier and faster than searching through the presets and having to choose a preset.  I'm still scratching my head as to why on earth this is an 'enhancement' as the rep described to me.  

89 Messages

 • 

1.5K Points

4 years ago

I'm quite aware of ways to work around this and instead of fiddling around with yet another preset that I need to find :-) it's probably easier to just ALT-click to reset the sliders. But... WHY?

My main grievance is - IF that setting needed to be removed, for whatever weird reason, then at least don't apply the auto-mix to the black & white mixer. That logic would imply that the auto-tone adjustments (the preference setting is gone as well) would also be applied all the time, which is (just as) nonsensical.

Champion

 • 

2.1K Messages

 • 

36.8K Points

4 years ago

 Alexander S. Kunz mentions this, but it's worth repeating. There are two Preferences settings that have been removed in LR 6.7 and CC 2015.7. You won't see these LR 6.7 and CC 2015.7

Champion

 • 

5.1K Messages

 • 

92.7K Points

4 years ago

"Information on this can be found here: https://helpx.adobe.com/lightroom/kb/apply-auto-tone-mix-converting-black-white-preferences-removed.... "

That article needs improvement with respect to the deleted preference Apply Auto Mix When First Converting To Black And White:

1. For people who previously had that option checked, there's no need to use a workaround, since clicking Black & White in the Develop > Basic panel will now always apply the auto mix.

2. For people who previously had the preference unchecked, the article doesn't provide a solution.  It should include the workaround steps described here: https://feedback.photoshop.com/photoshop_family/topics/-apply-auto-tone-mix-when-first-converting-to...

3. An important step is omitted: Before creating a preset, you must be in Develop with a photo that has already been converted to B&W, otherwise, the Auto Black & White Mix option doesn't appear under Auto Settings.

5 Messages

 • 

192 Points

4 years ago

This reply was created from a merged topic originally titled Lightroom: Still experiencing auto tone mix when converting to black & white even....

Hi. So, I understand that the latest update of Lightroom (2015.7) makes auto tone mix when converting to graysale the deafult and it cannot be disabled. So I disinstalled Lightroom using the CC app, then installed the previous version (2015.6.1). Now I see that in the preferences menu I can uncheck the "apply auto tone mix", the problem is that even if if I uncheck it Lightroom is still applying auto tone mix when I press V. What can I do to disable this function?

Champion

 • 

5.1K Messages

 • 

92.7K Points

In the original topic, Victoria Bampton wrote:

You need to roll back further - it wasn't working due to a bug, even before it was removed. I'm not sure when it was last working though.

5 Messages

 • 

192 Points

Hi John, thanks for the information. I will try with earlier versions

89 Messages

 • 

1.5K Points

Interesting. I've had the "apply auto mix" option disabled for a very, very long time, and it works as expected for me after reverting to 2015.6.1 (ie. no auto-mix is applied when I press V or switch to B&W with the mouse).

If reverting to 6.6.1 doesn't resolve this for some users, that sounds almost like there's something stuck in the preferences then.

5 Messages

 • 

192 Points

It seems strange to me as well. 2015.6 did not work either, so I had to roll back to 2015.5.1, and it seems working fine now, at last (no auto grayscale mix when the option is disabled in the preferences). I'll be keeping a look at it though, my confidence in the program went down a bit thanks to this issue......

89 Messages

 • 

1.5K Points

Indeed. It seems odd to remove an option when it has a bug, instead of fixing the bug. Following that logic, one would remove the radiator from the car when it is leaking. ;-)

What you could try is to reset the preferences - copy your existing Lightroom preferences file away where Lightroom won't find it, and while Lightroom isn't running. Then start Lightroom so that it builds a default preferences file (just to compare - you can copy your old preferences file back afterwards).

There should be an entry for the Auto Gray Mixer then. For what it's worth, in my "Lightroom 6 preferences.agprefs" file it looks like this:

AgCameraRawNamedSettings_autoGrayMixer = false,

250 Messages

 • 

6K Points

4 years ago

Agreed. I do not like the auto mix. It is almost invariably the exact opposite of what I am going to end up with, so it maximizes the slider touches. I prefer to start from zero'd B+W mix sliders. The preference worked well for me. Don't understand why it was removed. I know I can work around this with presets and command-clicking to reset the sliders is trivial but this seems a loss in functionality. This seems another one of those decisions not unlike the import panel disaster that is based on bad or misinterpreted usage statistics.

14 Messages

 • 

242 Points

4 years ago

This reply was created from a merged topic originally titled Lightroom CC 2015.8 & Camera Raw 9.8 - B&W Auto Grayscale Mix as Default.

Dear Lightroom Team,

In Lightroom CC 2015.7, the B&W Auto Grayscale Mix preset option has been removed from preferences an auto grayscale is no longer applied when converting to b&w. Instead, a linear conversion has been applied.

In Lightroom CC 2015.8 however, b&w auto grayscale mix is applied by default and cannot be switched off as the preset option is gone. I consider this a bug as the new behaviour as introduced in CC2015.7 should apply henceforth.

I tried this with an existing as well as with an entirely new catalog. Further on, I even reinstalled Lightroom and cleared out all preferences before creating the new catalog.

Could you please check and correct in an upcoming version? Meanwhile, I'll be using a preset to neutralise the auto-toning after conversion.

Re Camera Raw - latest version 9.8 - the (wrong) behaviour is consistent with Lightroom i.e. b&w auto grayscale mix is applied by default. But it shouldn't if the intent was to disable it as implemented in LR CC 2015.7. And this happens despite "Apply auto grayscale mix" is off in the Camera Raw settings. Pressing Default in the conversion dialog restores a linear conversion. Again, could you please check and restore consitent functionality as intended? 

Kind regards,

Roland Meier

5 Messages

 • 

192 Points

4 years ago

This situation is terrible for many reasons. Here they come:

- LR now applies auto grayscale mix by default when I switch to Black and White. There is nothing I can do to stop this. I can correct it after the fact, but cannot stop this from happening. What are we moving towards here? When can we expect auto tone to be applied by default in Color mode? At what point will I no longer be allowed to turn these automatic adjustments off?

I could almost understand this in Photoshop Elements, but this amount of second guessing and overriding the user in Lightroom is not right.

- There is a help file that discusses the removed preferences. There is a help file that discusses applying auto grayscale mix on import. There is no help file that discusses how to remove auto grayscale mix. There is no help file that explicitly states that auto grayscale mix is applied by default.

- Double clicking on "Black and White Mix" to disable auto grayscale mix is not very discoverable. How about a single click on the "Auto" button? I tried that before searching the web for answers.

If I enable Black and White from the Basic panel, double clicking on that text does ... absolutely nothing. That ruins the convenience of that button for those who do not want auto grayscale mix.

1 Message

 • 

62 Points

3 years ago

Totally agree with Bruce!