Skip to main content
Adobe Photoshop Family

3 Messages

 • 

100 Points

Thu, Jun 2, 2016 4:44 PM

Solved

Lightroom CC 2015.5.1: Deselect via Shift+D no longer working

After updating to Lightroom CC 2015.5.1 (win7, german) I can no longer use the keyboard shortcut shift+d to deselect the current photo. Using the menu still works.
Any ideas? Please fix if this is a general bug.

Responses

Official Solution

Adobe Administrator

 • 

15K Messages

 • 

287.4K Points

4 years ago

This should be fixed in Lightroom 2015.8/6.8 or later.

Sr. Product Manager, Adobe Digital Imaging

Adobe Administrator

 • 

8.2K Messages

 • 

117.8K Points

4 years ago

I am not sure about German language version but have you tried [Cmd/Ctrl]+[D]? That is the shortcut I have always used in the English version. 
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

3 Messages

 • 

100 Points

4 years ago

That still works, but it deselects all selected photos - not just the current active one (sorry, I guess I missed the word 'active' in my initial description). My use case: I have several photos selected and use the survey mode so that I can see all selected ones. Now usually when I press shift+d only the active photo gets unselected and the number of visible photos is reduced by one. This way I narrow down my selection. 

Adobe Administrator

 • 

8.2K Messages

 • 

117.8K Points

I have never used a [Shift]+[D] in Survey mode. I either [Ctrl/Cmd]+Click or click on the little X lower right on the image to deselect. 
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

Employee

 • 

1.7K Messages

 • 

32.4K Points

4 years ago

There is a KBSC translation issue for German. 

There is a workaround.

1. On Windows via Explorer, locate the "C:\Program Files\Adobe\Adobe Lightroom\Resources\de\TranslatedStrings.txt" and open it in a text editor such as NotePad.
On Mac via Finder, locate the following file "/Applications/Adobe Lightroom/Adobe Lightroom.app/Contents/Resources/de.lproj/TranslatedStrings.txt" and open it in a text editor such as TextEdit.

2. Find the locate the following entry in the text file:

"$$$/AgLibrary/Menu/File/Edit/DeselectActive/Key=Umschalt+d"

3. Change it to 

"$$$/AgLibrary/Menu/File/Edit/DeselectActive/Key=Shift+d"

4. Then save your changes to the file.

Relaunch Lr. Then "shift+d" should work for you.

Principal Scientist, Adobe Lightroom

3 Messages

 • 

100 Points

4 years ago

Thank you for your reply, Simon!
This did indeed fix my problem.

Employee

 • 

1.7K Messages

 • 

32.4K Points

4 years ago

Good to hear. I've logged an internal bug for fix in a future Lightroom update. Thanks for reporting the issue.

Principal Scientist, Adobe Lightroom

20 Messages

 • 

324 Points

4 years ago

This reply was created from a merged topic originally titled Ligtroom Keyboard Shortcut "deselect active picture" used two times now.

I use the german version of Lightroom CC and used to use the keyboard shortcut "Shift D" to deselect the active picture when I selected a bunch of in Survey Mode.
But now it is also assigned to show/hide the filter bar on the secondary display. What it does all the time, even when I closed the secondary display, it jaust brings it back. The old function of the shortcut isn't working any more. Ist there a new one and they forgot to change it in the menu? I really need it back.

Champion

 • 

5.1K Messages

 • 

93.1K Points

It appears that the problem with the first post in this topic has been "fixed", but a new bug introduced. 

As a workaround, you can change the keyboard shortcut for the secondary monitor's filter view command, by changing this line in TranslatedStrings.txt:

"$$$/AgApplication/Menu/Window/SecondMonitor/FilterViewShortcut=Shift+d"

See here for details about customizing TranslatedStrings.txt.

Employee

 • 

1.7K Messages

 • 

32.4K Points

Thanks for the report. Investigating...

Principal Scientist, Adobe Lightroom

20 Messages

 • 

324 Points

Yeah that helped. I changed "$$$/AgApplication/Menu/Window/SecondMonitor/FilterViewShortcut=Shift+d" into "$$$/AgApplication/Menu/Window/SecondMonitor/FilterViewShortcut=Shift+>". Now it's working as it used to do. Hope they fix it. That I don't have to do this after every update.

Thanks.