Skip to main content
Adobe Photoshop Family
jarno_heikkinen's profile

29 Messages

 • 

706 Points

Wed, Oct 21, 2015 5:59 AM

Solved

Lightroom CC 2015.2.1: 100% CPU when Creative Cloud has logged out

I setup a new Windows computer (because the gradient tool is crashing on my Mac all the time), so I logged out all Creative Cloud instances. Next time I start Lightroom on my Mac, instead of seeing any error or license fail, I get 100% CPU usage. It took me a while tough to figure out what had happened, so a little license reminder would be nice. Reset preferences did nothing, but starting Creative Cloud manually solved it.

Here's the Lightroom -tracebacks output, I get about 200klines/s of that JSON error:


2015-10-21 08:37:12.649 Adobe Lightroom[1000:16936] Enabling noisy tracebacks.
objc[1002]: Class MacExePath is implemented in both /Library/Application Support/Adobe/OOBE/PDApp/P7/adobe_licutil.app/Contents/MacOS/adobe_licutil and /Library/Application Support/Adobe/AdobeGCClient/gcupdater.dylib. One of the two will be used. Which one is undefined.
2015-10-21 08:37:15.762 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "isSyncingUserInfo" = false
2015-10-21 08:37:15.762 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "fullName" = <removed>
2015-10-21 08:37:15.762 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "firstCollectionAutoSync" = 2
2015-10-21 08:37:15.762 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "hostIsReachable" = false
2015-10-21 08:37:15.762 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "hasValidConnectionToOz" = true
2015-10-21 08:37:15.763 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "lastName" = <removed>
2015-10-21 08:37:15.763 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "email" = <removed>
2015-10-21 08:37:15.763 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "firstName" = <removed>
2015-10-21 08:37:15.763 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "userInfoCachePath" = <removed>
2015-10-21 08:37:15.763 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "shouldSyncUserInfo" = false
2015-10-21 08:37:15.763 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "ozUserId" = <removed>
2015-10-21 08:37:15.764 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "accountStatus" = "subscriber"
2015-10-21 08:37:15.764 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "isLoggedIn" = true
2015-10-21 08:37:15.764 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "syncCollectionsByDefault" = true
2015-10-21 08:37:15.764 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "assetLimit" = 250000
2015-10-21 08:37:15.999 Adobe Lightroom[1000:16936]
InvalidJSONInput: lexical error: invalid string in json text.
fetchAccessToken failed with 67
(right here) ------^
at /Volumes/data/jenkins/workspace/Lightroom/release/6.2.1/mac-inst/main/imported/third_party/lua-yajl/lua_yajl.c line 262
0: field to_value - C
1: [unnamed] - 1732623682:43+40
2: global pcall - C
3: [unnamed] - 606274854:765+25
4: [unnamed] - 1225013964:1214+33
5: [unnamed] - tail
---------------------------------
2015-10-21 08:37:16.011 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "shouldSyncUserInfo" = true
2015-10-21 08:37:16.011 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "syncCollectionsByDefault" = false
2015-10-21 08:37:16.011 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "hasValidConnectionToOz" = false
2015-10-21 08:37:16.011 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "isLoggedIn" = false
2015-10-21 08:37:16.012 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "fullName" = nil
2015-10-21 08:37:16.012 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "lastName" = nil
2015-10-21 08:37:16.012 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "email" = nil
2015-10-21 08:37:16.012 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "firstName" = nil
2015-10-21 08:37:16.012 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "userInfoCachePath" = nil
2015-10-21 08:37:16.013 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "ozUserId" = nil
2015-10-21 08:37:16.013 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "accountStatus" = nil
2015-10-21 08:37:16.013 Adobe Lightroom[1000:16936] AgWFSyncModels DEBUG current user model info "assetLimit" = nil
2015-10-21 08:37:18.003 Adobe Lightroom[1000:16936]
InvalidJSONInput: lexical error: invalid string in json text.
fetchAccessToken failed with 67
(right here) ------^
at /Volumes/data/jenkins/workspace/Lightroom/release/6.2.1/mac-inst/main/imported/third_party/lua-yajl/lua_yajl.c line 262
0: field to_value - C
1: [unnamed] - 1732623682:43+40
2: global pcall - C
3: [unnamed] - 606274854:765+25
4: [unnamed] - 1225013964:1214+33
5: [unnamed] - tail
---------------------------------
2015-10-21 08:37:20.008 Adobe Lightroom[1000:16936]
InvalidJSONInput: lexical error: invalid string in json text.
fetchAccessToken failed with 67
(right here) ------^
at /Volumes/data/jenkins/workspace/Lightroom/release/6.2.1/mac-inst/main/imported/third_party/lua-yajl/lua_yajl.c line 262
0: field to_value - C
1: [unnamed] - 1732623682:43+40
2: global pcall - C
3: [unnamed] - 606274854:765+25
4: [unnamed] - 1225013964:1214+33
5: [unnamed] - tail
---------------------------------
2015-10-21 08:37:20.010 Adobe Lightroom[1000:16936]
InvalidJSONInput: lexical error: invalid string in json text.
fetchAccessToken failed with 67
(right here) ------^
at /Volumes/data/jenkins/workspace/Lightroom/release/6.2.1/mac-inst/main/imported/third_party/lua-yajl/lua_yajl.c line 262
0: field to_value - C
1: [unnamed] - 1732623682:43+40
2: global pcall - C
3: [unnamed] - 606274854:765+25
4: [unnamed] - 1225013964:1214+33
5: [unnamed] - tail
---------------------------------
2015-10-21 08:37:22.007 Adobe Lightroom[1000:16936]
InvalidJSONInput: lexical error: invalid string in json text.
fetchAccessToken failed with 67
(right here) ------^
at /Volumes/data/jenkins/workspace/Lightroom/release/6.2.1/mac-inst/main/imported/third_party/lua-yajl/lua_yajl.c line 262
0: field to_value - C
1: [unnamed] - 1732623682:43+40
2: global pcall - C
3: [unnamed] - 606274854:765+25
4: [unnamed] - 1225013964:1214+33
5: [unnamed] - tail
---------------------------------
2015-10-21 08:37:22.009 Adobe Lightroom[1000:16936]
InvalidJSONInput: lexical error: invalid string in json text.
fetchAccessToken failed with 67
(right here) ------^
at /Volumes/data/jenkins/workspace/Lightroom/release/6.2.1/mac-inst/main/imported/third_party/lua-yajl/lua_yajl.c line 262
0: field to_value - C
1: [unnamed] - 1732623682:43+40
2: global pcall - C
3: [unnamed] - 606274854:765+25
4: [unnamed] - 1225013964:1214+33
5: [unnamed] - tail
---------------------------------
2015-10-21 08:37:22.011 Adobe Lightroom[1000:16936]
InvalidJSONInput: lexical error: invalid string in json text.
fetchAccessToken failed with 67
(right here) ------^
at /Volumes/data/jenkins/workspace/Lightroom/release/6.2.1/mac-inst/main/imported/third_party/lua-yajl/lua_yajl.c line 262
0: field to_value - C
1: [unnamed] - 1732623682:43+40
2: global pcall - C
3: [unnamed] - 606274854:765+25
4: [unnamed] - 1225013964:1214+33
5: [unnamed] - tail
---------------------------------
2015-10-21 08:37:22.013 Adobe Lightroom[1000:16936]
InvalidJSONInput: lexical error: invalid string in json text.
fetchAccessToken failed with 67
(right here) ------^
at /Volumes/data/jenkins/workspace/Lightroom/release/6.2.1/mac-inst/main/imported/third_party/lua-yajl/lua_yajl.c line 262
0: field to_value - C
1: [unnamed] - 1732623682:43+40
2: global pcall - C
3: [unnamed] - 606274854:765+25
4: [unnamed] - 1225013964:1214+33
5: [unnamed] - tail
---------------------------------

Responses

Official Solution

Employee

 • 

1.7K Messages

 • 

32.4K Points

5 years ago

Lightroom CC 2015.3/6.3 is available today that fixed this bug.

Details here: http://blogs.adobe.com/lightroomjourn...

Principal Scientist, Adobe Lightroom

Employee

 • 

1.7K Messages

 • 

32.4K Points

5 years ago

This is a known issue and will be fixed in the 6.3.


In the meantime, try the following workaround to try to sign out and sign back into your CC account:

1. Stop Lightroom.
2. Open the CC app.
3. If you are not logged in to the CC app
    a. Log in to the CC app
    b. Start Lightroom 
    c. Is it fixed? 
    d. If not, if you check the CC app, are you still logged in?
4. If you are logged in to the CC app
    a. Log out of the CC app
    b. Close the CC app.
    c. Open Activity Monitor and find the CCLibrary Process, kill it
    d. Open the CC app
    e. Log in to the CC app
    f. Start Lightroom
    g. Is it fixed?
    h. If not, if you check the CC app are you still logged in?

Principal Scientist, Adobe Lightroom