Skip to main content
Adobe Photoshop Family

9 Messages

 • 

526 Points

Mon, Apr 27, 2015 10:14 PM

Solved

Lightroom 6: TIFF file reloads after each Develop edit, potential data loss

LR6 (CC), edit TIF file (imported from PS or NIK). Image "reloads" after almost every Develop module edit. In some cases, all previous Develop module settings are lost, and the image reverts to it's original appearance. Even though the previous Develop module edits are still shown on the History panel - they no longer have any effect. Result - total loss of all user edits.

Workaround: disable "Automatically write changes to XMP" in catalog settings. This is what appears to trigger the constant "reloads".

Note this does not appear to be related to GPU - the problem occurs exactly the same whether GPU is enabled or disabled. Also note, the problem does NOT occur when editing RAW files. So far, it appears to occur only with TIF files.

Lightroom CC, 2015 Release
Windows 7, 64-bit, all latest updates
AMD Radeon HD 7700, latest AMD drivers

Responses

23 Messages

 • 

300 Points

5 years ago

Yay, I think they fixed the problem. With the new CC update. I installed it, I ticked the write to XMP files, took a file out of Lr to On One, did some adjustments, brought it back, and no issues. Threw it back to Ps, and another external plug in, brought it back and still no issue. Thanks Adobe.

23 Messages

 • 

300 Points

5 years ago

Well i was premature with my last post. now, everything is back to the way it was before. Sorry for the misinformation. Come on Adobe this needs fixed.

10 Messages

 • 

150 Points

5 years ago

I got all excited when I saw Larry's first post, but I see he is right with his second post. One thing I've noticed though, at least in my case, if I edit in Photoshop and choose "Edit Original," I do get the reloading on further edits in Lightroom. However, if I select "Edit a copy with Lightroom adjustments," the copy returned from Photoshop seems to be OK. I've only tested this once so far, but I will report back if this doesn't prove to be consistent with other images.

3 Messages

 • 

80 Points

5 years ago

Two quick tests as an original file and as a copy and both seem to work fine. Will try again tomorrow to make sure. Thanks so much for the fix!!!!!!!!

5 Messages

 • 

100 Points

5 years ago

What about stand-alone LR6 ?

Champion

 • 

2.6K Messages

 • 

33.7K Points

5 years ago

LR 6.1 is the standalone version and LR 2015.1 is the CC version. Bug fixes would be in both. New features would only be in CC.

5 Messages

 • 

100 Points

5 years ago

Another possible workaround the edit reloading issue: Unchecking the "always write to xmp" in lr "catalogue Settings"may cause metadata loss if catalogue gets corrupted.So with that box unchecked, the reloading stops,so to save data, select all images edited and go to Metadata,scroll down and choose "save metadata to files", since metadata is not being saved toXMP.

5 Messages

 • 

100 Points

5 years ago

Where do you find theLR6.1 upgrade?

9 Messages

 • 

200 Points

5 years ago

If it's fixed we can safely recheck the "auto write to xmp" box I guess

2 Messages

 • 

70 Points

5 years ago

Joseph, go to Help and "Check for Updates" if using Windows and you are using a standalone version of LR. If using Adobe Cloud then the Cloud app should prompt you to update automatically. Mine did anyway.

5 Messages

 • 

100 Points

Brian, thanx for the suggestion! Whent into "check for updates", updated to LR6.1 and the "reloading" went away!!!, Joe

5 Messages

 • 

100 Points

5 years ago

The problem is solved after the update!

(I tried with Silver Efex Pro 2 and HDR Efex Pro 2).

Thanks for the support.

Paul

5 Messages

 • 

102 Points

5 years ago

No it is not solved. I just took a picture from lightroom to photoshop and back again. Every adjustment I make to the tiff file in lightroom (curves, grain, clarity, anything) causes the image to reload, same as before.

FIX THIS, ADOBE.

Adobe Administrator

 • 

14.9K Messages

 • 

285.7K Points

It may help if we had your system info. Go to Help>System Info... and copy/paste the text from that dialog here.

Sr. Product Manager, Adobe Digital Imaging

10 Messages

 • 

150 Points

Seth, did you check to make sure your system did in fact update to the latest release, Lightroom CC 2015.1 or Lightroom 6.1? I had to run update separately to get it, because I have auto updates turned off. I've run adjustments like you did on two different tiff files, and no problems so far.

5 Messages

 • 

102 Points

System Info

Lightroom version: CC 2015.0.1 [ 1018573 ]
License: Creative Cloud
Operating system: Mac OS 10
Version: 10.10 [3]
Application architecture: x64
Logical processor count: 4
Processor speed: 2.5 GHz
Built-in memory: 8,192.0 MB
Real memory available to Lightroom: 8,192.0 MB
Real memory used by Lightroom: 491.5 MB (5.9%)
Virtual memory used by Lightroom: 2,274.9 MB
Memory cache size: 70.1 MB
Maximum thread count used by Camera Raw: 2
Camera Raw SIMD optimization: SSE2
Displays: 1) 1440x900

Graphics Processor Info:
NVIDIA GeForce GT 330M OpenGL Engine

Check OpenGL support: Passed
Vendor: NVIDIA Corporation
Version: 3.3 NVIDIA-10.0.31 310.90.10.05b12
Renderer: NVIDIA GeForce GT 330M OpenGL Engine
LanguageVersion: 3.30

Application folder: /Applications/Adobe Lightroom
Library Path: /Volumes/IcarusVR/Lightroom/Lightroom Catalog.lrcat
Settings Folder: /Volumes/Icarus Media/Users/Icarus/Library/Application Support/Adobe/Lightroom

Installed Plugins:
1) Aperture/iPhoto Importer Plug-in
2) Behance
3) Canon Tether Plugin
4) Facebook
5) Flickr
6) Leica Tether Plugin
7) Nikon Tether Plugin

Config.lua flags: None

Updated Toolkit: Adobe Camera Raw 9.0 for Lightroom 6.0 (build 1014445)
Updated Toolkit: Book Module 6.0 (build 1014445)
Updated Toolkit: Develop Module 6.0 (build 1014445)
Updated Toolkit: Import Module 6.0 (build 1014445)
Updated Toolkit: Library Module 6.0 (build 1014445)
Updated Toolkit: Map Module 6.0 (build 1014445)
Updated Toolkit: Print Module 6.0 (build 1014445)
Updated Toolkit: Slideshow Module 6.0 (build 1014445)
Updated Toolkit: Web Module 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.AgNetClient 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.AgWFBridge 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.Headlights 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.LibraryToolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.MultiMonitorToolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.archiving_toolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.bridgetalk 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.catalogconverters 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.cef_toolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.coretech_toolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.curculio 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.discburning 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.email 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.export 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.ftpclient 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.help 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.iac 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.imageanalysis 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.layout_module_shared 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.pdf_toolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.sdk 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.sec 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.socket 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.store_provider 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.substrate 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.ui 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.video_toolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.webview_toolkit 6.0 (build 1014445)
Updated Toolkit: com.adobe.ag.xml 6.0 (build 1014445)
Updated Toolkit: com.adobe.wichitafoundation 6.0 (build 1014445)
AudioDeviceIOBlockSize: 512
AudioDeviceName: Built-in Output
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: Uninitialized
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 2048
GL_MAX_TEXTURE_SIZE: 8192
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 8192,8192
GL_RED_BITS: 8
GL_RENDERER: NVIDIA GeForce GT 330M OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: NVIDIA Corporation
GL_VERSION: 2.1 NVIDIA-10.0.31 310.90.10.05b12
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_point_sprite GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod

5 Messages

 • 

102 Points

I guess mine hasn't updated yet if it says 2015.0.1? How do I get it to update? Shouldn't CC do it on it's own?

Adobe Administrator

 • 

8.2K Messages

 • 

117.4K Points

It should. Go to your Adobe Creative Cloud app and sign out - then sign in again (via Preferences) and see if that tickles it through.
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

33 Messages

 • 

492 Points

5 years ago

The 2015.1 release fixed the problem for me!

Going back and forth from LR to PS or SilverEfex tiffs back into LR and then doing LR adjustments: no reloading, no loss of edits. All good.

Thanks for the pretty quick fix/release.

Seth, not sure why you are still seeing this. Are you sure you have the new version installed?

2 Messages

 • 

70 Points

5 years ago

light room 6.0 update to 6.1, as long as you are in the library tab every thing is working ok, the second you go to the develop tab and bring a photo to work on it that's when Light room stops responding.

Champion

 • 

2.6K Messages

 • 

33.7K Points

May be a problem with the GPU.

Go to LR / Prefs / Performance and turn off Graphics Acceleration.

BTW, this is not what the original thread was about.

2 Messages

 • 

70 Points

Sorry about putting this in wrong place.

14 Messages

 • 

286 Points

5 years ago

This reply was created from a merged topic originally titled Lightroom keeps resetting develop settings on TIFF files once if they are saved i....

Pretty much the same bug as this one;
https://feedback.photoshop.com/photoshop_family/topics/bug-lr6-tif-file-reloads-after-each-develop-e...

However the XMP checkbox is unticked in catalogue settings.

Lightroom 2015.4