Skip to main content
Adobe Photoshop Family

2 Messages

 • 

104 Points

Sat, Sep 30, 2017 8:40 AM

Lightroom 5.7 not working after Mac 10.13 High Sierra installation

After opening error message comes up saying module change created error. No photos/images visible (though number of photos - in this case 63,000 - are visible at the bottom). Changing module creates more error messages. Followed by crash. Basically nothing works, nothing accessible. iMac 2012 NVIDIA GeForce GT 640M

Responses

81 Messages

 • 

1.1K Points

3 years ago

As far as I know, Adobe hasn't updated anything to work with High Sierra, It uses a completely new Disk format, which is why your photos are missing unless they are on an external?Me personally: I'm avoiding 10.13 for at least 6 months!

Champion

 • 

3.2K Messages

 • 

56.7K Points

3 years ago

Sorry, but this is nonsense. Photos don't get missing because of the new disk format. They are still where they were, and Lightroom should still see them. I don't know about Lr 5.7, but Lr 6 certainly works on High Sierra and does see its images. Try resetting the preferences (hold the Shift-Option-Delete keys while starting Lightroom) to see if that works.

Johan W. Elzenga,

http://www.johanfoto.com

81 Messages

 • 

1.1K Points

Clearly, you haven't read the readme with High Sierra, it is not a new file format, the entire disk drive is reformatted, so if LR isn't updated the disk is simply unreadable to the App! Read Victoria Bampton's Post as Lightroom Queen below link repeated here: https://www.lightroomqueen.com/lightroom-macos-high-sierra-compatibility/

So make sure you have an updated version of Lightroom first, otherwise, the images will still be missing, you need a version of Lightroom that is High Sierra compatible, for the images to be seen!

Champion

 • 

3.2K Messages

 • 

56.7K Points

Yes, I read it and I understood it. What you say about unreadable disks is simply not true. Lightroom only looks for images in folders, using simple folder paths. The underlying disk format has nothing to do with that. It can be HFS+, ExFAT or anything else. As long as MacOS X can read it, Lightroom running on MacOS X can.

High Sierra's new disk format still shows you images in folders, and that is all what Lightroom needs. It turns out that Lr5.7 works fine, just as I expected. And the solution was what I suggested; reset the preferences. See farther down this discussion. Besides, the OP wasn't talking about missing images in the first place. That was never his problem.

BTW: did you actually read the link you gave above? That links says that older versions work, although there are some issues. None of these issues is about missing images or unreadable disks...

Johan W. Elzenga,

http://www.johanfoto.com

1 Message

 • 

62 Points

WOW, holding the shift, option delete key while launching Lightroom 5 worked.  Unfortunately I have to do this every time I open it, but will probably upgrade LR anyway.  thanks 

Champion

 • 

5.3K Messages

 • 

95.5K Points

3 years ago

Here's what Victoria Bampton (Lightroom Queen) says about 10.13 (High Sierra) compatibility with older Lightroom versions: 
https://www.lightroomqueen.com/lightroom-macos-high-sierra-compatibility/

She's usually quite authoritative.  

119 Messages

 • 

2.5K Points

3 years ago

It should be noted that LR5.7 is a legacy app and is no longer supported with updates.   The solution is to update to LR6.12.    LR6.12/CC2015.12 is not impacted by the update to High Sierra and indeed works as expected with MacOS 10.13 on my iMac..    Currently the new APFS is not compatible with the Apple fusion drives, only SSDs. And as such only Macs with an SSD are presently being converted to the new file system.  If your iMac like mine sports a fusion drive it still runs HFS+. 

Champion

 • 

5.9K Messages

 • 

103.9K Points

3 years ago

I just upgraded a VM, as well as my MacBook Pro that I did a week or two back, before I wrote the post. The good news is 5.7.1 opened and worked as I described.

So we have to figure out why it's not working for you...

Error changing modules isn't an error we see often these days, but first port of call would be this tech note: https://helpx.adobe.com/lightroom/kb/error-changing-modules-lightroom.html

Victoria Bampton a.k.a. The Lightroom Queen

www.lightroomqueen.com

Author of Adobe Lightroom Classic - The Missing FAQ and Adobe Lightroom - Edit Like a Pro books.

2 Messages

 • 

104 Points

Thank you so much Victoria. I followed your link and deleted the pref file (also deleted a couple of other pref files too for good measure, maybe foolhardy?). Problem SOLVED! After a few new welcome screens all photos back to normal. I cannot tell you how pleased I am. Took some pics today and was thinking they'd have to stay on the card until I sorted this out, but no...

FWIW, in reply to some comments above. The photos were never missing or changed. It was just that they were not visible in Lightroom. And yes I could upgrade, but since this works fine for my needs, why should I? Maybe I will when I get a new Mac.

Also FWIW yes this mac does have a fusion drive, but I have a feeling that was not the problem here - I don't think the file format has changed for these computers yet. And anyway the photos are on an external drive.

81 Messages

 • 

1.1K Points

Cool, I'm glad you got it sorted :)me personally I'm avoiding 10.13 like the plague, for at least 6 months! :)

54 Messages

 • 

1.4K Points

3 years ago

I just ran into the "Error changing modules" message out of nowhere last night with the latest version of Lightroom CC on my iMac running 10.13, but not the new disk format (everything is still HFS+). Trashing preferences has helped, but the startup catalog list still isn't retaining all of my catalogs.

1 Message

 • 

60 Points

3 years ago

So, I really need help. I recently had lightroom crash with 4317 of my working edited photos on it.  I panicked and brought it to a computer repair place to have them help me restore lightroom.  Two days later they called me to come get it, I came home, opened lightroom and every single photo is missing.  I COMPLETELY understand that the photos are not stored in lightroom (if one more person tries to explain this to me I will freak out). However, this is where I worked on the photos and the edits/changes I made to all these photos are stored in the lrcat.  Soooo, turns out the computer guys updated my Operating System to HIgh Sierra and now the photos are not longer in iphoto but in photos.  I cannot figure out for the life of me how to get them back into lightroom with the original edits.  I cannot even drag and drop them into lightroom like I used to, and when I try to export OR import, the photos category is grayed out and inaccessible.  Please someone help! I am a photographer and this is one years worth of work. 

Champion

 • 

5.9K Messages

 • 

103.9K Points

Oh boy Jessica. That's going to be a job and a half if you imported them from the iPhoto package without copying them to a "normal" location. On the upside, it is fixable, but Lightroom 5 isn't supported on High Sierra, so you may need to upgrade if you run into problems with the program itself.

First things first, do you have a backup of your iPhoto Library? Perhaps on Time Machine or another external hard drive.

Victoria Bampton a.k.a. The Lightroom Queen

www.lightroomqueen.com

Author of Adobe Lightroom Classic - The Missing FAQ and Adobe Lightroom - Edit Like a Pro books.