lrsuer24's profile

427 Messages

 • 

7.7K Points

Fri, Apr 27, 2012 9:28 AM

Lightroom 4.1RC2: Very strange behaviour of clarity for a specific image

The clarity test image posted in the other thread : https://d37wxxhohlp07s.cloudfront.net... exhibits a very strange behaviour in LR4.1RC2: It nearly completely turns black for clarity +50: https://d37wxxhohlp07s.cloudfront.net...

Is this intended or a bug?

P.S. In the other thread where the properties of clarity were discussed, http://feedback.photoshop.com/photosh..., the effects on that image in LR 4.1 RC1 was clearly different from LR3 and perhaps not what everybody would expect, but at least the overall image was OK and still visible and not completely "corrupted" like in RC2 here.

Responses

Official Solution

Employee

 • 

478 Messages

 • 

10.7K Points

9 y ago

This issue has been fixed in Lightroom 4.1, which is now available. To download the 4.1 update, go to the Help menu in Lightroom and choose "Check for Updates".

Thanks,
Ben

4.5K Messages

 • 

76.3K Points

There were 2 issues (see my post above).
So far, I have only checked the behavior on "Cemal's squares" - it's better.

Lr4.1 seems to have fixed a lots of stuff - good job Adobe! - whew!! - R.

427 Messages

 • 

7.7K Points

9 y ago

Additional information: This seems to happen if in a JPEG/TIFF image, a significant portion of the image is completely black (0/0/0). It does *not* happen if this portion is nearly-black (e.g. 1/1/1). I will post sample images in a moment.

Original images: The black rectangle in first one has RGB values 0/0/0, and the second one has 1/1/1:





And now the images with clarity +50 applied:





Looks like a bug to me.

66 Messages

 • 

1.2K Points

9 y ago

Looks like a graphics driver problem rather than Lightroom. Do you have the latest drivers and OGL enables etc?

427 Messages

 • 

7.7K Points

The last two are exported images, not screenshots. Nearly impossible that this has something to do with graphics drivers.

Just to be sure, I checked: Graphics card is Nvidia GeForce GT 520 with driver version 296.10, which is the most recent one.

OpenGL is enabled, which is however only relevant for Videos. Again: Just to be sure: Same effect with OpenGL off.

Edit: Just to clarify in case there was a misunderstanding: The black rectangle is not the problem - I painted that into the picture myself ;-) .... the problem is how clarity reacts on a large image region with RGB 0/0/0.

4.5K Messages

 • 

76.3K Points

9 y ago

It seems clarity has changed between Lr4RC1 & Lr4RC2.

Adobe - please comment about this.

427 Messages

 • 

7.7K Points

There is a remark in the RC2 release notes: "Fixed Issues: (...) Clarity adds grey tinting to 100% white tones." Perhaps this fix causes the different behaviour.

4.5K Messages

 • 

76.3K Points

If it just did what it says, it would not be a problem - the tones affected in this example were not 100% white, right?

I mean, the behavior in Cemal's example is radically different (and presumably "wrong") on a wide range of greyscale tones, right again? See link:

http://feedback.photoshop.com/photosh...

4.5K Messages

 • 

76.3K Points

9 y ago

Adobe - this *must* be fixed before final release - please acknowledge.

Another example here:

http://forums.adobe.com/thread/995958...

6 Messages

 • 

176 Points

9 y ago

More examples in this thread here - it's proved to be an issue for me in editing several high contrast photos
http://forums.adobe.com/thread/997568...

4.5K Messages

 • 

76.3K Points

9 y ago

Clarity was changed in RC2 (Lr4.1). Some of the differences are independent of lens corrections.

Cemal's squares show no artifacts, but the difference in clarity effect is very noticeable:

http://feedback.photoshop.com/photosh...

Sounds like some behavior is influenced by lens corrections too...

130 Messages

 • 

2K Points

9 y ago

LR4.1 RC2 has an addtional Clarity bug that introduces very bad aliasing artifacts in high contrast areas. This occurs when any of the Lens Corrections 'Transform' tools or Lens Profile 'Distortion' are used. The Shadow tool produces the same aliasing artifacts. See these posts for more details:

http://forums.adobe.com/thread/997568...

http://forums.adobe.com/thread/995958...

5 Messages

 • 

132 Points

9 y ago

I have the same issue with some photos (jpg and tif) as well.
Reproducable with pictures that have "a significant portion of the image is completely black (0/0/0)" - as stated above - even after cropping the black parts away...

4.5K Messages

 • 

76.3K Points

Clearly there are two aspects:
1. Those that have more to do with large black regions, and *not* lens corrections.
2. Those that have to do with lens corrections.

Note: Slider behaviors and image adaptation are governed by the tonal distribution of the *entire* photo, not just the cropped region!

127 Messages

 • 

3K Points

9 y ago

Great test images - thank you. I've logged a bug.

7 Messages

 • 

130 Points

9 y ago

so this could be only a clarity bug into RC2?
Look at this, thanks.

http://forums.adobe.com/message/44611...

4.5K Messages

 • 

76.3K Points

Right - the "big black area" clarity bug which existed in RC2 has been fixed in Lr4.1 final.

7 Messages

 • 

130 Points

but also with v4 and 4.1 rc1 I have the same correct results... I dont undestand sorry.
here http://www.nikonclub.it/forum/index.p... removed gradient clarity.

427 Messages

 • 

7.7K Points

FYI: I also answered in your original u2u-forums-thread: Yes, this really seems to be another problem, when 4.0 and 4.1 final have such huge differences in rendering. Probably warrants its own problem thread.