Skip to main content
Adobe Photoshop Family

7 Messages

 • 

154 Points

Sun, Apr 29, 2012 4:16 AM

Lightroom 4 slow and crashing

Lightroom 4 runs very slowly in develop module, very juddery nothing is smooth sliders resizing, brush tool etc. and also keeps crashing

Responses

Champion

 • 

704 Messages

 • 

8.5K Points

9 years ago

See: http://feedback.photoshop.com/photosh...

Is this related to what you are seeing?

7 Messages

 • 

154 Points

9 years ago

Yes John, thanks for the link unfortunately it looks like Adobe hasn't fixed the problem yet. Shame they didn't do more testing before they released it. Would have saved them a lot of embarrassment and us a lot of frustration.

Champion

 • 

220 Messages

 • 

4.1K Points

9 years ago

Have you tried Lr4.1RC2 available from Adobe Labs?

7 Messages

 • 

154 Points

9 years ago

No Geoff, but looking at some of those who have its not made much difference, is that correct?

Champion

 • 

220 Messages

 • 

4.1K Points

9 years ago

No, it really has made a difference for most. I am using it and while there are still some issues (2nd monitor lag, etc) performance is very good. Mind you I haven't had the issues others have, no rhyme, no reason!!

3 Messages

 • 

88 Points

9 years ago

Of course, the first I've heard of 4.2 RC is here in this thread. That's a shame Adobe.
I'm running 4.1RC but wouldn't being informed that 4.2 is out. Brother.

7 Messages

 • 

154 Points

9 years ago

I'm just downloading LR4.1RC2 so we'll see how it runs

7 Messages

 • 

154 Points

9 years ago

Well LR4.1RC2 does seem to work better but still slow in develop especially when working at 100% doesn't move smoothly when navigating around image, but much better than LR4 it hasn't crashed yet either