Skip to main content
Adobe Photoshop Family

163 Messages

 • 

3.8K Points

Mon, Jul 11, 2016 9:06 AM

Lightroom 2015.6: Interactive speed/GPU usage

In LR 2015.6 and maybe(!) also in earlier versions, I have a problem with interactive speed while draging the sliders:


Right after I start LR and maybe for some more minutes, I have perfect interactive speed while draging sliders in the develop module (with GPU enabled).


But then, all of a sudden, this interactive speed gets noticable worse and even the GPU usage (watched by a desktop widget) goes down. It ́s as if the GPU isn ́t used anymore for some things. Unchecking and and rechecking GPU in the preferences doesn ́t help. Only a restart of LR.


I have no clue, why this happens, or what I have to do to make it happen. I just can ́t repro it. But it happens everytime I use LR.




BTW. I`m on WIN 8.1, 5930K@4,1ghz, 32GB RAM, GTX 970.


LR in general runs pretty fast. But something is happening after a few minutes. The program in general does not get any slower. It ́s just the interactive speed and GPU usage that goes down.


RAM and VRAM are not maxxed out, if it happens. I still have at least 50-70% left.


Responses

Employee

 • 

1.7K Messages

 • 

32.4K Points

4 years ago

Try this

  1. Open Lightroom.
  2. Invoke Lightroom > Preferences... menu command
  3. When the Preferences dialog appears, select the Presets tab.
  4. Click on the button labeled “Show Lightroom Presets Folder...”
  5. Lightroom will reveal the root preset folder in the Finder/Explorer.
  6. Now goto http://adobe.ly/29s13pW and download the config.lua file and copy it into the root preset folder at step 5.
  7. Relaunch Lr and see if you can go further than it used to be without the config.lua.
  8. Remove or rename the config.lua from the root preset folder after the experiment (to restore to the original Lr 6.6 behavior).

Principal Scientist, Adobe Lightroom

2.6K Messages

 • 

33.7K Points

Step 4 needs to be done without the Store Presets with Catalog checkbox enabled. 

If you do store your presets with your catalog, you can temporarily uncheck it, click the button to Show Presets (which will be the non-catalog-relative location) then put the checkmark back so your presets are used from the catalog-relative location if they were, before.

And Step 5, at least using Windows, will highlight a folder.  You need to put the config.lua inside that folder, so open that folder if necessary, before pasting the config.lua.

163 Messages

 • 

3.8K Points

Thanks for that, Steve!

Now I just need to find some time to test again....

2.6K Messages

 • 

33.7K Points

You can check Help / System Info... to see if the config.lua flags section has anything in it or not.  That way you know if the config.lua is the correct place and being used.

163 Messages

 • 

3.8K Points

4 years ago

Hi Simon,

thanks for your help. I ́ll try that. But what ́s that file gonna do actually?

Employee

 • 

1.7K Messages

 • 

32.4K Points

4 years ago

The file is a Lightroom configuration file that contains some settings to scale back RAM usage for caching the previously loaded negatives. It also generates a log file named "AgNegativeCache.log" inside your "Documents" folder in case we need it to troubleshoot further.

Principal Scientist, Adobe Lightroom

587 Messages

 • 

11.2K Points

It also generates a log file named "AgNegativeCache.log" inside your "Documents"
Is this file generated only in case of problem? I can't find it. I have checked in Help | System Info that config.lua has been taken into account.

Thanks.

Employee

 • 

1.7K Messages

 • 

32.4K Points

Hi Patrick, I've got feedback from others that we have determined the root cause of this particular issue (slow down over time). For that reason, I've removed the logging from the current config.lua download so that it will not accumulate the log. The actual fix will be in the next Lr update. If this config.lua improves things for you, you should pick up the next Lr update when it is available. And make sure to remove/rename the config.lua by then. 

Principal Scientist, Adobe Lightroom