rod_laird_looa3irmeud4's profile

2 Messages

 • 

80 Points

Mon, Feb 24, 2020 2:36 AM

ISO specific presets do not allow camera profile! Grrrrrr

I had previously set up import preset defaults that were ISO specific and which allowed specification of a camera profile specific to each ISO as well as noise reduction settings. This allows for the skew of colour profiles that increases with ISO - particularly at high ISOs.

9.2 has broken all of that.

So I used the Adobe provided ISO-specific example which suggested the following repeat group for each ISO value:

     <rdf:li

      crs:ISO="xISO"

      crs:CameraProfile="xISOProfile"

      crs:LuminanceSmoothing="xISOsmooth"/>

The CameraProfile text represents the profile that would be specified. (i have dummy placeholders preceded by x where I substitute values.

I wrote an Excel spreadsheet that would allow me to generate custom import parameters for each of my cameras and all the camera profile naming conventions I have used over the years and camera models. My Sony A7's have in excess of 30 ISOs for which I generate custom colour profiles, so the list of custom presets is long. The spreadsheets lets me set ISO specific parameters in a table as well as generating the custom profile names.

Here is an extract showing this customisation from my generated XMP:

    <rdf:li
       crs:ISO="50"
       crs:CameraProfile="ILCE 7RM4 ISO000050"
       crs:LuminanceSmoothing="1"/>

The camera profile parameter works if placed in the <rdf:Description ... > body. (So I know the naming convention / syntax is correct) But it does not work in the ISO dependent body. The luminance smoothing works.

So this is REALLY ANNOYING!!!! They have taken something that worked just fine and borked it.

If you are interested in the Excel generator it is available here. There is no documentation, it has just been quickly put together for personal use - but it will enable anybody interested to see how the Adobe template was "mined" and reformated to generate a custom version. I suspect this will work for parameters other than the camera profile... If you have some Excel chops you can work out what to do.

This should really NOT be this hard and is very disappointing.

Any tips on solving this of course appreciated - but I suspect this is now locked in as a "feature"





Responses

1.2K Messages

 • 

13K Points

1 y ago

9.2 introduced a whole raft of bugs, fortunately they seem to be isolated to usability issues. They are certainly irritating and I would vote for Adobe to roll back to 9.1.

2 Messages

 • 

80 Points

1 y ago

There is a fundamental design change here so roiling back just postpones the problem. Other posts i have read suggest rolling back would in any case not restore my previous presents. I can certainly restore my system state from my regular snapshots and that would be certain to restore my old presets. But ultimately I am going to have to write some software to generate xmp files that meet my needs. But it seems the syntax does not allow for ISO specific camera profiles; THAT is the major problem!!!!!!