Skip to main content
Adobe Photoshop Family

2 Messages

 • 

92 Points

Wed, Jun 24, 2015 6:53 PM

Solved

Flickr Export Plugin in Lightroom 6 ignores "Remove Person Info" setting and exports person keywords like regular keywords

When exporting photos to Flickr using the built-in export plugin, the "Remove Person Info" setting is ignored and the person keywords are exported anyway. This is a serious and unexpected information disclosure.

Regular export and other export plugins like JF Collection Publisher work fine and honour the "Remove Person Info" setting as expected.

The only workaround i found is editing the keyword itself is mark it as "no export" in the keyword tag settings, which is impractical as I want to be able to include person infos on other exports.

Responses

Official Solution

Employee

 • 

475 Messages

 • 

10.7K Points

5 years ago

This is fixed in Lightroom 6.2, which is available today.

Thanks,
Ben

Champion

 • 

5.3K Messages

 • 

95.7K Points

5 years ago

Interesting, happens to me too.

As a workaround, did you trie Friedl's Flickr plugin? He actively maintains it and is very responsive. (A fix to the Adobe plugin will take months at a minimum, if at all.)

2 Messages

 • 

92 Points

I tried migrating to Jeffrey's plugin but despite the many nice features, it is mostly unusable for me because I can not import the old Set/Collection mappings :-(

Champion

 • 

5.3K Messages

 • 

95.7K Points

5 years ago

Some more info on this bug: I used Friedl's Run Any Command to insert a post-process action in the Flickr publish service that saves away a copy of the exported file. That copy has all the person keywords removed. This suggests that the Flickr plugin is mistakenly uploading a wrong version of the file.

Champion

 • 

5.3K Messages

 • 

95.7K Points

5 years ago

See this bug report for a related bug I just discovered: http://feedback.photoshop.com/photosh.... This bug is not causing the the Flickr problem, since that problem occurs regardless of the setting of Write Keywords As Lightroom Hierarchy.

9 Messages

 • 

184 Points

5 years ago

Bug has not been fixed in 6.1.1

Employee

 • 

475 Messages

 • 

10.7K Points

5 years ago

Thanks Philipp, I am able to reproduce this problem, and I have reported it to the Lightroom engineers.

Thanks,
Ben

Champion

 • 

5.3K Messages

 • 

95.7K Points

5 years ago

The release notes for LR CC 2015.2 say this is fixed: http://blogs.adobe.com/lightroomjourn...

5 Messages

 • 

124 Points

2 years ago

I'm still seeing this bug in Lightroom 6.14. Removed "Include on Export" from individual keywords, but that didn't help.  Then enabled "Write Keywords as Lightroom Hierarchy" in Flickr plugin settings and that seemed to fix it.