Skip to main content
Adobe Photoshop Family

294 Messages

 • 

4.5K Points

Thu, Sep 20, 2018 9:53 PM

Failure to import jpgs when tifs are present

Upon executing the Import command in Lightroom Classic CC 7.5 runnongon a MacPro with Sierra, a folder with 58 tif files and 58 jpg files—which are exactly the same save for the file extension—only results in an import of the tif files.  The jpgs are left out.

When a given tiffile is deleted, then and only then is the jpg imported.

What is going on?

I have routinely since LR 3 imported both the raw files with the jpgs and have both imported in the catalog.  Now, in 7.5, the jpegs are ignored if the requisite tiff exists.

Responses

Champion

 • 

5.8K Messages

 • 

102.2K Points

2 years ago

Go to Preferences > General and make sure "Treat JPEG files next to raw files as separate photos" is checked. I suspect it's considering the TIFFs as raw files.

294 Messages

 • 

4.5K Points

2 years ago

Thanks, Victoria!

I have always kept that setting checked as I like to see my jpegs next to my raw files (and dngs if I create them).  However, the upgrade to 7.5 might have changed that setting as it did for 'keep presets with catalog'—the upgrade unchecked that setting to great annoyance.

Next time I start up LR I'll check to confirm.  Funny thing is, I did an import of Sony raw files (.arw) and jpegs right after the upgrade and everything imported, so if the setting is checked, we might have an issue with tiff raw files which I never released in previous versions.

(Yeah, I have an old Olympus medical imaging microscopy camera which produces tiffs as it raw file format; however this was the first time I have used it since the upgrade.)

Champion

 • 

5.1K Messages

 • 

92.5K Points

2 years ago

I just verified that my LR 7.5 continues to treat a companion JPEG as a sidecar of a TIFF:



And that checking "Treat JPEG files next to raw files as separate photos" disables that behavior.

This has been LR's behavior for many years, so it does sound like the option may have gotten unchecked in your preferences somehow.

294 Messages

 • 

4.5K Points

Victoria and John are correct; the 'Treat JPEG files next to raw files as separate photos' was NOT checked.

Clearly, as I always had this setting checked, the upgrade process from LR ^ to LR 7.5 reset this setting, just as it did to "Store presets with catalog" setting.  Annoying.  A sloppy upgrade process indeed.

Champion

 • 

5.8K Messages

 • 

102.2K Points

That sounds like the preferences got corrupted somewhere along the line.

294 Messages

 • 

4.5K Points

Could be, but after reviewing all of the settings in my preferences, I found that only these two were changed.  I'm thinking it was a deliberate reset decision made by a developer.  I say this because a corrupted preferences would have created more havoc, methinks.

It's not unheard of to have such issues (decisions made by a team member) escape the development team lead.  Here's another example.  The Canon 1D X, their top-of-the-line professional camera, will, upon performing a factory reset in the field, default to saving only jpegs and not raw files.

No raw files created in the Number A-1 camera in the Canon line!  Idiotic!  I discovered this 'feature' whilst in a heliocopter flying over the Nambian desert, having the camera lockup while banging away at 12 fps at a herd of Gemsbok.  As we swung around for another pass, I reset the camera.  I felt there was a problem right away as the previews were coming in just too damn fast for high-res raw files and high-res jpegs (which I always shoot).

Lo and behold, the camera reset left off the raw files.  Had to manually set that preference and shoot again.

Canon fixed that issue with the 1D x Mk II.  It only proves that a team is only as strong as it's weakest team member.  I think someone at Adobe botched this, but I would like to hear if others have seen this issue when upgrading from LR6 to LR 7.5.  Upgrading earlier might not have revealed this; it might be a new bug.