roger_luo_g9dyf87whfjmj's profile

1 Message

 • 

70 Points

Mon, Oct 28, 2019 3:10 AM

Aperture import stuck at 0%

I upgraded to Mac OS X Catalina and then tried to import my photos/videos from Aperture using Lightroom classic's built-in plug-in. The import progress shows 0% but never progresses even after 20 hours. I have about 400GBs of stuff in Aperture which can no longer be used under Catalina. Please help! 

Responses

4 Messages

 • 

110 Points

2 y ago

Hi Roger Luo,
Sorry for the inconvenience. Will you please provide more information such as
What is the LightRoom version that you are using?
Are you able to import any other Aperture library or is it happening with one library only?
This information will help us find out more about the issue.

Thanks,
Akhilesh HM

174 Messages

 • 

3K Points

2 y ago

Akhilesh, does the LR plugin to migrate from an Aperture Library need Aperture to run in the background? If yes, well, Aperture is no longer supported on macOS from Catalina. This is why Apple recommended that users migrate from Aperture to their chosen alternative (in this case Lightroom) BEFORE upgrading to Catalina: https://support.apple.com/en-us/HT209594

Roger: Hope you find a solution soon. If Adobe doesn't come back with a recommendation, maybe you can check out this article to see if the open source solution it mentions can help you (as it at least allows you to run Aperture, albeit temporarily, in Catalina): https://petapixel.com/2019/10/29/this-app-lets-you-use-apples-aperture-photo-editor-on-macos-catalin...

Otherwise, you might need to downgrade from Catalina back to Mojave (or whatever you had before), restore from backup, and migrate from Aperture to LR in the previous OS version. But wait til Adobe responds.

NOTE: I haven't upgraded to Catalina, so haven't tested any of my recommendations: if you follow any advice given here, you're assuming full responsibility for any risks. So, ensure you have a proper backup before trying anything.

[The lesson here is: ALWAYS read everything provided by the manufacturers of your operating system and critical applications to check what needs to be done BEFORE upgrading your OS. If possible, wait until after the first major patch of any new OS is released (to allow vendors to learn about issues that may only be discovered when users install the new OS version, and release fixes for them). Don't rush the upgrade process...]

4 Messages

 • 

110 Points

2 y ago

@Edmund Gall 
No, Aperture need not be running/installed to import Aperture Library. Also, we have tested that importing the Aperture library in LightRoom on Catalina works just fine.
May be answers to the aforementioned question would help us understand more about why is it happening.

Thanks,
Akhilesh HM