Skip to main content
Adobe Photoshop Family

27 Messages

 • 

3.4K Points

Fri, Jan 13, 2012 1:12 PM

Closed

Revel: Adobe Revel has stopped downloading originals

I have uploaded a large library of photos from a variety of computers and now on my main computer (which wasn't used for any of the uploads) I have ticked the box to "Keep originals" in order to download a copy of each photo to enable me to back up my library.

Problem is that after initially downloading around 1500 pictures, the download appears to have hung (With 17657 photos still to download) and it hasn't downloaded any more photos for more than 24 hours now.

I have tried re-booting and reinstalling the software to no avail. My internet connection is on an unlimited bandwidth deal and I can download at full speed from other websites so it can't be a bandwidth cap or any other internet related issue.

Can anyone help me understand what is going on?

I would be prepared to completely uninstall the software to start again from scratch but deleting the application and the main library file clearly doesn't delete all the data as it still remembers my login details and other standing data.

Are there any instructions for a total uninstall?

Thanks for your help.

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

806 Messages

 • 

14.7K Points

9 years ago

Hi Steve,

I'm trying to reproduce the issue, but I can't so far. I will keep at it. Meanwhile, could you answer a couple questions that might steer us towards properly validating your issue?

-- Did you install Revel 1.1 from the app store, or update from Carousel 1.0.3?
-- Is your net connection Ethernet or WiFi?
-- what version of OS X do you run?

I saw from another thread that you've already tried uninstalling and reinstalling the app. Deleting the app and associated Revel library file in /Pictures may not be sufficient to clean your prior session off the machine. To completely remove Adobe Revel off you mac, here's a list of items to clean:

/Applications/Adobe Revel.app
~/Pictures/Adobe Revel Library.cr
~/Library/Caches/com.adobe.Carousel.mac
~/Library/Containers/com.adobe.Carousel.mac
~/Library/Preferences/com.adobe.Carousel.mac.plist
~/Library/Preferences/com.adobe.Carousel.mac.plist.lockfile

After cleaning your machine, and reinstalling Revel, you can "Keep Originals" to sync back down files already uploaded to the cloud.

10 Messages

 • 

356 Points

i did the following however could not find any of the library files, where are these? and just by uninstalling and installing it and deleting the library it did not work to your point :( I really love the idea of Revel however would love to get this issue resolved as I have a lot more pictures that I would like to add soon.

27 Messages

 • 

3.4K Points

Michel
The library files you are looking for can be found in the Library folder under your personal user directory (ie not in the system library). Are you using OSX Lion? If you cannot see a library folder under your user directory you will need to unhide system files - Lion hides them by default. To do this follow the instructions here: http://www.mikesel.info/show-hidden-f...
Steve Ratcliffe

10 Messages

 • 

356 Points

Thanks Steve, I will try this out.

10 Messages

 • 

356 Points

ok i did the steps to see the library and it seems to have worked however I am still not able to find the library files, if this ok/normal?

10 Messages

 • 

356 Points

ok finally found them after I search for library, but searching for com.adobe.carousel of anytime was not finding anything.

27 Messages

 • 

3.4K Points

9 years ago

Hi Charlie,

Thanks for your help here. I appreciate it.

To Answer your questions:
1) I originally installed Revel as an update from Carousel 1.0.3 but since you posted full uninstall details I have now done a fresh install. It didn't resolve my issue though.
2) Net connection is Ethernet on my iMac
3) OSX Lion 10.7.2 (11C74)

Ok - I was hoping that a full uninstall / reinstall would have solved the issue but my Download of originals has hung again and in almost exactly the same place as before (this time with 17638 photos still to go). My internet connection is absolutely fine and connection status in Revel is Green (Connected) - I can be sure that Revel isn't receiving any data by monitoring the connection to my iMac from my router. I can still upload new photos to the cloud from my iMac and other computers/iOS devices on my account but if I do I won't be able to "Keep originals" which is a problem.

The only conclusion I can draw is that there must be one (or more) photos in my Library in the cloud which Revel doesn't like and won't let me download for some reason. Does this make any sense to you? Presumably if it encounters a corrupted photo it should really timeout and go onto the next one but this doesn't seem to be happening in my case.

I could delete the offending photo(s) from my library if only I knew which one it was! Is there any way of finding out (maybe a logfile or something) what Revel is doing and where it is up to in the download process? Is there any diagnostic data on my account available from your end?

If you have any other suggestions I'd be grateful to hear them.

Thanks,

Steve Ratcliffe

27 Messages

 • 

3.4K Points

9 years ago

Charlie,

Not sure if this is relevant but I have another mac (Which I used for most of the uploads so the Carousel Library file was already quite big). I thought for safety I would tick the "Keep originals" box on this macbook as well as the iMac I am having problems with and the download has completed successfully. I don't think this proves anything really as, if the problem is caused by a corrupt photo and it was uploaded from this machine, the cause of the problem was already in the Carousel Library so didn't need to be downloaded again.

Just thought this might be useful background.

Thanks again for your help.

Steve Ratcliffe

806 Messages

 • 

14.7K Points

9 years ago

Hi Steve

I appreciate your efforts and all the additional detail. Since I still can not reproduce the problem, I can only venture guesses. I'm logging a bug for a developer to take a closer look. May we contact you directly for more info?

It shouldn't matter that one specific asset may be corrupt, but it's something I'll look into further.

Also, having more than one desktop client which is syncing images (up and down) should be fine.

27 Messages

 • 

3.4K Points

9 years ago

Hi Charlie,

Happy to be contacted directly for more info.
If I can't get the sync to work with my iMac, that is going to cause me a major issue. The macbook on which the sync has worked has a small hard disk and as I can't move the library to Network storage because the software doesn't allow it, it's absolutely full now. I really wanted to delete the Library from my laptop which was why I was synching the iMac.

Can I raise an official support ticket for further help (it isn't obvious how to do this for Revel on the Adobe website)? Is it possible it is something I've done or a setup issue with my iMac?

Thanks

Steve

806 Messages

 • 

14.7K Points

9 years ago

Another question, suggested by a team mate as a possible explanation for why this machine behaves differently than your other machine...

How much available disk space do you have? Revel needs sufficient space to deposit all the incoming Original photos. Trying to put 12 GBs of photos into 10GB of free disk space won't work. We're supposed to pop up a message about this condition though -- I'm checking to ensure that's working correctly. The message should pop soon after Revel realizes your current import or sync will exceed disk space. With 17657 images, Revel could already have downloaded lots of pictures before it realizes the total size of the Sync effort won't fit.

27 Messages

 • 

3.4K Points

9 years ago

Charlie,

I have 950GB available free space on the iMac's 1TB disk so I don't think that can be the issue. On the macbook where the download of originals has completed, the size of the Adobe Revel Library.cr file is 38.32GB but on the iMac it is just 25.9MB

One weird thing though I noticed that the size of the library file on the iMac didn't seem to increase even during the successful download of the first 1500 or so images. That made no sense to me at the time.

Thanks

Steve

806 Messages

 • 

14.7K Points

9 years ago

Hi photolord

On my home connection, I just finished uploading over 18,000 images. My upstream connection isn't the fastest out there, so it took a while (almost a couple days). But on a Macbook Pro with a config like yours, and the 1.1 client now available from the App Store, my upload didn't stall. So I'd like to ask more about your config, hoping new clues can clarify what causing trouble for you.

Are you using an antivirus program?

If you have a firewall in place, can you describe it? Software or hardware? I'm using only the basic hardware firewall included in my home router, with no special ports open.

Did you change anything about your system like your machine name?

Are you able to upload better from another location (home, work, local coffee shop, etc?)

1 Message

 • 

70 Points

No antivirus program
No firewall that I know of.
I did not change the name of the machine
AT&T internet
Motorola Modem
Cisco Linkskys E1000 Wireless Router
I have not tried uploading from another location with my laptop other my house.
I am able to upload with my iphone fine using the same WIFI connection.

806 Messages

 • 

14.7K Points

Hi Photolord, and change in behavior for you? If you're trying only with WiFi, can you also try plugging in your Macbook Pro directly with a network cable?

27 Messages

 • 

3.4K Points

9 years ago

Hi Charlie,

I have emailed you with the answers to your questions so I don't have to post data on a public forum.

Suffice it to say for anyone else's benefit that the mac I'm having problems with is a late 2011 iMac and is pretty much as it came from the factory. I am also using the firewall which is built into my home router. My system name hasn't changed. I haven't been able to try the Desktop anywhere other than at home so I can't answer that question. I don't have the same issue with my macbook pro anyway but that behaves itself at home and in my office.

Thanks,

Steve

806 Messages

 • 

14.7K Points

9 years ago

Hi Michel

The long story short is yes, it would be best to start over with importing and I recommend doing this in a new carousel.

Here's why: if you delete the current app before your images complete upload, then the cloud thinks you'll continue uploading them at some point. When you uninstall and reinstall the app using your same account, trying to import the same photos will tell you they're duplicates and block them from being imported even though they're not completely uploaded yet. The cloud will wait for you to finish uploading the images from what it thinks is your other device (even though it is your same Mac/iPhone/iPad). The result is some photos will never finish uploading, and will be stuck on Uploading Originals in the Status view. We're looking into how we can improve this in the future.

To workaround the issue with the current app, I recommend these steps:
1) Be sure your originals exist outside of Revel. If they do not, use Export Originals on Mac to get your images out of Revel.
2) Follow the instructions in the thread above to clean Carousel / Revel off your Mac or device.
3. Reinstall Revel.
4. Sign into your account, and delete your current carousel or carousels which have blocked uploads.
5. Create new carousel(s) to replace what you just deleted.
6. Import your photos again.

With these steps, Revel 1.1 should be able to upload all your photos.

806 Messages

 • 

14.7K Points

9 years ago

Hi Michel

There is not yet an indicator for how many images are already uploaded to a carousel. I spoke with the Product Manager about this just earlier this week, and we know this is something we want to add to an upcoming release.

806 Messages

 • 

14.7K Points

9 years ago

Our next release coming out soon should fix issues reported for both upload, and download of originals. Please stay tuned!

806 Messages

 • 

14.7K Points

9 years ago

Hi John, auto-import is only supported on iOS (iPhone, iPad) at this time. I agree, this would be a nice thing to have, with settings to watch iPhoto or one's Pictures folder. I'll ping the team about it.

6 Messages

 • 

120 Points

9 years ago

Hi everybody and thanks for this Topic.
Some monthes ago about 2 or 3 I ahd no problems with uploading to revel. Since I had to delete my carousels, the news ones created stop upload and I've tried all your process of suppress an re-install of revel but still I have the problems of upload blocked...

some good news please?????? because I 've paid for using revel about 50€ and at this moment I canno't use it.

many thanks for your answer

806 Messages

 • 

14.7K Points

9 years ago

We're working on an update to be released soon that should improve import and upload of large batches of images.

Blue, I just replied to you separate post with some questions. You mentioned a chance in behavior, so I'm curious if other things are happening with your account. Please see my separate message to you.