Skip to main content
Adobe Photoshop Family

21 Messages

 • 

484 Points

Fri, Aug 3, 2012 2:07 AM

Lightroom 4: No support for tethered capture Canon 5D III

I am a pro photographer and I use tethered shooting to my laptop computer all the time. I am frustrated that Lightroom 4.1 does not support my Canon 5D III. Please add support for this camera. Thank you

Responses

43 Messages

 • 

482 Points

8 years ago

Lightroom stinks and is not a professional level product. Switch to Aperture or Capture One if you want a professional level product for Canon cameras.

1 Message

 • 

62 Points

8 years ago

I know it's way more than 3 people who have this problem; it's just such a pain to even find this page that fewer have registered. When will this be resolved? When I bought my Mk3, I updated to LR4. I'm now wishing I had bought Aperture instead.