Skip to main content
Adobe Photoshop Family

2 Messages

 • 

110 Points

Fri, Oct 17, 2014 6:56 AM

Closed

Elements 12 Freezes when using Brushes on MacOS 10.10

Photoshop Elements V. 12 keeps freezing when I try and use brushes – any brush, even the default ones. I just downloaded the new Yosemite software for my Mac, so it might be compatibility issues too.

This conversation has been merged. Please refer the main conversation:

Responses

2 Messages

 • 

70 Points

6 years ago

I have the same problem

2 Messages

 • 

70 Points

6 years ago

Started right after Yosemite was installed. I wonder if upgrade to 13 would fix it?

3 Messages

 • 

90 Points

6 years ago

Ugh me too! Same, just updated to Yosemite

13 Messages

 • 

290 Points

6 years ago

Ditto. I reported this in another topic, but was brushed off by the moderator.

I still have PSE10 installed and that seemed to work.

13 Messages

 • 

290 Points

6 years ago

See

http://feedback.photoshop.com/photosh...

Adobe has known about this for months but has ignored it.

15.1K Messages

 • 

195.8K Points

Did you report the problem to Apple, so Apple could investigate and fix the issue in the OS?

13 Messages

 • 

290 Points

Yes. Being a professional software engineer for 25 years now, I'm used to reporting interactions like this to both parties so they can work together.

3 Messages

 • 

90 Points

6 years ago

Great. that seems helpful. I only updated to Yosemite because my PSE12 was shutting down every time i tried to save anything and no one from Adobe would help me fix that either.

13 Messages

 • 

290 Points

6 years ago

I just got a comment on the Apple forums that PSE13 appears to work fine with 10.10.

72 Messages

 • 

1.2K Points

6 years ago

Hi All,

Please try using mouse instead of track pad and see if your issue is resolved.
Just to add, PSE 13 works fine on Yosemite.

Thanks!!