george_fielding's profile

10 Messages

 • 

170 Points

Fri, Dec 21, 2018 3:21 PM

Photoshop: Lens correction not imported from Lightroom

Since updating to the latest version of photoshop i've found that the lens correction applied in lightroom is not carried through to photoshop when i edit the image there.

Previously if i select an image in lightroom, right click> edit in photoshop, it carries across all of the adjustments INCLUDING lens corrections. Now when i edit images in photoshop the lens correction isn't applied. The really annoying thing is that when i import the edited image back into lightroom and try applying a lens correction again, it seems to get confused and the resulting image doesn't look like the unedited image (with correction applied!)


Is anyone else having this issue? I spoke to customer service and they said that the lens correction setting was removed for the latest version of photoshop... is there a work round?

Responses

Champion

 • 

3.7K Messages

 • 

61.1K Points

3 y ago

Customer service obviously talks rubbish. Of course it was not removed. Are you using Windows or Mac? I haven’t noticed this on my Mac. There is a bug in Windows that manifests itself when you start Photoshop by sending an image from Lightroom. Lots of things go wrong then, maybe this is one of them. The solution is to start Photoshop manually first. Or check the ‘Disable Home Screen’ checkbox in the Photoshop preferences.

380 Messages

 • 

6.7K Points

3 y ago

I tried this without Photoshop launched and with Photoshop already running. In both cases, the lens correction was applied as expected, but in the first case, most Ps menu items were disabled because I have the Home Screen preference enabled.

It is surprising, and disappointing, that the Photoshop bug when opening from Lr to an unlaunched Ps that causes the menus to be disabled when the Home Screen option is enabled has not been fixed in the latest updates!


10 Messages

 • 

170 Points

3 y ago

OK So i've tried it with photoshop running, and opening photoshop from lightroom and the problem persists!
What's even more strange is that, while all of my lenses lose their correction in photoshop, SOME of my lenses seem to be able to have the correct profile correction added again in lightroom, while others (mostly wide angles) have a seemingly different profile added which distorts more than it solves!

On the plus side, disable home screen seems to have fixed the issue with setting greyed out!

2 Messages

 • 

90 Points

2 y ago

I am having the same problem! Ever figure it out? Lens corrections not transferring. See video attached.

3 Messages

 • 

82 Points

2 y ago

Hi, after a few edits last night, I noticed a problem....

 I've just noticed tonight that my TIFF file when edited in PS doesn't reflect the full settings when I use CNTRL-E command in LR. Its clearly missing the correct color profile and lens correction in a side by side comparison.

 After a few tests I can see LR is completely ignoring any of my "Camera Colour profiles" ( while working in LR, they all come out exactly the same color when using the TIFF in PS). 

 Also, the available lens profiles for (my)  Canon lenses do not make any changes in the TIFF(while different in LR, they all look the same/raw etc when using the TIFF in PS). Using the 24-105L II, with a 5D4. Other develop settings appear to be used and applied to TIFF correctly.


NOTE: Adobe Color Profiles are being transferred through to TIFF in PS correctly. And manual distortion/vignetting is being transferred through to TIFF in PS correctly.

( currently LR 8.2.1, Camera Raw 11.2.1, Win 7)


Is this something that will require more CR2 files copied over as mentioned 3 months ago, or do you have enough data from the earlier posts?


Cheers,

graeme