Skip to main content
Adobe Photoshop Family

5 Messages

 • 

100 Points

Tue, Oct 29, 2019 3:46 PM

Solved

Photoshop fails saving files sent from Lightroom - Edits are lost

While working on an NEF (Nikon) RAW image in Lightroom Classic (Creative Cloud):
- Select "Edit In Photoshop" or "Open as Layers in Photoshop"
- Make edits in Photoshop
- Click "Save" to send edits back to Lightroom

Photoshop's Save Progress will make it to 94%-97% then stop.

PhotoShop does not freeze, I can continue to make edits.

However, the edits are not saved:

  • Edits are not sent back to Lightroom and 
  • I'm not able to save as a standalone file because an error message indicating "the document is currently being saved in the background. Please try the operation again after the save has been completed."
But the save never completes, even waiting overnight. All that can be done is to force close PhotoShop and all edits are lost.

This started after updating to Catalina (may or may not be any correlation)

Any thoughts or ideas?

Thanks.

---

Specs:
  • MacBookPro13,3
  • Quad-Core Intel Core i7, 2.9 GHz
  • RAM: 16 GB

PhotoShop: 20.0.7

Lightroom: 8.4.1

Camera Raw: 11.4.1

Responses

151 Messages

 • 

1.9K Points

a year ago

On your MAC, bring up System Preferences, select Security and Privacy. Select the Privacy tab, on the left select Files and Folders. Make sure Photoshop (and Lightroom Classic) have rights to all files and folders

799 Messages

 • 

11.5K Points

That may be related, and it’s good to check, but it’s not the “I can’t import” issue that many are experiencing which is fixed by the Security & Privacy Pref.

5 Messages

 • 

100 Points

Hi @David, Thanks for the idea. I checked and all adobe apps have proper rights to access files & folders.

799 Messages

 • 

11.5K Points

a year ago

Totally related to Catalina! Not sure exactly why, but start by eliminating OS “cruft” as an issue by running Onyx. Onyx is at (https://www.titanium-software.fr/en/o...), select the Onyx version for your Catalina, download, run it, reboot.

In Onyx run almost everything in the Maintenance tab, deselecting things you may not want deleted, like Launch Services . Hit the "Options" button and deselect more stuff like Cookies & Other Site Data, Browser History, Form Values, etc. that you DON’T want deleted. If you don’t know what something is, google it, or don’t run it, or ask me), then hit Run Tasks. After it's done it will ask for a reboot.

5 Messages

 • 

100 Points

Hi @Carlos, I installed and ran Onyx. I have no idea what it did exactly, but it fixed the problem. Thanks for the help.

799 Messages

 • 

11.5K Points

My pleasure Colin! Happy Mac'ing (and shooting)!

Adobe Administrator

 • 

8.2K Messages

 • 

118.3K Points

a year ago

I tested on my end Colin with the same versions installed and the save happened no problem and the results (with edits) appeared back in Lightroom. 

When you send a file to Photoshop is it being sent as a PSD or a Tiff?

Have you attempted to reset Photoshop's preferences?
 

Adobe Photography Products

Quality Engineering - Customer Advocacy

5 Messages

 • 

100 Points

Hi Rikk, thanks for the reply. 

I took @Carlos' advice and installed an app called Onyx that resets many of the Mac OS settings/parameters. After doing this & restarting the computer, the problem resolved itself.

I'm afraid I do not know which setting may have been the one to fix the issue.

FWIW, for my setup, Photoshop sends the edits back to Lightroom as a TIFF.

Thanks again.

5 Messages

 • 

100 Points

a year ago

Hi Rikk, thanks for the reply. 

I took @Carlos' advice and install an app call Onyx that resets many of the Mac OS settings/parameters. After doing this, the problem resolved itself.

I'm afraid I do not know which setting may have been the on to fix the issue.

FWIW, Photoshop sends the edits back as a TIFF.

Thanks again.