Skip to main content
Adobe Photoshop Family

7 Messages

 • 

140 Points

Mon, Apr 22, 2019 1:03 PM

Answered

Lightroom: Panorama Merge Stuck at 100%

I have a set of pictures to be stitched to a panorama. I have taken each shot in 3 different exposures, so I have a total of 18 pictures. I first tried the HDR Panorama Merge on these 18 RAW photos, but the process was taking too long. So I did HDR Merge on each of the 6 different shots and from these 6 HDR images, I planned to do a Panorama Merge. However, when the progress bar is always stuck at 100% on Gathering Data, not giving me the preview.

I have tried restarting Lightroom and my desktop but to no avail. I am using iMac (Late-2015). macOS Mojave, Processor 2.8GHz Intel Core i5, 8GB 1867 MHz DDR3.

Not to mention my iMac lags significantly while Lightroom is open. I usually have Google Chrome, Spotify and WhatsApp running in the background but to my knowledge, these are not heavy on processes.

Responses

Adobe Administrator

 • 

9.2K Messages

 • 

127.8K Points

2 years ago

Please go to Help>System Info... in Lightroom and get us your current installed version number please. 
Adobe Photography Products

Quality Engineering - Customer Advocacy

7 Messages

 • 

140 Points

Lightroom CC version: 2.2.1 [ 20190312-1546-e438717 ] (Mar 13 2019)

Adobe Administrator

 • 

9.2K Messages

 • 

127.8K Points

Thanks Pek,

When you did the joint HDR/Pano Merge, you said it was 'taking so long' that you tried the other. Would it ever actually complete if you left it alone?
Adobe Photography Products

Quality Engineering - Customer Advocacy

7 Messages

 • 

140 Points

I left it alone for 2 hours, stuck at Gathering Data 100%

Adobe Administrator

 • 

9.2K Messages

 • 

127.8K Points

Ok.  If I read this correctly, HDR works, Pano fails (using HDR Results), HDR/Pano Fails.

What happens if you take the 6 normal exposures and don't worry about HDR for now. Will those stitch into a Pano?
Adobe Photography Products

Quality Engineering - Customer Advocacy

7 Messages

 • 

140 Points

Yes, it does work, although taking 1 hour to merge. Is that normal?

Adobe Administrator

 • 

9.2K Messages

 • 

127.8K Points

What is the Camera used here?
Adobe Photography Products

Quality Engineering - Customer Advocacy

7 Messages

 • 

140 Points

Canon EOS 80D with EF-S 18-135mm f/3.5-5.6 IS USM kit lens

Adobe Administrator

 • 

9.2K Messages

 • 

127.8K Points

Given your specs, I would expect a time less than two minutes for a merge of 3 Canon 80D files. 

What is the free space on your drive?
Adobe Photography Products

Quality Engineering - Customer Advocacy

7 Messages

 • 

140 Points

My cloud drive doesn't have free space now

Adobe Administrator

 • 

9.2K Messages

 • 

127.8K Points

That may be the issue.  Can you free up some space on that drive?
Adobe Photography Products

Quality Engineering - Customer Advocacy

1 Message

 • 

60 Points

I have a same issue but the C drive space gets full ie 228GB it says about some catalog issues

Adobe Administrator

 • 

15.8K Messages

 • 

295K Points

2 years ago

Does this happen with all sets of panoramas, or only this set? If it's set specific, can you post a link to your set of files for us to troubleshoot with?

Sr. Product Manager, Adobe Digital Imaging

7 Messages

 • 

140 Points

Not just this set. I'm also not able to get the link because Lightroom CC is taking forever to generate the URL for me

13 Messages

 • 

242 Points

2 years ago

I have the same issue with version 2.3. It was merging fine when my library was ~100 pictures, but now when I uploaded the rest of ~4000 images it stopped working.
In my case it is stuck on "Gathering Data... 100%".

Adobe Administrator

 • 

9.2K Messages

 • 

127.8K Points

2 years ago

I am sorry to hear that the 2.3 update didn't fix the issue for you. At this point, we would need to get a few sample files from you that fail so that we can test with your files. Are you willing to share files with us?
Adobe Photography Products

Quality Engineering - Customer Advocacy

13 Messages

 • 

242 Points

I'm OK to share files with you, no problem.

https://www.dropbox.com/s/quh770y1uzffsm8/Lightroom%20bug.zip?dl=0
https://www.dropbox.com/s/fefg5zvdbtyn0vm/Lightroom%20HDR%20bug.zip?dl=0

Separate issue is that Lightroom CC fails to merge HDR panorama. Lightroom CC Classic has no problems merging both.

I posted same images in other thread https://feedback.photoshop.com/photoshop_family/topics/hdr-merge-getting-stuck-at-100.

But like I said, panorama has stopped working for ALL images, even for those that were working before I made library bigger. When I had like 100 images it was fine. Now I have few thousands and it's stuck.

Adobe Administrator

 • 

9.2K Messages

 • 

127.8K Points

Kirill, 

I tested with your files (thank you for those) using Lightroom Desktop 2.3.  I was able to successfully merge an HDR, a Pano and an HDR/Pano from your files with no issues.

I would recommend you reset your preference file and try again.  If that doesn't cure it you may want to do a clean install of the App. 

Preference File reset:

A Preference File will survive a Lightroom uninstall/reinstall. Sometimes weird behavior is corrected/cured by resetting the preferences. 

Reset Procedure:

1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom. 
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.

Does the behavior continue after resetting the preferences?

Clean Install:

Close Lightroom
Restart the computer
Use the Adobe Creative Cloud App to uninstall Lightroom
Restart the computer
Install Lightroom  via the Creative Cloud App without launching any other programs.
Restart the computer
Launch Lightroom
Wait 5 minutes

I am going to post these same instructions into your other thread.
Adobe Photography Products

Quality Engineering - Customer Advocacy

13 Messages

 • 

242 Points

I have tried both options, it did not help. And as you see, it's not just my problem.

Adobe Administrator

 • 

9.2K Messages

 • 

127.8K Points

Are you by chance clicking on a collapsed stack of images instead of group of individual images?
Adobe Photography Products

Quality Engineering - Customer Advocacy

13 Messages

 • 

242 Points

I am :) holy hell, it works when I selected individual photos!!! Moreover, when I expanded the stack and selected all photos in it and made a panorama it went well too. That's a bummer... not intuitive at all...

13 Messages

 • 

242 Points

Rikk, may I ask you to also take a look at this issue: https://feedback.photoshop.com/photoshop_family/topics/no-star-rating-in-filmstrip-of-lightroom-cc-2-3, I don't know how to mention you there. Seems you are the guy who can assist with it )

Adobe Administrator

 • 

9.2K Messages

 • 

127.8K Points

2 years ago

I spoke to the engineer regarding stacks and we are looking into that behavior. For now: expand the stack and then click on the individual images. 
Adobe Photography Products

Quality Engineering - Customer Advocacy

13 Messages

 • 

242 Points

Yes, so far this workaround is okay.