Skip to main content
Adobe Photoshop Family

32 Messages

 • 

554 Points

Mon, Dec 18, 2017 8:04 PM

Closed

Lens correction for Olympus micro four third

It seems like that none of the Olympus lenses are supported regarding optical correction. At least I do not see them in the lists and also switching the correction on or off has no impact on the photo. This is dissapointing, because Olympus is one of the well known brands. It is especially an issue because I like to shoot in RAW. With JPEG, the camera will perform the correction. So I get stuck because of this. So, please Adobe add the corrections to Lightroom cc!

This conversation has been merged. Please refer the main conversation:

Responses

67 Messages

 • 

1.4K Points

3 years ago

Isn't that because lens correction is built in with the RAW files from Olympus micro four third camera? There may be a little info balloon telling you lens correction is built in.

Champion

 • 

5.8K Messages

 • 

102.5K Points

3 years ago

Yep, Arnold's spot on. They're built in and automatically applied. That's true of all micro-four thirds (I'm an Olympus shooter myself) and a number of other compact/mirrorless cameras too.

2 Messages

 • 

76 Points

3 years ago

But, shooting with my Olympus M. Zuiko Pro lens (12 - 40mm f/2.8) I do NOT see that a profile correction has been applied.  Instead the Lens Correction box in LR CC Classic tells me that no lens profile was found.  Does that mean the the lens is not supported?  Or are the corrections being properly made but the message is wrong?  Thanks for any comment.

Champion

 • 

483 Messages

 • 

8.9K Points

No, the 12-40 lens IS supported, but like most lens profiles it only applies to raw files. If the image you're looking at is a Jpeg, then yes you will see the message "Unable to locate a matching profile automatically" if you attempt to "Enable Profile Corrections". With a raw file, however, there is no need to enable the profile corrections as the LC panel should report "Built-in Lens Profile applied".

So check the file type you're working with, and let us know if you're still seeing a different behaviour to this.

2 Messages

 • 

76 Points

Hmmm.  I just bought the camera and lens two days ago.  i thought I had it set to take RAW + JPEG, but ... I bet you're already ahead of me ...  I didn't.  Thanks so much, Jim.  You explained my concern and helped me correct a huge setup mistake!!