Skip to main content
Adobe Photoshop Family

4 Messages

 • 

342 Points

Mon, Oct 31, 2011 6:36 PM

Solved

Premiere Elements: PRE10 can't open PRE9 project: Error. [d:\pre\mediacore\mediafoundation\api\inc\Keyframe\Keyframe.h-142]

PRE10 can no longer open a project created in PRE9 and edited and rendered in PRE10, giving this error:

PRE has encountered an error.
[d:\pre\mediacore\mediafoundation\api\inc\Keyframe\Keyframe.h-142]

If you click on "Continue" (the only option), it comes up with "The project could not be loaded, it may be damaged or contain outdated elements."

1. The first error is one BIG FAIL, for there is no such folder on my drive and should not be hard-coded into an application to begin with.

2. If the project is damaged, why not tell me WHERE exactly it may be damaged or WHICH are the outdated elements. If I look at the XML source, it looks just fine.

3. What NOW other than recreating the project? PRE9 cannot open it either, so something's f***ed.

Over to Adobe....

Responses

4 Messages

 • 

342 Points

9 years ago

PS: The auto-saved projects also no longer open in PRE9 or 10.

71 Messages

 • 

1.1K Points

9 years ago

For the issue that ends up in a corrupt project, please do the following:
1. Download perl from http://www.activestate.com/activeperl...
2. Open cmd prompt
3. Run this command from there
perl -p -e "s/([-0-9]+?),([0-9]{12,24})/$1.$2/g" damaged.prel >working.prel
4. Please specify the path for the prel files that cause the issue in place of the text “damaged.prel”
5. Reopen the project and let me know how it goes.

Regards,
Satish

6 Messages

 • 

112 Points

This is not the solution for all project files this problem is not solved yet. (See my comment for the next post).

3 Messages

 • 

80 Points

9 years ago

Exact command with paths should go like

perl -p -e "s/([-0-9]+?),([0-9]{12,24})/$1.$2/g" C\Users\...\Desktop\AVCHD.prel >C\Users\...\Desktop\AVCHD_working.prel

6 Messages

 • 

112 Points

This does not solve the problem with my file at all. I used the perl statement above to correct my file, BUT THE ERROR STILL OCCURS, just later.

My file opens, if I replace ";" by "," in the <Keyframes> lines with the following command:
HANDLE WITH CARE
perl -p -e "s/([-0-9]+?)\.([0-9]{12,24});([0-9]{15})/$1.$2,$3/g" damaged.prel >working.prel
HANDLE WITH CARE

The thing is, that I don't know if replacing ";" by "," characters breaks anything in the project. But at least the file opens. I would really like to send you my project file, so you might find a solution solving the file opening.

4 Messages

 • 

342 Points

9 years ago

I have used Windows 7 to use a restore point copy, which then opened the project just fine. As it was just one change, there was no real loss.

That said, thank you, Satish and Mohammad, for your help. I will keep this handy, should it occur again.

Kind regards,
Helmar

1 Message

 • 

60 Points

9 years ago

I wrote corect path and it said its wrong.
I was testing on diffrent files in diffrent locations.

Adobe Elements 10, Windows 7 64BIT

6 Messages

 • 

112 Points

9 years ago

Opening a project file results in the following Error when loading the project file: d:\pre\mediacore\mediafoundation\api\inc\Keyframe/Keyframe.h-142

After this, opening is cancelled.

This error occured in PRE 10. The file was initally created using PRE 9 and was opened successfully a few times in PRE 10. Later the error occured.

There exists a knowledge base article (see http://kb2.adobe.com/cps/925/cpsid_92..., which does not solve the problem: The error just pops up later when opening the file.

This reply was created from a merged topic originally titled
Error when loading the project file: d:\pre\mediacore\mediafoundation\api\inc\Keyframe/Keyframe.h-142.

9 Messages

 • 

162 Points

9 years ago

I have a crash with error:... keyframe/keyframe.h-142. I not a computer expert. What shall I do to slove the problem???

This reply was created from a merged topic originally titled
Premiere Elements: crash with error: keyframe.h-142.

9 Messages

 • 

162 Points

9 years ago

I'm not sure what the experts recommends? The solution to use a se-store point seems must promising?? Do you have an Idea?

2 Messages

 • 

72 Points

9 years ago

Dear Sir / Madam,

Onlangd I purchased premiere elements 10, but rather it gives problems.
Saved projects are no longer open with the following error occurs:

"Premiere Elements has encountered an error.

[d:\pre\mediacore\mediafoundation\api\inc\Keyframe/Keyframe.h-142]

CONTINUE
--------------

And in the next window:

-------------

Project could no be loaded. It's damaged oder has old elements

Because of this I have lost several projects. On the Internet, the problem appears to occur more frequently.
After contacting adobe I send you this message since it allows Premiere Elements is not workable.
Like to hear from you solve this problem.

Sincerely,
marianne

This reply was created from a merged topic originally titled
premiere elements 10 error [d:\pre\mediacore\mediafoundation\api\inc\Keyframe/Keyframe.h-142].

217 Messages

 • 

4.3K Points

9 years ago

Hi Marianne,

Please try the solution here to see if it resolves the issue

Keyframe.h-142 error | Opening projects | Adobe Premiere Elements
http://kb2.adobe.com/cps/925/cpsid_92...

-Dave

2 Messages

 • 

72 Points

9 years ago

Hi Dave,

Thank you very much the problem is resolved. This is the definitive solution to this problem or can go out more often and there will be a fix?

Regards Marianne

9 Messages

 • 

162 Points

9 years ago

I Cant make it work. Give me some more precise instructions. I would like to add an PDF file, but thats impossible.
Regards
Kim

6 Messages

 • 

112 Points

9 years ago

Hello,

can someone please help me. The knowledge base article solution does not repair my file. I still cannot open it. The same error message occurs, but only later.

Regards
Jens.

217 Messages

 • 

4.3K Points

9 years ago

Kim/Jens,

You might try opening the project in the older version of Premiere Elements that created it if you still have it installed. Also, if you have backups of the project, test opening them as well. Beyond that, might be best to contact our technical support department for assistance.

-Dave

6 Messages

 • 

112 Points

9 years ago

Hello David,

the project from PRE 9 could be initially loaded with PRE 10 successfully. Then I used PRE 10 to work on the project and all was fine. But when I opened the project later (now saved with PRE 10) the error above occured.

At this point I cannot open the project in PRE 9 anymore because this does not recognize the new file format. I also cannot open the project with PRE 10.

Fixing the file is my only option because I cannot open it, but as stated, the fix above does not help. I need to have another option to fix the file (it's about 2 hours of family video and needs to be ready at christmas as a gift).

Regards,
Jens.