Photoshop: Keyboard shortcuts not working (CS6)

They work fine most of the time, then randomly they wont. It's only the single key shortcuts. (B for brush, Bracket keys, etc.)

*** Recently upgraded to CS6, never had the problem on 5.5***
17 people have
this problem
+1
Reply
next » « previous
  • I have been having similar issues for a couple of PS versions now. I am on an iMac OSX 10.9.1 now and its also been as far back and OSX 10.5 that I can remember. I have to hit key commands 2-3 times before they register. It is very annoying and time consuming... Any help would be greatly appreciated
    • view 1 more comment
    • I am not using a tablet, keyboard is the Apple Keyboard that came with the iMac, and its a usb one not wireless. I am using a logitech bluetooth mouse though, but I was having the problem in 10.8 as well...maybe its the logitech mouse?
    • It could be the mouse, or more specifically, the software that comes with the mouse. Look under your System Preferences and check out the utilities that come with your mouse. It's been my experience that these usually intercept certain combos to help users, but that interferes with many applications' use of such key-combos. I would disable everything to see if that solves the problem. From there, you can re-enable individual options to see what triggers the breakage. I would be very curious to hear of your results.

      Thanks and good luck,
      David
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited

  • I've noticed that my anti-virus/anti-malware software may be the culprit. When I exclude Photoshop.exe from being monitored, Photoshop becomes responsive to keyboard shortcuts again.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited

  • I cannot find anything as far as logitech software in system preferences, after all I am on mac and all I did when I bought the mouse was plug it in and it worked... when I go to the mouse tab under system preferences it only has the few options to change mouse speed and double click speed
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited

  • I installed the logitech software for mac and still have the issue... I would love if we could find a fix for this, as it is super time consuming and annoying and for the price of the adobe software it should work seamlessly....
    • view 11 more comments
    • Ok...I am available right now if you are...
    • After working with Nate, it appears that the culprit was his MagicMenus sidecar app. Once we turned off the shortcuts (found under Preferences, final tab), not only did the problem go away, but Photoshop in generally seemed to speed up a little.

      David
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited

  • A plug-in to work around this issue is available at bit.ly/NzQly1 this plug-in works with both CS6 and CC.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited

  • I’m happy
    Hi
    I found another solution to this problem, since I noticed that [ on a Mac is "Alt + Shift + (" and "Alt + Shift" is turning my cursor into a color sampler and the plugin didn't work for me.
    I changed the keyboard shortcuts for brush size to é and è instead of [ and ] since I'm on a Azerty keyboard. You might want to change that to some other unused keys
    and now my Wacom can control my brush size again
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited

  • 1
    there seems to be a conflict with Safari or Chrome.. shut these down first and see if it works then
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited

  • In System Preferences change your keyboard type. Even though I'm using an Apple keyboard (chiclet style) neither my 2011 mbp or 2014 imac can recognize the older style of chiclet keyboard.

    Go and manually tell it you're using an ANSI keyboard (the default is, for some reason Japanese) and all of the sudden your shortcuts will work.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited

next » « previous