This topic was merged into another on Mon, 14 Jan 2013 20:54:21 +0000 Click here to see the authoritative topic.
Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Lightroom: LR4.2 Performance Issues remain

The performance issue is an absolute workflow killer and I am at the point where I want to throw my 2009 MacPro tower out the window. LR4.2 has not improved matters whatsoever. I spend more time waiting for module switches and image adjustments to take effect than actually editing images. There were similar issues with the upgrade from LR2 -> LR3 but not to this degree.
Please, please stop adding new features, functionalities, and/or window dressing – get back to the basics and focus on making a functional product for your user base.
35 people have
this problem
+1
Reply
  • A large majority of users are not seeing what you describe (user forums are notoriously self-selecting.

    For example, slow module changes is something very specific that is not commonly mentioned. There will be a slight pause the /first/ time a module is enabled/loaded, but subsequent module switches should be pretty quick. This implies there is something else at play here.

    Are you able to reproduce these problems with a test catalogue opened from a test account?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Understood and thank you for your time/consideration. This has been a longstanding problem on my system and has not been resolved by any of the version updates or release candidates. Am running a mac pro with 2 2.8ghz quad core Xeon and 10gb of RAM on Lion 10.7.5. 4 internal HD and a 10TB DROBO connected via eSATA. 3 of the internals are on a RAID5 via Apple RAID card.

    Internal RAID5: OS and Apps
    Internal HD: LR catalog and Cache
    External RAID: Image Catalog

    The following performance issues have been longstanding and severe (these are just a few of them/most annoying):

    1. Incredibly slow module changes and between images in the Develop module. Change can take more than 60sec on occasion.
    2. Adjustment lags. Slider adjustment effect is laggy
    3. Export time. Takes up to 2 min to export a file for editing in external software (command-control-E)
    4. Sorting/Rating. Rating adjustments do not show for 5-10 seconds after staring.

    Please let me know how to set up a test catalog/account.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Clearly LR is unusable on your system. If everything worked correctly, then spreading things out would be optimal, but since everything is not working correctly, then to determine what might be causing pathological slowness, try to reduce the number of devices and system components LR interacts with to as small as possible, and move that footprint between devices to see if some are faster than others.

    This means temporarily unplug everything external that is not needed to run LR--the external drives and any other devices like scanners and calibrators and perhaps even network connections and printers and tablets and whatever else, leaving only a mouse if possible.

    Then create a new LR catalog on one of the two external drives, put a few test images there, designate that drive for the cache but a different location than the current cache, and see if things are better. Then delete all that, and create a new catalog and copy new test images and configured the cache to the new location, and test over there. The DROBO and External RAID should be detached during this period.

    Depending on those results, you can then delete those test components and attach the external RAID and try with a test environment over there.

    It might be necessary to actually uninstall LR and re-install it to another location as part of the testing, but that's probably not something to try during the initial experiments.

    Besides the various external devices, problems with iffy memory chips, or having hyper-threading and associated core-parking enabled, have caused slowdowns for some people. Ambient light monitoring with a hardware calibrator has slowed some people down. Multiple large monitors can be a problem, so unplugging a second or third monitor can help diagnose the problem.

    Adobe relies on Apple-supplied system functions and Apple relies on third-party-supplied drivers for various devices, so there could be unexpected interactions between some of those components that are causing issues, that Adobe, Apple or a device manufacturer might never see, except in a rare combination of circumstances that happen to exist with your computer.

    You haven't indicated whether Activity Monitor shows the CPU being overused, or hardly used, during the periods of slowness. This could be a hint as to what is happening. An overused CPU can be caused by a normally accelerated function being emulated by software cause it to be many times slower. A hardly-used CPU can indicate there is either slow I/O happening, somewhere, or some normally-efficient system function that is failing and timing out after an extended period before the error is detected and the fallback action is being taken.

    Short of boxing up your system and sending it to Adobe and have them experiment with it, directly, there isn't alot Adobe can do, unless they happen to find problems on other systems they do have access to and fix them, and the next version is fast for you, again.
    • Nicely said Steve. The only thing I would add is:

      If hardware disconnects and other such stuff don't help to clear up the issues, consider unplugging everything "internal" as well, which isn't essential (i.e. software services and processes...), since system-dependent problems can also be hardware-independent.

      Cheers,
      Rob
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m so so sad
    I've been using LR4 now for a week and it's painfully slow with almost every function (raw or jpg). I've searched some user groups and have done all the suggestions found to be relevant but to no avail. Still slow. If there's no fix I'd prefer to go back to LR3 which was fantastic. Can I get a refund if that happens?
    Equip=late 2009 iMac 3.06ghz Intel core 2 duo, 4gb 1067 ram, ATI Radeon HD 4670 256 MB, OS 10.7.5.

    This reply was created from a merged topic originally titled
    Vey Slow LR4.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m a lot
    Since installing the Lightroom 4.2 update, Lightroom has become very slow for me in several areas:

    1. I created a smart collection that has "pick flag is unflagged" as one of its criteria. When I press the x key to change the flag status on an item, in LR4.1 the item immediately disappeared from the collection. It felt almost instantaneous.

    Since the upgrade to 4.2 it can take anywhere from a second to 20 seconds for the item to disappear. This makes it impossible to productively work with more than just a few items.

    2. Today I imported several 8GB and 4GB cards into my library over the course of a project, and every import seemed to be slower than the last one, up to the point where importing 4GB of pictures took 30 minutes.

    Restarting Lightroom seems to speed things up a bit for a while. The issues return though.

    I am very frustrated with this drop in performance, everything was good in 4.1 - it pretty much killed my productivity and made me look very unprofessional in front of my client, while we've been staring at the screen, waiting for things to happen.

    I would understand if this was a major version jump, but all I see in the release notes are bug fixes and support for new cameras. Nothing that I think warrants such a negative change in performance.

    At this point I'd prefer to downgrade back to 4.1 - how do I do that?

    This reply was created from a merged topic originally titled
    Lightroom 4.2 is massively slower than 4.1 in several areas.
    • view 2 more comments
    • Just install 4.1 and use your 4.1 catalogue copy the upgrade to 4.2 should have left behind.

      As for your problems:

      1. This sounds like database contention. Have you tried optimizing the catalog?

      2. Are you importing raw images? What sort of previews are you making on import? Are you writing changes to XMP?

      You don't say what platform you are on.
    • Update: I've finally ploughed through the job (with the performance issues), back in the studio, did everything that was recommended, including setting up a new catalog, optimising the old one (several times), made sure OS and everything was up-to-date (everything was), made sure there were no preview renders going on (there weren't), made sure LR wasn't writing XMPs automatically, increased the raw cache size from 10GB to 50GB (does that even make sense on a catalog that holds less than 5000 pictures?!)

      The end result: LR4.2 is now performing at acceptable speed. I have NO idea which of the above steps made the difference and at this point I don't have the time to do deeper analysis (neither should I have to).

      The whole story leaves a really bad taste with me. I love Lightroom, it enables me to do things I couldn't do before, but why should the point update from 4.1 to 4.2 require the customer to go on a week-long search for a solution to a problem that wasn't existent on the same system with the same catalog before the update.

      Adobe either didn't finish testing 4.2 before it was released, or the beta tester base was too small, or Adobe's quality standards have dramatically changed in the last months. Whatever the reason may be, I already dread 4.3 and hope I won't have to go through anything remotely similar when it's released.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Does anybody know if Adobe are even trying to find a fix for the disastrously slow performance of Lightroom 4 ?

    I have spent hours on the phone to them but have given up talking to them as although they are aware of the problem they can't offer a solution.

    Slow rendering of RAW files in "Develop" is causing me eye strain and hours of extra time at the computer after each shoot waiting for each image to focus / render.

    Every image takes 10- 12 secs to focus before you can edit, and that also means you cannot switch between images to select a preferred one as the process is so slow that by the time the new one is in focus you can't remember what the previous one looked like! Hopeless.

    I am using Lightroom 4.2

    I'm using a 27" iMac 8GB RAM. Nikon D700 and D800

    And I'd REALLY like to know about any fix, present or future. Thanks.

    This reply was created from a merged topic originally titled
    Lightroom 4 is so slow that it is almost unusable on a high spec iMac shooting on a Nikon D800.
    • Please read Mr. Sprengel's comment, above. It contains a lot of useful information.

      You need to work from the known to the unknown to solve the problem that is almost certainly specific to your setup.

      This thread has few common complaints, unfortunately.

      There is a long article else-thread that deals with some of the very common things that solve many similar problems for others. Have you tried them? For example, given that you are seeing issues with develop rendering have you tried recreating the raw cache, and resizing it appropriately? Is the raw cache on a fast partition separate from the main catalog?

      These are the specific sorts of things that can make a real difference, but we don't know which ones you tried.

      Focus on specific aspects, and simplify, simplify, simplify. Try with a test account with a few images and work your way from there.

      If you are using a Mac, getting a series of "samples" from the Lightroom process would be useful, as well.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Hi John.
    I have increased the cache size to 5GB.
    What do you mean by recreating the raw cache?
    I create a new catalogue for each photo shoot.
    Thanks
    • |> "What do you mean by recreating the raw cache?"

      Delete it's contents, using OS, or purge-cache function in Lr preferences - they both do the same thing.

      Note: A properly functioning cache doesn't help (a normally functioning) Lr go much faster, *but* an improperly functioning cache might make it go a lot slower, e.g. if there is wonky data in the cache files due to some previous bug or whatever.

      Cache used to benefit from being huge, but Lr4 cache files are much smaller than Lr3. If the cache isn't filling up, then it's plenty big.

      PS - My cache is set to 50GB (way overkill) but only has 2GB in it. 5GB should be plenty for Lr4 (after clearing old/big Lr3 entries out I mean).
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Well, thank you Rob!

    Purging the cache has helped. It has speeded things up, I wouldn't call it quick now, but it has certainly helped.

    I've got a feeling that I may well have purged the cache before whilst on the phone to Adobe technical support, at the same time as increasing the cache size to 20 GB (not 5 GB as I previously thought).

    Can the cache be purged at any time? How often? During editing a shoot?

    Using my Nikon D800 in Raw produces images of about 55 MB. On a shoot I can easily shoot 1,500 - 2000 images on both cameras, D700 (much smaller files, about 10MB) and D800.

    Is creating a new catalogue for each shoot a good idea (The man at Adobe thought it was, and is something I have always done since Lightroom first came out)?

    Are there any other tips such as purging the cache that might improve things further?

    Thanks again.
    • (Re-)purging the cache shouldn't help significantly. If it does, then Lr is being funny with your cache (and I don't mean funny ha-ha).

      I'd be curious to know whether it makes things better or worse to just disable the cache altogether (purge your cache, then using your OS, make the cache folder non-writable). It should make it a tiny bit slower, but in your case, if you are having cache problems, it may make it faster. eh?

      But to answer your question, theoretically yes: it can be purged at any time, but I wouldn't do it while it's rendering photos for develop or creating previews (which also creates cache entries).

      PS - Personally, I wouldn't create separate catalogs for each shoot unless you really need to, or you'll "never" go back to those photos again afterward anyway... - but that's a personal thing... - if it ain't broke don't fix it...

      Note: how much improvement you can get speed-wise depends on how normally Lr is functioning. If no funny-business is going on, then you can get improvement by following Adobe's performance guidelines and getting faster computer, but if your performance is abnormal due to wonkiness, all bets are off...

      PS - I created EditInLightroom to help D800 (and similar) users have faster editing sessions when doing high-volume shoots: works better when original raws have been converted to DNG, but supports proprietary raw formats too.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m frustrated
    i have 32 gb of memory and 32 core in 2 processors. i am using amd opteron processors, windows 7 64 bit. lightroom is up to date.
    i have imported a small number of raw photos from a canon mark 2 - about 2000 photos. when i try to view the pictures to grade them, i can see the first 10 or so as quickly as i want, but after that, lightroom starts slowing down and saying "Loading...". The number that i can see quickly varies. Ihave set the preview to 1:1, have optimized my catalog several times.
    This is a very fast computer with the c drive split across 2 SSDs. the 1 tb drive I am using to hold the photos is not an ssd drive. it is about half empty. Because of the way my computer was set up, some user data is not on the c drive where adobe expects it and apparently this prevents adobe bridge and photoshop from running unless i run as admin, but this does not seem to be an issue for lightroom.

    This reply was created from a merged topic originally titled
    lightroom 4.2 is slow.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • This is from another thread on LR 4.2 performance problems. I'm posting here to hopefully help some others.

    Problem: LR 4.2 is so slow that it is unusable

    I'm running Windows 7 64-bit with the 64-bit version of LR. I have a quad core processor with 8GB physical memory on the machine.

    Last week, I downloaded and applied the Lightroom 4.2 update (Lightroom_4_LS11_win_4_2). Previously I was running 4.1. Since the update, Lightroom's performance became so sluggish as to be nearly unusable.

    Pretty much everything about 4.2 was sluggish -- from import to library scrolling to switching between pictures in development mode to editing. I tried splitting projects up into separate LR projects to get the total number of pictures down. This did not help. I was editing a project with 35 RAW images. (Note: I used to edit projects with over 300 pictures in 4.1 and had acceptable performance.) When I looking at one picture in development mode and then clicking on another, it took a while (over a minute) for the new picture to display fully.

    Solution: catalog optimization and cache tuning

    I optimized the catalog (File->Optimize catalog), then I purged the cache and increased the cache size to 5GB (Edit->Preferences, FileHandling tab, Video Cache Settings at bottom). Lightroom seems to be running *much* faster now.

    I should note that my cache size was set to 2GB. From what I've read, this seems to be an unacceptable cache size for either LR 3 or 4, so I'm not sure how it was running acceptably before. None the less, performance is excellent now.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I appear to have resolved my problem, which was that i could not view sets of pictures quickly. i had thought that i had 1:1 previews set, but it appears that there is no default preference of this kind. instead, you either select pics already imported, - library-previews-render 1:1 or while importing you make sure that you click on the file handling panel - render previews-1:1. the rendering process for more than a few pictures is very long but at least it is something that could be done overnight or unattended. i also wonder what would happen to a very large catalog in terms of how much space is eaten up (previews for 1300 pics is 3.12 gb) , but at any rate my problem is resolved apparently. the various articles on optimization were helpful in figuring this out.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m frustrated
    Morning all. I have LR4.1 and love it. Well, want to love it. It is so much better than 3 at developing, making books, etc etc.

    But oh my giddy aunt it is SO SLOOOOW* :-(

    Running Win7 on i3 with 8Gb RAM, 1080p LED 2ndary monitor. Not the best setup in the world, granted, but LR3 flew on it. LR4 is like going back 5 years in time.

    I assumed you were working on fixing this, but when I saw your response to speed complaints for the 4.2RC that "no-one is complaining about speed" I realised I needed to make a profile, log in, and let you know. Please oh please fix the performance issues.

    The weird thing is that CS6 runs way faster than CS3 did, on the same hardware. LR4, h3ll no.

    LR4 is lightyears (haha) ahead of LR3 in terms of features and what the pics look like coming out of there. But. it. is. so. slow.

    Andy

    * Main speed issues are:
    - going to and from Develop module from grid view. I get a black bar at the top of the screen, so I go make coffee and wait for it to come right.
    - the preview pane top left takes so long to update when hovering over a preset that I don't bother to use it any more
    - during use, everything just slows down (memory leak?) so I reset my machine every tea or coffee break to keep the performance going. Never had to do this with LR3.

    This reply was created from a merged topic originally titled
    LR4.2 not addressing performance? Oh noes!.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Andy, my problem sounded similar to yours, only I saw it going from LR 4.1 to 4.2. Have you tried what I did above? Just a few simple things and I got my performance back.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m thoroughly fed up and considering Capture One
    OMG I agree it is SOOO SLOW. I am also on the point of throwing out my 2009 Mac Pro 2 x Quad Core Intel box with SSD and 24Gb after spending 4 days doing a job that would usually take me 1.5 days and 2 weeks on a job that should have taken 4 days. Click and wait, click and wait. I'm finding I can't even add a star rating instantaneously. Spent a couple of hours with Adobe on chat and went though all the settings (which were already exactly as recommended). The only suggestion they came up with was to read a document helpfully aimed at LR3 (which I had already been over) and to create a new profile. Having already rebuilt my Mac I was sceptical but eventually did it anyway but to no avail; I couldn't even open the catalogues, let alone work on them.

    I think LR has always been a bit slow, but I used to put this down to having a very large catalog. I'm currently using just one catalog per project though - largely defeating the value of LR - in an effort to pick up speed, but this project has only 1200 images in it and is still so slow I'm losing the will to live.

    I'm having similar problems with PS CS6. I recently subscribed to the Cloud, but cant imagine that has anything to do with it. If it weren't for the fact that my Mac seems OK with non-Adobe apps I'd blame the hardware, but it's fine.

    I've tried all of the following advice gleaned from forums and Adobe: optimised catalogs; purged cache; set large cache size (it's 80Gb); closed all other apps whilst in LR (which with a machine of this spec I should not have to do); ensure latest version of O/S, ensured HDD and permissions all OK, rendered 1:1 previews before working on a set of pics... NONE of it has made any difference. Uf anyone has any further ideas I'd be happy to hear them!

    Meanwhile I agree with another comment; come on Adobe, sort out the fundamentals before adding more bells and whistles.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m very frustrated
    I've patched my LR 4.1RC2 to 4.2. When 4.2 frist starts, the speed is acceptable (switching screens, doing edits),

    however, as i continue to use it, it starts to slow down, occasionally going back to have half of preview window blacking out (as it did in the 4.0).

    Even leaving 4.2 running, (not editing or switching between lib and dev) seems to cause it to slow down. Is there a background task running that's going rogue and leaking memory?

    when this happens, LR very often displays "unknown error occurred" and that's my queue to exit LR and restart.

    this is frustrating. i'll try to optimize the catalog and purge the cache.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m frustrated
    I love lightroom, I have been using it since version 3 came out and I have to say that the new features in version 4 was an excellent upgrade. It posed a real competition for Apple Aperture 3 and even Capture One pro 6. I generally love Adobe products and I got to praise them for the excellent software they have produced. It is to my regret to say that I have not have all the best working with the new release of Lightroom. I have found myself being less productive than ever before. Lightroom 4.2 has caused some serious slowdowns on my windows pc. It was just last night after optimizing the LR catalog that I had to spend an entire 1-1/2 hours editing one photo, which this photo could have taken me 15 mins have lightroom not slowed down on me. I am completely frustrated with lightroom. This is not the first time I have encountered a major slowdown with the program. I have made up my mind that if Adobe refuse to fix this slowdown with the software I am switching to Capture One Pro. I have never gotten any from of lag using Capture One. I think it is more time efficient to edit in Photoshop than lightroom, however it is not the most convenient way form me to go as a Photographer editing hundreds of photos in a week!!

    This reply was created from a merged topic originally titled
    Major Slowdown with Lightroom's Workflow.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • ALR 4.2 comes VEEEERY SLLLLLOOOOOOWWWW :(
    (compares 3.x)
    It's impossible to work with many photos with normal speed.
    All optimisations was done - not hepled: ALR still laggy on each main operations.

    Core i7 2.6GHz 4cores 16G RAM Win7x64 SSD for cashe SATA for RAW
    Canon 5D mk3 CR2
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m really fed up
    Lightroom v slow - examples:

    Pic 1
    shows the delay in waiting for 2 same-sized images to display (using Survey shortcut 'N'). It takes around 2-3 secs for the small image to display at the same size as the big one.



    Pic 2
    Shows delay in rendering several images the same size in Survey. On background is the first pic, the rest have all been selected and displayed using 'N' but there is an even longer delay while all images render to same size and line themselves up.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Windows 7 and even more so in Windows 8 has the most extensive performance and data metric gathering ability than any OS. If Adobe is serious about this issue then they should be gathering this data from users on the slow systems.

    ETW tracing metrics can be gather from Windows 7/8 from users in an admin prompt. More tech savy users can start the .cmd file that enabled the metric tracing Adobe needs to review. Customer does his "slow bit", then stops the tracing.

    Adobe collects this from the user, and analyzes it, if needed with the help of Microsoft developer support.

    Who knows, this seemingly random systems impacted could be video driver "profiles" that both AMD and NVidia use. Some "feature" in the driver could be in conflict. Can't tell unless that informant is gathered and tossed in to the matrix pool for correlation.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • At this time, I am experimenting with video card profile settings (NVidia Control Panel).

    Main focus is to see if "Threaded Optimization [Auto | off | on]" has an effect with how LR drives video updates to the screen.

    I think lag time is power optimization, where the GPU clocks down to save power/heat. I turned this off so the GPU run at full speed and so does memory.

    Another thing to do is (for windows), "Control Panel->Power Options" Select "High Performance", this will turn off slowing the CPU. It will run at 100% all the time.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m very frustrated
    BTW: LR 4.3 did not change anything for me.

    I have excluded Folders from spotlight (Adobe-Cache, Folder with LR-Database and Preview-Database, all Folders holding the RAWs). That brought back some speed in the Library-Mode. Scrolling thru thumbnails and skipping thru fullscreen-photos ('e') is a bit faster now (but still slower than LR3 or LR2)

    Developing a picture in LR 4.2 or 4.3 is a pain. Now it easily takes 30+ Minutes where it were about 5-10 Minutes with LR3. Moving a slider results in waiting a few seconds to see a result. It's impossible to work on a real shooting with some hundreds or thousands photos :(

    Sure, my old iMac (running OS-X 10.7) is not the fastest but the difference between LR2/LR3 and LR4 is not acceptable. I can see this slowdown on my MacBookPro (running OS-X 10.8) too. (using RAW-Files from my Canon 5D mk1)
    Currently i really consider switching back to LR3 when i have the next shooting, because no one pays me for waiting for Lightroom and i only have so much time to finish editing pictures.

    On the other hand, a twitter-follower shows me his LR 4.3-Performance which was simply stunning. Changes in developing-module were nearly instant. He has a SDD with the Lightroom-cataloge on it (RAWs on a HDD).

    But now, please don't tell us, the solution is to use SSD... What does a SDD has to do with the performance in the develop-module? If the problem is, that LR has to write back tons of data back to the database, than THIS has to be optimized - not the drive this catalogue is on.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m frustrated
    LR4 was dog slow to start with; it always under performed LR3. I wasted money on this upgrade because it cannot be used. I have been creating new catalogues for every job which make no difference. The LR3 engine out performs LR4 even when I switch to LR3 within LR4. Adobe, you need to give LR4 users a free LR5 upgrade or fix this version and stop saying that the majority of users do not experience this problem. LR3 works and LR4 doesn’t, plain and simple, MAC & PC users alike.
    • You're clearly frustrated, but it would help to know exactly WHAT you're finding slow. The new Develop controls are doing significantly more complex calculations than the old ones, so some areas (preview rendering, exports, etc.) will always be slower than LR3. So understanding what you're finding slow will help to determine whether it's expected behaviour or whether you're seeing something else entirely.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated